Subject: Re: [Tools-discuss] IEEE in bibxml2 vs. bibxml6

From: Carsten Bormann <[email-masked]>
Date: Fri, 15 Feb 2019 15:28:17 +0100

At some point I’d like to have a rational solution for the below.
Copying the IEEE cobwebs from bibxml2 to bibxml6 would solve the problem (I.e., allow me to look up IEEE in bibxml6 as opposed to bibxml2 as of now).  As would creating a bibxml.IEEE or some such from both directories and keeping them in sync.

Grüße, Carsten

> On Mar 15, 2017, at 08:36, Carsten Bormann <[email-masked]> wrote:
> 
> There are IEEE citation files both in bibxml2 and bibxml6.
> Is there a way to automatically decide with one to use?
> Could the bibxml2 files maybe be copied over to bibxml6 so we can always use bibxml6 for IEEE?
> 
> (kramdown-rfc currently uses bibxml2 for IEEE; there is currently no easy way to access bibxml6.  I can’t switch that over to bibxml6, as the bibxml2 references are in use in existing documents, e.g. for IEEE 754.  Why are we even doing this splitting up?  90 % of the files are in bibxml3 anyway.)
> 
> Grüße, Carsten
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 27 Feb 2019 14:34:01 +0100

Hi Carsten,

Sorry for the delay in responding to this.

On 2019-02-15 15:28, Carsten Bormann wrote:
> Copying the IEEE cobwebs from bibxml2 to bibxml6 would solve the
> problem (I.e., allow me to look up IEEE in bibxml6 as opposed to
> bibxml2 as of now). As would creating a bibxml.IEEE or some such from
> both directories and keeping them in sync.

I don't know why the split exist.  It looks as if the bibxml2 IEEE items
haven't been updated since 2013, bibxml6 since 2015.  I have a dim
recollection of looking into that some years ago, and discovering that
the web resource used to populate one of these had stopped being
maintained.

In the long run, rather than trying to patch up the old TCL scripts,
I would prefer to build new bibxml generation infrastructure on
www.ietf.org or datatracker.ietf.org.

For now, I'll happily copy the bibxml2 IEEE entries to bibxml6.

Shall I do so?

Best regards,

	Henrik

> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 Feb 2019 14:38:26 +0100

> For now, I'll happily copy the bibxml2 IEEE entries to bibxml6.

Please do, assuming there are no conflicts.
Then I’ll switch to bibxml6 for IEEE.* references in the next version of kramdown-rfc.

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 27 Feb 2019 14:45:43 +0100

> Then I’ll switch to bibxml6 for IEEE.* references in the next version of kramdown-rfc.

Ok, done.

Best,
	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 Feb 2019 15:53:23 +0100

Kramdown-rfc2629 version 1.2.11 now searches bibxml6 for IEEE.* references such as:

  IEEE.754.1985:

There should be no user-visible change for IEEE.* references that already worked.
But new ones should now be working: those that have been added to bibxml6, but not to bibxml2.  See for yourself:

http://xml2rfc.tools.ietf.org/public/rfc/bibxml6/

As always, update via

	gem update kramdown-rfc2629

(add a sudo if needed on your platform), or simply `gem update` to update all rubygems.

Grüße, Carsten

> On Feb 27, 2019, at 14:45, Henrik Levkowetz <[email-masked]> wrote:
> 
>