Subject: [Tools-discuss] New tool: Using Emacs Org Mode for writing RFCs

From: Russ Housley <[email-masked]>
Date: Mon, 4 Mar 2019 18:36:32 -0500

FYI

> From: Christian Hopps <[email-masked]>
> Subject: New tool: Using Emacs Org Mode for writing RFCs
> Date: March 4, 2019 at 6:19:20 PM EST
> To: "ietf\@ietf.org" <[email-masked]>
> 
> 
> Check it out: https://github.com/choppsv1/org-rfc-export
> 
> If you are an Emacs user, especially one who is familiar with/uses Org Mode, I think you'll like this.
> 
> I've been working on an org mode exporter for writing RFCs. As it's now in MELPA (package: ox-rfc) I figured it was a good time to announce it's availability. Basically you write your RFC in Org Mode and export it to XML. The back-end supports exporting to XML (for manual xml2rfc), but also supports exporting to text, HTML, or PDF, including directly into a buffer for easy previewing.
> 
> Highlights:
> - Powerful Org Mode
> - Simple Citations/References.
> - Lists (Numbered, Unnumbered)
> - Definition Lists (term + definition)
> - Tables
> - Embedded Code (Literate Programming e.g., embed yang model, trees, examples)
> 
> In particular YANG embedding is pretty neat. There's no need for separate files and tree generation (and example validation) can be automated from the embedded text.
> 
> Check out the README and the examples (currently in the ert-tests directory).
> 
> Thanks,
> Chris.

---

From: Richard Barnes <[email-masked]>
Date: Mon, 4 Mar 2019 22:24:24 -0500

Is there a brief answer to the question of what advantage this has over
Markdown, which has its own Emacs mode?

https://jblevins.org/projects/markdown-mode/

On Mon, Mar 4, 2019 at 6:36 PM Russ Housley <[email-masked]> wrote:

> FYI
>
> *From: *Christian Hopps <[email-masked]>
> *Subject: **New tool: Using Emacs Org Mode for writing RFCs*
> *Date: *March 4, 2019 at 6:19:20 PM EST
> *To: *"ietf\@ietf.org" <[email-masked]>
>
>
> I've been working on an org mode exporter for writing RFCs. As it's now in
> MELPA (package: ox-rfc) I figured it was a good time to announce it's
> availability. Basically you write your RFC in Org Mode and export it to
> XML. The back-end supports exporting to XML (for manual xml2rfc), but also
> supports exporting to text, HTML, or PDF, including directly into a buffer
> for easy previewing.
>
> Highlights:
> - Powerful Org Mode
> In particular YANG embedding is pretty neat. There's no need for separate
> files and tree generation (and example validation) can be automated from
> the embedded text.
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>