Subject: [Tools-discuss] Draft name prefixes

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Apr 2019 09:58:38 +1000

Hi all,

Could we add a link to <https://www.ietf.org/standards/ids/guidelines/> to the top of <https://datatracker.ietf.org/submit/>? Or maybe <https://www.ietf.org/standards/ids/>.

I think this would help new authors who aren't aware of those resources.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 09 Apr 2019 22:47:45 -0400

Maybe with an "If this is your first Internet-Draft submission" around it.

There is a lot of noise on that page.  I wonder if it makes sense to cut that down to the bare essentials.  New submitters don't need to know about the API, for example.  There is an "Instructions" "tab".

On Wed, Apr 10, 2019, at 10:05, Mark Nottingham wrote:
> Hi all,
> 
> Could we add a link to <https://www.ietf.org/standards/ids/guidelines/> 
> to the top of <https://datatracker.ietf.org/submit/>? Or maybe 
> <https://www.ietf.org/standards/ids/>.
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Thu, 11 Apr 2019 13:08:39 -0400

On Tue 2019-04-09 22:47:45 -0400, Martin Thomson wrote:
> There is a lot of noise on that page.  I wonder if it makes sense to
> cut that down to the bare essentials.  New submitters don't need to
> know about the API, for example.  There is an "Instructions" "tab".

It's almost as if that page was written as though it were an RFC :P It
appears to think of itself as a reference, not a tutorial or a howto.

Fwiw, i agree with Martin that taking a vicious editor's knife to that
and figuring out the most important stuff in a much simpler and shorter
document would make it more useful to a first-timer audience.  (doesn't
mean there's no place for a reference, of course).

I also note that https://www.ietf.org/standards/ids/guidelines/#6 says:

    It is strongly recommended that the draft include a notice (with
    email address) of where comments should be sent. For example:

    "Comments are solicited and should be addressed to the working
    group's mailing list at ___@______ and/or the author(s)."

And yet, it's not clear how to send edits to this 9-year-old document
itself (it could use at least some http→https fixes in 2019).

         --dkg

---

From: Russ Housley <[email-masked]>
Date: Tue, 16 Apr 2019 15:07:40 -0400

> On Apr 11, 2019, at 1:08 PM, Daniel Kahn Gillmor <[email-masked]> wrote:
> 

The Tools Team might be able to offer some improvements to the web page, but the id-guideline belong to the IESG.  The Tools Team cannot take any actions there.

Russ