Subject: [Tools-discuss] Looking for a clue

From: Fred Baker <[email-masked]>
Date: Wed, 10 Apr 2019 15:21:39 -0700

I have had a problem with XMLMind on my laptop, and spent some time with Warren on that this morning. It turned out that I needed to reinstall the application from scratch. Now I have a different problem.

When I go to xml2rfc.ietf.org to try to compile the XML output, it tells me that it is

Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml6:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml7:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml8

However, I have historically had a copy of the library on my computer, and in my .bash_profile have

export PATH=~/bin:$PATH
set XML_LIBRARY=/Users/fred/In-Progress/XML_Library

Historically, it has used the library on my laptop. Anyone have an idea why it might be different now? Why would the tool override the configuration that I have been using since xml2rfc was created?

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 17 Apr 2019 15:23:29 +0200

Hi Fred,

On 2019-04-11 00:21, Fred Baker wrote:
> I have had a problem with XMLMind on my laptop, and spent some time
> with Warren on that this morning. It turned out that I needed to
> reinstall the application from scratch. Now I have a different
> problem.
> 

Yes, and that's not changed.  That is however only germane for unexpanded
includes that have to be resolved from the submitted xml source by the
web service.

> Historically, it has used the library on my laptop. Anyone have an
> idea why it might be different now? Why would the tool override the
> configuration that I have been using since xml2rfc was created?

The web service will of course not have access to the files on your laptop,
but if you previously had XMLMind set up to expand includes in your xml
source before running it through the web service, it would explain things.

This can be accomplished by running xml2rfc with the --exp (--expand) option.

Of course, if that's the way you had it set up earlier, it also implies that
you had xml2rfc installed, in order to do the expansion, which would mean
that you may not have needed to use the web service.  Unless maybe you had
an old version of xml2rfc which was up to doing the expansion, but didn't
want to use it for output generation?

This is a lot of speculation, but the bottom line is really that there is
no way for the web service at xml2rfc.ietf.org to access the local files
indicated by XML_LIBRARY=/Users/fred/In-Progress/XML_Library unless you
do the expansion locally first.

Regards,

	Henrik