Subject: [Tools-discuss] DMARC handling default for IETF mailing lists?

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Apr 2019 22:13:31 +0200

I just configured a mailing list and noticed that the configuration selection

Replace the From: header address with the list's posting address to mitigate issues stemming from the original From: domain's DMARC or similar policies. 
(Details for from_is_list)
No	Munge From	Wrap Message

defaulted to “No”.  Does the list admin have to set this to “Munge From” manually?
(We don’t want to do that with known DMARC-bad source addresses, I believe.)
Or does “No” mean “Munge, if needed”?

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Apr 2019 22:17:13 +0200

> (We don’t want to do that with known DMARC-bad source addresses, I believe.)

Make that
(We don’t want to do that except for known DMARC-bad source addresses, I believe.)

(Where “that” is From-Address munging.)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 11 Apr 2019 23:28:02 +0200

Hi Carsten,

> Or does “No” mean “Munge, if needed”?

I believe 'No' means "Don't Munge", and given that we are running a separate
DMARC workaround, I believe this should not be set by default.  If you set
it, things should still work, but you'll replace our default DMARC workaround
with the Mailman approach.

We're still hoping to be able to deploy ARC, which should be better than both
the current default workaround and the Mailman workaround.

Best regards,

	Henrik

> 
> Grüße, Carsten
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Apr 2019 23:58:22 +0200

Hi Henrik,

> On Apr 11, 2019, at 23:28, Henrik Levkowetz <[email-masked]> wrote:
> 
> Signed PGP part
> Hi Carsten,
> 
> DMARC workaround, I believe this should not be set by default.  

Ah, thank you.

> If you set

Don’t want to do that.

So maybe the prompt in the config section could have a sentence of the form “Don’t enable this unless you know what you are doing; there is a separate DMARC workaround ongoing.”

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 12 Apr 2019 00:05:51 +0200

Hi Carsten,

>> the current default workaround and the Mailman workaround.

I've suggested that as a local Mailman patch to our admins.

Best,

	Henrik