Subject: [Tools-discuss] how to reference BCPs (such as BCP38)?

From: Michael Richardson <[email-masked]>
Date: Tue, 14 May 2019 09:43:25 -0400

We have a comment on a document asking us to make the reference to BCP38
explicit.  Right now we have:

            In particular, the RPL root SHOULD do BCP38 (<xref
            target="RFC2827" />) processing on the source addresses of all IP

and:
     <?rfc include="reference.RFC.2827" ?>

We tried to do:
     <?rfc include="reference.BCP.38" ?>

but this does not work.  Not such file exists.  Is there some other way to
get this right?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Julian Reschke <[email-masked]>
Date: Tue, 14 May 2019 15:54:59 +0200

On 14.05.2019 15:43, Michael Richardson wrote:
> ...

Just paste the contents of
<https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.2827.xml>
into your document and change xref/target and reference/anchor to "BCP38".

Best regards, Julian

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 14 May 2019 15:58:17 +0200

Hi Michael,

> but this does not work.  Not such file exists.  Is there some other way to

Umm.  I think you'll have to construct the <reference> entry yourself, for
now.  Eventually, we should be able to build reference BCP entries for all
BCPs, using <referencegroup> where necessary; but that will only work with
vocabulary v3.  I suspect the lack of <referencegroup> is what's behind no
autogenerated BCP entries.

Regards,

	Henrik

---

From: Michael Richardson <[email-masked]>
Date: Tue, 14 May 2019 10:11:44 -0400

> into your document and change xref/target and reference/anchor to "BCP38".

Yeah, okay. I was hoping for something else.
done.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 14 May 2019 16:21:34 +0200

With kramdown-rfc, you get to choose the label:

normative:
  BCP38: RFC2827

(You need to set
stand_alone: true
to make this work in the current version of kramdown-rfc, but you’ll want that anyway.)

Grüße, Carsten

> On May 14, 2019, at 15:43, Michael Richardson <[email-masked]> wrote:
> 
> Signed PGP part
>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 14 May 2019 11:49:59 -0400

> BCP38: RFC2827

So, then I reference {{BCP38}}?

This document predates kramdown... so it's pre XML :-(
It should have been done already.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 14 May 2019 20:32:30 +0200

> So, then I reference {{BCP38}}?

Yes.

> This document predates kramdown… 

I don’t think so…
(My records say useofrplinfo is from 2015.  
Kramdown-rfc was first published as a gem in Jan 2011.
I just never campaigned it, because I wrote it for myself and my co-authors.)

> so it’s pre XML :-(

I can help with upconverting XML to markdown, by the way.

> It should have been done already.

Talking about useofrplinfo, I think one could say that…
(RFC 6550 should never have been published without that information.)

Grüße, Carsten