Subject: [Tools-discuss] .ics files for interims?

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 May 2019 12:54:44 +0200

We just announced 12 future virtual interims in the CoRE WG.
Is there an easy way to get the .ics files for these?
(The search term ics gets a LOT of hits on site:ietf.org ;-)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 May 2019 13:41:44 +0200

Oh, that was too easy.

https://datatracker.ietf.org/meeting/upcoming.ics?filters=core

Grüße, Carsten

> On May 15, 2019, at 12:54, Carsten Bormann <[email-masked]> wrote:
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 15 May 2019 13:48:20 +0200

Hi Carsten,

> (The search term ics gets a LOT of hits on site:ietf.org ;-)

This turned out to be a fairly easy fix.  I've applied a patch
to add these to the group [Meetings] tab; please check that this
is what you desired:

https://datatracker.ietf.org/group/core/meetings/

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 15 May 2019 13:51:09 +0200

Hi Carsten,

> https://datatracker.ietf.org/meeting/upcoming.ics?filters=core

Heh.  You used the 'Customize' dropdown on the 'Upcoming Meetings'
page, I guess?

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 May 2019 13:54:17 +0200

> https://datatracker.ietf.org/group/core/meetings/

Thanks — that is the version for people who need to add specific interims to their calendar, and

is for people who want them all in one swoop (or even subscribe to them).  Maybe you could add the latter link to the former page (“Calendar entries for all upcoming meetings”)?

Grüße, Carsten

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 15 May 2019 11:57:54 +0000

Hi Carsten, all,

I would also be keen to have an .ics file available with the virtual/interim meetings announcements.
It would be great to have an automated way (e.g. in the meeting request form) to link the .ics and webex (or other tools) info.
We are running regular virtual meeting with the NMRG and, even if not complex, putting all parts together takes time.

--Laurent.

> -----Original Message-----
> From: Tools-discuss <[email-masked]> On Behalf Of Carsten
> Bormann
> Sent: Wednesday, May 15, 2019 12:55
> To: tools-discuss <[email-masked]>
> Subject: [Tools-discuss] .ics files for interims?
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 15 May 2019 14:09:12 +0200

> is for people who want them all in one swoop (or even subscribe to them).  Maybe you could add the latter link to the former page (“Calendar entries for all upcoming meetings”)?

Sure.  Will do.

	Henrik

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 09:58:19 -0400

> virtual/interim meetings announcements.

It's there.
It's very useful to know when they all are to avoid conflicts.
An annoyance is that the interim meeting ics also includes a bunch of actual
in-person meeting details.  It's an annoyance once you start populating your
meeting week schedule, and you turn off the interim meeting view, and then
forget to turn it back on :-)

    > It would be great to have an automated way (e.g. in the meeting request
    > form) to link the .ics and webex (or other tools) info.
    > We are running regular virtual meeting with the NMRG and, even if not
    > complex, putting all parts together takes time.

This is easy...
The calendar includes a pointer to your agenda.

Your agenda had contain to the webex/etc. info, right?  So just upload the
info there.  This also puts the webex/etc. info squarely under the control of
the chairs.

LPwan interim is starting in 3 minutes, and I see it point to
   https://datatracker.ietf.org/meeting/interim-2019-lpwan-07/materials/agenda-interim-2019-lpwan-07-lpwan-01

and if you look there, you see the webex URL.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 15 May 2019 16:11:53 +0000

Thanks Michael.
This is not exactly what I was asking for but it gives a different understanding.
Below for additional comments.

--Laurent.

> From: Michael Richardson <[email-masked]>
> Sent: Wednesday, May 15, 2019 15:58
> To: Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> <[email-masked]>
> Cc: Carsten Bormann <[email-masked]>; tools-discuss <[email-masked]>
> Subject: Re: [Tools-discuss] .ics files for interims?
> 
> 

LC: here I was meaning to have the .ics file as an attachment to the e-mail generated when the meeting is announced. Then I can directly click on it and include in my calendar application. Otherwise, I have to switch to the datatracker to find the .ics.

>    https://datatracker.ietf.org/meeting/interim-2019-lpwan-
> 07/materials/agenda-interim-2019-lpwan-07-lpwan-01
> 

LC: agreed. This is useful to have all links in the same place. But My proposal was to automate creation of the interim/virtual meeting + creation of the webex, i.e. to *generate* the webex link when on the meeting request form.

LC: my ideal workflow would be to automatically generate the meeting request from the final choice in the doodle poll. The only "manual" input would then be the agenda content.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 May 2019 13:54:51 -0400

> LC: here I was meaning to have the .ics file as an attachment to the
    > e-mail generated when the meeting is announced. Then I can directly
    > click on it and include in my calendar application. Otherwise, I have
    > to switch to the datatracker to find the .ics.

So, shouldn't the attachment point to the agenda?
That way, you get the layer of indirection, which lets the chairs actually
make sure the link is correct.

    > LC: agreed. This is useful to have all links in the same place. But My
    > proposal was to automate creation of the interim/virtual meeting +
    > creation of the webex, i.e. to *generate* the webex link when on the
    > meeting request form.

Until the IETF is paying for (and getting via SLA) support from Webex, with
some serious commitment to full-functionality cross-platform, I'd rather that
we did no further integration with webex, API or not.
At this point, Cisco donates Webex to us, and we get no SLA. We can't report bugs.

    > LC: my ideal workflow would be to automatically generate the meeting
    > request from the final choice in the doodle poll. The only "manual"
    > input would then be the agenda content.

That would also be cool :-)
But it would be another proprietary integration.

I would volunteer for do a short demo for WG chairs of using Doodle better.
Many WG chairs are not aware of how it integrates with calendars, and so
often do not "pick" the meeting in doodle. (That clears up tentative values).
And I would support having doodle integration, if IETF were to become a
"business user" of doodle... That would require an RFP, etc.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 May 2019 20:08:15 +0200

> I would volunteer for do a short demo for WG chairs of using Doodle better.

Yes, please.

> often do not "pick" the meeting in doodle. (That clears up tentative values).

I pester them each time they don’t do it.

Multicasting this information would of course be more efficient.

Grüße, Carsten