Subject: [Tools-discuss] emailing authors of an RFC

From: Michael Richardson <[email-masked]>
Date: Wed, 12 Jun 2019 11:45:51 -0400

The page at: https://datatracker.ietf.org/doc/rfc7030/ has an email button
that generates:
     [email-masked]

is this correct? (That was the correct draft name).
mail.ietf.org, says:
    <[email-masked]>: host mail.ietf.org[4.31.198.44] said: 550 5.1.1

could this be because this draft predates having contact addresses?
Is this because the draft has been published, but we don't update the email
contacts, or...?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Wed, 12 Jun 2019 11:52:34 -0400

> [email-masked]

BTW, I think that we want to encourage people to use the aliases @ietf.org
for authors for three reasons:

1) I think that it will indirect through DT database, so if an author changes
   their email, it should follow them?

2) we can include WG chairs, WG lists, or BIS authors, or other people, particularly
   we can also keep people from spamming authors if necessary.
   (particularly authors who have moved on)

3) we can archive things if that makes sense, or even bring request trackers
   into the loop if it seems appropriate in the future.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 12 Jun 2019 19:12:08 +0200

Hi Michael,

> is this correct? (That was the correct draft name).

That was a correct draft alias, but draft aliases expire 2 years after the
draft's expiration.

We should not show the button when the alias doesn't exist.  That we 
currently do so is a bug.

Best regards,

	Henrik

> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 12 Jun 2019 19:19:38 +0200

> for authors for three reasons:

You mean, as opposed to explicit author email addresses, yes?
>    their email, it should follow them?

Yes.

>    (particularly authors who have moved on)

Yes, if an author disable all their email addresses in the datatracker,
that will be the effect.

>    into the loop if it seems appropriate in the future.

Ack.

	Henrik

---

From: Michael Richardson <[email-masked]>
Date: Wed, 12 Jun 2019 14:44:03 -0400

> You mean, as opposed to explicit author email addresses, yes?

Yes, exactly.

I don't know if we would want to remove author email addresses from RFCs, but
it sure would be nice to draw attention to the DT alias, and I don't think we
do much in the production process.  That's kinda a second order issue though.
Getting the DT aliases to work consistently is the first issue.

    > Yes.

Coolness.

So what's up with draft-ietf-pkix-est@
or I'd have thought it would be rfc7030@

and I keep wondering if we shouldn't put it at @doc.ietf.org or something
like that rather than @ietf.org, as the list will keep growing, and
maybe we want to have different spam filtering policies.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 12 Jun 2019 14:45:23 -0400

> That was a correct draft alias, but draft aliases expire 2 years after
    > the draft's expiration.

    > currently do so is a bug.

but the draft became an RFC.
And it's displayed on the RFC document DT page.
Do we have author aliases for RFCs?  Maybe we don't.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 12 Jun 2019 22:14:25 +0200

> Do we have author aliases for RFCs?  Maybe we don't.

No.  Not sure if we should.

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Jun 2019 08:39:10 +0200

> No.  Not sure if we should.

Yes, we should.  (See the discussion over at 
Archived-At: ⁨<https://mailarchive.ietf.org/arch/msg/anima/sfev_MdLg-cgZTVFxE8jl3SQCIo>⁩
for an example why this would be a good idea.)

The [email-masked] aliases have been serving as a stand-in for the missing RFC author set aliases.  I for one was not aware that these are now being deleted automatically, which makes plugging the RFC author alias hole more important.

(Yes, authors of RFCs for wildly successful [RFC5218] protocols may want to have a way to opt out.  Instead of deleting an alias and causing a non-delivery message, a helpful piece of information how the IETF works and how to reach out to the WG or any successor would be useful for those.)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 13 Jun 2019 15:18:19 +0200

> for an example why this would be a good idea.)

Let me clarify.  I wasn't trying to say that RFC author aliases wouldn't be
a good thing, I was questioning whether the IETF should provide these, rather
than the RFC Editor.

> The [email-masked] aliases have been serving as a stand-in for
> the missing RFC author set aliases. I for one was not aware that
> these are now being deleted automatically, which makes plugging the
> RFC author alias hole more important.

The draft-* aliases have always been time-limited; I think I kept them
for 12 months after expiration when they were hosted on @tools.ietf.org,
and extended that to 24 months when we moved them to @ietf.org.

Regards,

	Henrik

> (Yes, authors of RFCs for wildly successful [RFC5218] protocols may
> want to have a way to opt out. Instead of deleting an alias and
> causing a non-delivery message, a helpful piece of information how
> the IETF works and how to reach out to the WG or any successor would
> be useful for those.)
> 
> Grüße, Carsten
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Jun 2019 15:49:09 +0200

> a good thing, I was questioning whether the IETF should provide these, rather

That is a valid question.

However, the IETF does have the datatracker identities, which can make these aliases a bit more sustainable.

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 13 Jun 2019 15:52:12 +0200

On 2019-06-13 15:49, Carsten Bormann wrote:
> However, the IETF does have the datatracker identities, which can
> make these aliases a bit more sustainable.

Yes.  The datatracker already exports some information to the RFC Editor;
if it is deemed that the RFC Editor should own the RFC author alias email
addresses, we'd make sure they could pull the relevant information from
the datatracker.

Regards,

	Henrik

---

From: Bob Hinden <[email-masked]>
Date: Thu, 13 Jun 2019 08:22:34 -0700

Henrik,

> On Jun 13, 2019, at 6:18 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> 

I agree, this is a question for the RFC Editor.

Personally, I am not sure I see too much value, as maintaining an alias over many years will be difficult.  Especially for people who don’t contribute frequently.  But that is again a question for the RFC Editor.

Thanks,
Bob

---

From: Sandy Ginoza <[email-masked]>
Date: Thu, 13 Jun 2019 10:20:11 -0700

Hi all,

Adding Heather to the thread.  

I think this is a reasonable thing that could be added to the RFC info pages.  My main concern is the ongoing maintenance effort if the underlying addresses are supposed be kept current.  Henrik, if any of the underlying addresses become stale with the existing aliases, what happens?  Do you have a method for keeping them up to date? 

Michael, just curious - what’s your use case for this?  Currently on the info pages, we have text suggesting the user email the WG if they want to discuss the RFC; for example, this is what appears for RFC 7030:
Discuss this RFC: Send questions or comments to [email-masked] <mailto:[email-masked]?subject=Question%20regarding%20RFC%207030>

Thanks,
Sandy

> On Jun 13, 2019, at 8:22 AM, Bob Hinden <[email-masked]> wrote:
> 
> Henrik,
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 13 Jun 2019 22:07:14 +0200

Hi Sandy, all,

On 2019-06-13 19:20, Sandy Ginoza wrote:
> I think this is a reasonable thing that could be added to the RFC
> info pages.  My main concern is the ongoing maintenance effort if the
> underlying addresses are supposed be kept current.  Henrik, if any of
> the underlying addresses become stale with the existing aliases, what
> happens?  Do you have a method for keeping them up to date?

The draft email aliases use the latest email information from each author's
datatracker account.  If the address used when submitting a draft has
been marked inactive, the current primary address for that author is used
instead.  If the account of an author has no active addresses (presumably
because the author has marked them all inactive) no email will go out to
that author.

The aim is to use the most current address for each author.  Of course,
if an author doesn't keep their set of email addresses current in the
datatracker, we're not better off (but also not worse off) than using the
original email address from the document.  Sometimes, though, an author
will ask the secretariat to update the address set of a co-author, which
helps for authors who don't have a login or don't maintain their set of
email addresses.

What I think we could easily do is to provide an API that provides a
JSON blob with the best set of author addresses for a given RFC, based
on the information in the datatracker accounts of the authors; you could
then use that to maintain rfc author aliases similar to the draft author
aliases provided at @ietf.org.

> Michael, just curious - what’s your use case for this?  Currently on
> the info pages, we have text suggesting the user email the WG if they
> want to discuss the RFC; for example, this is what appears for RFC
> 7030:

> Discuss this RFC: Send questions or comments to [email-masked]
> <mailto:[email-masked]?subject=Question%20regarding%20RFC%207030>
> 
> Thanks,
> Sandy
>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 13 Jun 2019 20:05:07 -0400

> happens?  Do you have a method for keeping them up to date?

I think that rfc-editor website could likely pull the data from DT
using the API.

    > want to discuss the RFC; for example, this is what appears for RFC

The RFC7030 WG, PKIX, is pretty much closed.
While I actually know the authors, I felt it was more appropriate to use the
alias.   I don't really know if the authors are on the list either.