Subject: [Tools-discuss] Kramdown bug?

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 13 Jun 2019 15:37:59 -0400

This using kramdown-rfc2629-1.2.11
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux].

I put together an OpenFlow reference using the following:

  OPENFLOW:
    title: " OpenFlow Switch Specification, Version 1.5.1 (Protocol version
0x06)"
    seriesinfo:
      ONF TS-025
    date: March 2015
    target:
https://www.opennetworking.org/wp-content/uploads/2014/10/openflow-switch-v1.5.1.pdf
    author:
     org: Open Networking Foundation

The resulting reference looks like:

   [OPENFLOW]
              Open Networking Foundation, "OpenFlow Switch
              Specification, Version 1.5.1 (Protocol version 0x06)", ONF
              TS-025 , March 2015, <https://www.opennetworking.org/wp-
              content/uploads/2014/10/openflow-switch-v1.5.1.pdf>.

In particular, there is a space between the seriesinfo and the following
comma, even though there is no space following it in the source file. Or am
I using seriesinfo incorrectly?

Thanks,
Andy

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Jun 2019 21:56:45 +0200

>       ONF TS-025

Probably best fix:

     seriesinfo:
       ONF: TS-025

Each seriesinfo entry always is a key-value pair (name=, value=), both of which are then shown, simply separated by a space.

Kramdown-rfc is a bit too permissive here, allowing an empty value.  They key you gave and the empty value are separated by a space, causing a trailing space.

I don’t know a way to use seriesinfo to place a single string that does not have a space (but then I never actually needed that).

Grüße, Carsten

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 13 Jun 2019 16:04:03 -0400

Carsten,

Thanks, that fixed it!

   [OPENFLOW]
              Open Networking Foundation, "OpenFlow Switch
              Specification, Version 1.5.1 (Protocol version 0x06)",
              ONF TS-025, March 2015, <https://www.opennetworking.org/
              wp-content/uploads/2014/10/openflow-switch-v1.5.1.pdf>.

Cheers,
Andy

On Thu, Jun 13, 2019 at 3:56 PM Carsten Bormann <[email-masked]> wrote:

> >     seriesinfo:
> >       ONF TS-025
>
> Probably best fix:
>
>      seriesinfo:
>        ONF: TS-025
>
> Each seriesinfo entry always is a key-value pair (name=, value=), both of
> which are then shown, simply separated by a space.
>
> Kramdown-rfc is a bit too permissive here, allowing an empty value.  They
> key you gave and the empty value are separated by a space, causing a
> trailing space.
>
> I don’t know a way to use seriesinfo to place a single string that does
> not have a space (but then I never actually needed that).
>
> Grüße, Carsten
>
>