Subject: [Tools-discuss] postconfirm

From: Mark Nottingham <[email-masked]>
Date: Mon, 24 Jun 2019 11:05:38 +1000

Hello,

For the escape-workshop-pc mailing list, we had a number of submissions from non-IETF people get stuck at the confirmation stage, because people who were not familiar with postman norms didn't realise they had to respond to the confirm message.

In particular, the Subject of the e-mail is "Confirm: ...", and the most prominent line is "Confirmation of list posting -- confirmation ID: ..." -- which can be read to say that THIS e-mail is confirming that posting has already occurred.

Would it be possible to rewrite the confirmation message to make it more clear to busy readers that they need to act on the message?

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 24 Jun 2019 04:28:12 +0200

Hi Mark,

On 2019-06-24 03:05, Mark Nottingham wrote:
> Hello,
> 
> For the escape-workshop-pc mailing list, we had a number of
> submissions from non-IETF people get stuck at the confirmation stage,
> because people who were not familiar with postman norms didn't
> realise they had to respond to the confirm message.
> 
> In particular, the Subject of the e-mail is "Confirm: ...", and the
> most prominent line is "Confirmation of list posting -- confirmation
> ID: ..." -- which can be read to say that THIS e-mail is confirming
> that posting has already occurred.
> 
> Would it be possible to rewrite the confirmation message to make it
> more clear to busy readers that they need to act on the message?

Certainly.

Do you have a proposal for the changed message?

Regards,

	Henrik

---

From: Robert Sparks <[email-masked]>
Date: Mon, 24 Jun 2019 13:23:37 -0500

Perhaps start the subject with "Action Required:" ?

RjS

On 6/23/19 9:28 PM, Henrik Levkowetz wrote:
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 25 Jun 2019 09:52:02 +1000

That would really help. Could we also start the mail with something like:

"Attention: your message has not been posted to the list yet. Please confirm your posting by..."?

Cheers,

> On 25 Jun 2019, at 4:23 am, Robert Sparks <[email-masked]> wrote:
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Jun 2019 02:28:48 +0200

Hi Mark, Robert,

> "Attention: your message has not been posted to the list yet. Please confirm your posting by..."?

The body is based on a template, so easily changed.  Changing the subject
line has repercussions on the code, so let's see if a body change would
be enough.  So, the proposal is to change the body as follows:

Old template text:

  Confirmation of list posting -- confirmation ID: $filename
  
  The ietf.org mailing-list server has received a list posting from 
  $sender to $recipient with the subject 
  '$[msg["subject"]]'
  
  As the sender address isn't subscribed to the list, and has not been
  confirmed earlier, we have to request a confirmation of the address.
  To confirm the address, send a message to $recipient,
  with the same subject line as this message.
  
  (Simply sending a 'reply' to this message should work from most email
  interfaces, since that usually leaves the subject line in the right
  form.  The reply's additional "Re:" is ok.)
  
  If you do not wish your posting to the list to go through, simply
  disregard this message.  Questions to $[conf.admin_address].

New template text:

  Attention: your message has not been posted to the list yet.
  Please confirm your posting by responding to this message:
  
  The ietf.org mailing-list server has received a list posting from 
  $sender to $recipient with the subject 
  '$[msg["subject"]]'

  As the sender address isn't subscribed to the list, and has not been
  confirmed earlier, we have to request a confirmation of the address.
  To confirm the address, send a message to $recipient,
  with the same subject line as this message.

  (Simply sending a 'reply' to this message should work from most email
  interfaces, since that usually leaves the subject line in the right
  form.  The reply's additional "Re:" is ok.)

  If you do not wish your posting to the list to go through, simply
  disregard this message.  Questions to $[conf.admin_address].

Does that match your proposal?

	Henrik

---

From: Robert Sparks <[email-masked]>
Date: Mon, 24 Jun 2019 21:35:57 -0500

I think mark’s point is that the people he was trying to reach triaged the mail on the subject and never looked at the body (so a body change would be a no-op). 

As an aside, we have other templates that pull the envelope into the template. Perhaps this one should go there too?

Sent from my iPhone

> On Jun 24, 2019, at 7:28 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Mark, Robert,
>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 25 Jun 2019 13:10:16 +1000

Exactly.

Thanks,

> On 25 Jun 2019, at 12:35 pm, Robert Sparks <[email-masked]> wrote:
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Jun 2019 07:24:36 +0200

On 2019-06-25 04:35, Robert Sparks wrote:
> I think mark’s point is that the people he was trying to reach
> triaged the mail on the subject and never looked at the body (so a
> body change would be a no-op).

That's not how I read Mark's email.

> As an aside, we have other templates that pull the envelope into the
> template. Perhaps this one should go there too?

The problem here is that the confirmation verification code looks at the
subject line, by ignoring some parts (like tacked-on Re:) and splits the
remainder in group.  The Subject template should be close to that code to
avoid getting them out of sync; and, as indicated below, body changes do
not require code changes, but Subject changes almost certainly _will_
require code changes.  So no, the Subject line should not be part of the
body template.

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Jun 2019 07:30:32 +0200

> Exactly.

Ok, so if the body was never read, that change is immaterial?

For the Subject change, is this the proposal?

Old subject line text:

  Confirm: {recipient}:{filename}:{hash}

New subject line text:

  Action Required: Confirm: {recipient}:{filename}:{hash}

Henrik

>> As an aside, we have other templates that pull the envelope into
>> the template. Perhaps this one should go there too?
>> 
>> Sent from my iPhone
>>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 25 Jun 2019 12:25:59 +0200

> Ok, so if the body was never read, that change is immaterial?

I wouldn’t say that — you don’t want to lose the first half of the people in the Subject line and then the second half when they do read the body, so both need to convey the “action required” message.

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Jun 2019 12:51:57 +0200

Hi Carsten,

> I wouldn’t say that — you don’t want to lose the first half of the people in the Subject line and then the second half when they do read the body, so both need to convey the “action required” messa…

I would not say that either, but with Mark saying "Exactly" to Robert's
statement that a body change would be a no-op, I'd like to be perfectly
clear on what changes are actually desired, before I go touching the
email pipeline.

Mark, could you please accept or modify the proposed changes to subject
line and body?  You're the only one who have had direct contact with the
people who experienced an issue, so you have more information than the
rest of us about what the actual perception was.

	Henrik

---

From: Richard Barnes <[email-masked]>
Date: Tue, 25 Jun 2019 09:43:46 -0400

This reminded me of a complaint I've had for a while:

When I use the Datatracker to submit an I-D, I have to go through the "open
email, click a link" dance, click a button" dance even though I am logged
in to the Datatracker.  Is it not possible to just match the logged-in user
ID with the author email addresses and proceed directly to posting?

--Richard

On Sun, Jun 23, 2019 at 9:05 PM Mark Nottingham <[email-masked]> wrote:

> Hello,
>
> For the escape-workshop-pc mailing list, we had a number of submissions
> from non-IETF people get stuck at the confirmation stage, because people
> who were not familiar with postman norms didn't realise they had to respond
> to the confirm message.
>
> In particular, the Subject of the e-mail is "Confirm: ...", and the most
> prominent line is "Confirmation of list posting -- confirmation ID: ..." --
> which can be read to say that THIS e-mail is confirming that posting has
> already occurred.
>
> Would it be possible to rewrite the confirmation message to make it more
> clear to busy readers that they need to act on the message?
>
> Cheers,
>
> --

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Jun 2019 15:47:51 +0200

Hi Richard,

> ID with the author email addresses and proceed directly to posting?

Yes.  This is something we want to do, but it hasn't reached the top of
the priority list yet.

Best regards,

	Henrik

---

From: Russ Housley <[email-masked]>
Date: Tue, 25 Jun 2019 10:14:39 -0400

> Yes.  This is something we want to do, but it hasn't reached the top of

Yes, indeed.  Remember that the I-D submission was added to the Datatracker long before end-user accounts.  At the time it was added, only the Secretariat and the Area Directors had accounts.

Russ

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 26 Jun 2019 08:28:41 +1200

> Yes, indeed.  Remember that the I-D submission was added to the Datatracker long before end-user accounts.  At the time it was added, only the Secretariat and the Area Directors had accounts.

However, the current system has the virtue of allowing a team of authors
to include people who are not registered tracker users. Also it prevents
somebody usurping authorship of a draft, because only *previous* authors
can approve a posting. Both of those properties need to be kept.

(I'd also say that among the annoyances in my life, having to wait for
the confirmation email when posting an I-D is truly very minor.)

   Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 26 Jun 2019 15:01:49 +0200

Mark:

Please confirm or modify the proposed changes to subject line and body,
so I can move forward with this.

	Henrik