Subject: [Tools-discuss] too long draft names error

From: Michael Richardson <[email-masked]>
Date: Mon, 17 Jun 2019 08:47:36 -0400

I think that there mus tbe something wrong with the error message:

%make submit
curl -S -F "user=[email-masked]" -F "xml=@rfc7030est-clarifications.xml" https://datatracker.ietf.org/api/submit
Validation Error: {'__all__': [u"Expected name 'draft-...' using lowercase ascii letters, digits, and hyphen; found 'draft-richardson-lamps-rfc7030est-clarifications-00'."]}%

I had the same error using the web interface.

I shortened the draft name to draft-richardson-lamps-rfc7030est-clarify-00
and then it worked.  Maybe an additional error message would help?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 17 Jun 2019 15:25:39 +0200

Hi Michael,

> and then it worked.  Maybe an additional error message would help?

Right.  Will fix.

	Henrik

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Jun 2019 09:36:09 +1200

>> and then it worked.  Maybe an additional error message would help?

Does anyone know why the rules limit names to 50 characters (https://www.ietf.org/standards/ids/guidelines/#7)? I'm not saying there shouldn't be a limit, but Michael's original name didn't seem unreasonable.

    Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 18 Jun 2019 13:42:11 +0200

Hi Brian,

> Does anyone know why the rules limit names to 50 characters (https://www.ietf.org/standards/ids/guidelines/#7)? I'm not saying there shouldn't be a limit, but Michael's original name didn't seem un…

I don't, but here is what I know:

I introduced a check for the 50 character limit in idnits 1.95, 4 may 2006.

A copy of the 1id-guidelines.txt file I have from 2002 does not mention it, while a copy with timestamp 24 March 2005, internal date March 25, mentions
the limit.  That was written by Bill Fenner for the IESG.

The current guidelines has this in Change History:

   Changes from Feb 8, 2005 version to March 25, 2005 version:

    ...

   o  Spell out exactly how drafts are named.

which aligns with the explicit mention of the 50 character limit in the
March 24 version.

Best regards,

	Henrik