Subject: [Tools-discuss] Calendars

From: Mark Nottingham <[email-masked]>
Date: Mon, 22 Jul 2019 10:03:44 -0400

[ cc:ing a bit broadly, apologies ]

I'd like to suggest that the .ics files on the agenda NOT be available until the agenda is finalised, to avoid people downloading the wrong time slots.

For example, if a meeting that is traditionally held on Monday in the first slot is moved during conflict resolution.

I understand that this was (probably) communicated somewhere, but we all get a *lot* of e-mail, and this seems like leaving an attractive nuisance around.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 22 Jul 2019 16:25:49 +0200

> I understand that this was (probably) communicated somewhere, but we all get a *lot* of e-mail, and this seems like leaving an attractive nuisance around.

Hmm.

The "right" way to use an ICS file is to use by reference; in which case
schedule changes will automatically by reflected in a calendar app. At
least that what happens for me in Thunderbird/Lightning and when
importing he calendar into Google Calendar...

Best regards, Julian

---

From: Michael Richardson <[email-masked]>
Date: Mon, 22 Jul 2019 14:15:52 -0400

Julian Reschke <[email-masked]> wrote:
    >> I'd like to suggest that the .ics files on the agenda NOT be available
    >> until the agenda is finalised, to avoid people downloading the wrong
    >> time slots.
    >>
    >> For example, if a meeting that is traditionally held on Monday in the
    >> first slot is moved during conflict resolution.
    >>
    >> I understand that this was (probably) communicated somewhere, but we
    >> all get a *lot* of e-mail, and this seems like leaving an attractive
    >> nuisance around.
    >>
    >> Cheers,

    > The "right" way to use an ICS file is to use by reference; in which
    > case schedule changes will automatically by reflected in a calendar
    > app. At least that what happens for me in Thunderbird/Lightning and
    > when importing he calendar into Google Calendar...

+1

With Google Calendar, there is a challenge if you want to change the list of
WG that you are subscribed to.  I solved that by creating an indirection,
and subscribing Google Calendar to that.  I run this on my web serer
once a day:

%cat /corp/docs/SSW/ietf/meeting/ietf105/cal.sh

#!/bin/sh

cd /ssw/docs/SSW/ietf/meeting/ietf105

curl -s >agenda.ics 'https://datatracker.ietf.org/meeting/105/agenda.ics?add,capport,cbor,core,anima,dnsop,mops,opsawg,v6ops,sidrops,roll,ace,acme,cacoa,cose,ipsecme,lake,lamps,rats,saag,suit,teep,loops,6lo,6man,6tisch,dnssd,dprive,netrqmts,secdispatch'

Then I can just edit this script to add/subtract WGs.
It would be nice if I could register my interest in the WGs on the
datatracker and remove that layer of indirection.  The challenge is that
Google Calendar (and others too) do not let me change the URL easily.  Maybe
that's just a bug there.

What I'm really missing (in the calendaring space) is the ability to
subscribe to a foreign event, and have it show up in my main calendar.  I'm
told the IETF APP will do this, and that works for IETF meetings, but not in
general.  I can't do that for the virtual interim calendar, etc.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 22 Jul 2019 15:02:01 -0400

> On Jul 22, 2019, at 2:15 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

The IETFers iOS/iPadOS app currently filters all meetings but the main 3 meetings per year. I have been considering adding a switch to enable/disable all meetings which would include all of the scheduled interim meetings. Not sure if this would solve your problem.

I agree that if you log into the IETF site, you could then generate a calendar subscription per user and that user could add/subtract interest in events/wg’s while having a constant subscription URL.

This seems like an enhancement request for the datatracker.

Tom

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 24 Jul 2019 15:05:33 -0400

By default, the calendar downloads ICS files (i.e. Content-Disposition).

> On 22 Jul 2019, at 10:25 am, Julian Reschke <[email-masked]> wrote:
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 24 Jul 2019 21:20:34 +0200

> By default, the calendar downloads ICS files (i.e. Content-Disposition).

Well yes. This is a UI problem. You need to copy the link, not download
the ICS file.

Or the ICS file would need to carry information about where to refresh
from. I believe that's currently not possible.

Best regards, Julian