Subject: [Tools-discuss] UTF-8 in PDF on datatracker

From: Tom Pusateri <[email-masked]>
Date: Mon, 5 Aug 2019 13:29:02 -0400

Mirja pointed out a problem where a line in our draft looks fine in TXT and HTML but not in PDF.

“On page 21, HTML and text version has "TTL⩾0", which gets mangled in PDF version.”

See:

https://datatracker.ietf.org/doc/draft-ietf-dnssd-push/

Is the datatracker PDF version created by xml2rfc without the —utf8 or is it created with Henrik’s scripts from the TXT version?

Thanks,
Tom

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 5 Aug 2019 13:30:26 -0400

Oops, got the reporter wrong: 

^Mirja^Alexey

> On Aug 5, 2019, at 1:29 PM, Tom Pusateri <pusateri=[email-masked]> wrote:
> 
> 
> https://datatracker..ietf.org/doc/draft-ietf-dnssd-push/
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Aug 2019 19:54:04 +0200

On Aug 5, 2019, at 19:29, Tom Pusateri <pusateri=[email-masked]> wrote:
> 
> “On page 21, HTML and text version has “TTL⩾0", which gets mangled in PDF version.”

Well, you have a 

U+2A7E GREATER-THAN OR SLANTED EQUAL TO

there.  I think you want a

U+2265 GREATER-THAN OR EQUAL TO

(I have no comment on the PDF situation.)

Grüße, Carsten

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 5 Aug 2019 14:01:07 -0400

> On Aug 5, 2019, at 1:54 PM, Carsten Bormann <[email-masked]> wrote:
> 

Thanks. My co-author inserted it and also added the —utf8 switch but I see that is now deprecated:

xml2rfc --utf8 draft-ietf-dnssd-push.xml -o draft-ietf-dnssd-push.html --html
Warning: The --utf8 switch is deprecated.  Use the new unicode insertion element <u>

Thanks,
Tom

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 5 Aug 2019 22:13:08 +0200

Hi Tom,

Replying to your messages in order:

On 2019-08-05 19:29, Tom Pusateri wrote:
> Is the datatracker PDF version created by xml2rfc without the —utf8
> or is it created with Henrik’s scripts from the TXT version?

The latter.  And it has problems with UTF8.  I've tried to mitigate that,
but it's not perfect.

Eventually, the PDF will be generated directly from the xml when the
xml is provided, but the needed work still remains to be done.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 5 Aug 2019 22:16:27 +0200

Hi Tom,

> Warning: The --utf8 switch is deprecated.  Use the new unicode insertion element <u>

In this case (since the PDF is created from the htmlized text), this is
irrelevant.

However, even if --utf8 (for v2 xml) is deprecated, it still works for some
uses.  Going forward, it will eventually be removed.  But the bug here is in
the htmlized-text to pdf processing, not in whether --utf8 is used or not.

	Henrik

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 5 Aug 2019 17:04:57 -0400

> On Aug 5, 2019, at 4:16 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Tom,
> 

In this case, for v2 or v3, I don’t think these two options (—utf8 and <u>) are equivalent.
In the current xml2rfc using v2 input, the —utf8 option is necessary to get the correct TXT and HTML output.

The <u> element will not do this as currently defined and seems to be for a different purpose.

Thanks,
Tom