Subject: Re: [Tools-discuss] [Cellar] I-D Action: draft-ietf-cellar-ebml-12.txt

From: Michael Richardson <[email-masked]>
Date: Mon, 21 Oct 2019 13:50:17 -0400

Dave, is ebml in XML v3, uploaded as such?
Were the txt and HTML generated by you or the datatracker?

> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-cellar-ebml-12

looking at the diff of the txt, there are a bunch of relative references which did not
get expanded correctly from the markdown:

    unknownsizeallowed attribute (#unknownsizeallowed)).

Looks like a tooling issue somewhere.
Looking at this:
  https://www.ietf.org/id/draft-ietf-cellar-ebml-12.html

I don't see #unknownsizeallowed in the same way, but the reference that is
generated looks off to me.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Dave Rice <[email-masked]>
Date: Mon, 21 Oct 2019 14:22:10 -0400

Hi Michael,

> On Oct 21, 2019, at 1:50 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

It was uploaded via https://datatracker.ietf.org/submit/ <https://datatracker.ietf.org/submit/>.

> Were the txt and HTML generated by you or the datatracker?

With xml2rfc 2.32.0 locally the files look ok, I’m attaching them.

I haven’t tested but in the XML within the <sourcecode> we have 0x0A for line breaks. I wonder if an 0x0d (carriage return) would make a difference, though I feel guilty using up version numbers just to test that.

>    unknownsizeallowed attribute (#unknownsizeallowed)).

I’ll address that separately.

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 21 Oct 2019 20:28:35 +0200

Hi Dave,

On 2019-10-21 20:22, Dave Rice wrote:
> Hi Michael,
> 
>> On Oct 21, 2019, at 1:50 PM, Michael Richardson <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>
> It was uploaded via https://datatracker.ietf.org/submit/.
> 
> I haven’t tested but in the XML within the <sourcecode> we have 0x0A for line 
> breaks. I wonder if an 0x0d (carriage return) would make a difference, though I 
> feel guilty using up version numbers just to test that.

Using 0x0D will not make a difference.

I've run into this for at least one other draft, and I believe that the
upcoming new datatracker release deployment will pull in the latest xml2rfc
and address this.

I will do some additional testing in my dev copy, though.

Best regards,

	Henrik

>> ] [email-masked] <mailto:[email-masked]> http://www.sandelman.ca/        | 
>>   ruby on rails    [
>>
>>
> 
> 
> 
> 
> 
> 
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Dave Rice <[email-masked]>
Date: Mon, 21 Oct 2019 15:37:27 -0400

Hi Henrik,

> On Oct 21, 2019, at 2:28 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Dave,
> 

Is there a way to tell which version of xml2rfc is used in the datatracker at any particular time? It would be helpful to ensure my local testing matches.
Dave

> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 21 Oct 2019 21:39:40 +0200

Hi Dave,

> Is there a way to tell which version of xml2rfc is used in the datatracker at any particular time? It would be helpful to ensure my local testing matches.

The generated HTML file should have the xml2rfc version in a meta tag:
<meta content="xml2rfc 2.33.0" name="generator">

Best regards,

	Henrik

---

From: Julian Reschke <[email-masked]>
Date: Mon, 21 Oct 2019 21:44:29 +0200

On 21.10.2019 21:39, Henrik Levkowetz wrote:
> ...
> ...

<https://www.ietf.org/id/draft-reschke-http-jfv-10.html> shows the issue
and has a generator tag of 2.32.0.

Best regards, Julian