Subject: [Tools-discuss] Please retain the online V1 xml2rfc tool

From: Mike Jones <[email-masked]>
Date: Thu, 31 Oct 2019 15:04:32 +0000

The V1 xml2rfc tool can currently be run at http://xml2rfc.tools.ietf.org/old.html.  I continue to use this to make errata updates to some legacy specifications by the OpenID Foundation.  (I need the V1 tool because it emits HTML fragment targets using the section "anchor" value, rather than as a section number, as the V2 tool does.)

As the http://xml2rfc.tools.ietf.org/ site is being updated to support V3, I would very much appreciate it if you could leave http://xml2rfc.tools.ietf.org/old.html as is.

                                                       Thanks,
                                                       -- Mike

---

From: Julian Reschke <[email-masked]>
Date: Thu, 31 Oct 2019 16:23:21 +0100

On 31.10.2019 16:04, Mike Jones wrote:
> The V1 xml2rfc tool can currently be run at
> http://xml2rfc.tools.ietf.org/old.html.  I continue to use this to make
> errata updates to some legacy specifications by the OpenID Foundation..
> (I need the V1 tool because it emits HTML fragment targets using the
> section “anchor” value, rather than as a section number, as the V2 tool
> does.)

Hmmm, that is something all versions of xml2rfc should do. The only
difference might be the actual placement...

> ...

Best regards, Julian

PS: the V1 tools works just fine locally; all you need is a TCL
installation.

---

From: Mike Jones <[email-masked]>
Date: Thu, 31 Oct 2019 18:11:45 +0000

There are many minor differences between the V1 and V2 output for HTML.  The table of contents format is different.  The font rendering for <spanx style="verb"> values is different.  The color of artwork is different.  Etc.  So I really need to keep using V1 to obtain equivalent output for these legacy specs.

Yes, if need be, I'll figure out how to make a local installation work.  But as a favor, I'd really appreciate it if you left http://xml2rfc.tools.ietf.org/old.html in place.

				Thanks again,
				-- Mike

-----Original Message-----
From: Julian Reschke <[email-masked]> 
Sent: Thursday, October 31, 2019 8:23 AM
To: Mike Jones <[email-masked]>; [email-masked]
Subject: Re: [Tools-discuss] Please retain the online V1 xml2rfc tool

On 31.10.2019 16:04, Mike Jones wrote:
> https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fxml2r
> fc.tools.ietf.org%2Fold.html&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7Ccd1fbda0caf74f34ac5c08d75e164ab7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637081322171173303&amp;sdata=UHHhiBCIKGKsGNnZ2Ct1XWluEYApLR1mUj83rdq%2BrUM%3D&amp;reserved=0.  I continue to use this to make errata updates to some legacy specifications by the OpenID Foundation..
> section "anchor" value, rather than as a section number, as the V2 
> tool
> does.)

Hmmm, that is something all versions of xml2rfc should do. The only difference might be the actual placement...

Best regards, Julian

PS: the V1 tools works just fine locally; all you need is a TCL installation.