Subject: [Tools-discuss] Xml2rfc web service at https://xml2rfc.tools.ietf.org/experimental.html does not do v3 plaintext

From: Carsten Bormann <[email-masked]>
Date: Sat, 26 Oct 2019 18:03:14 +0200

FYI: I cannot make the xml2rfc web service at https://xml2rfc.tools.ietf.org/experimental.html work for v3 plaintext.  It complains that it cannot encode a character in ascii, but I didn’t specify ASCII, I asked for plaintext.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 26 Oct 2019 18:24:06 +0200

> FYI: I cannot make the xml2rfc web service at https://xml2rfc.tools.ietf.org/experimental.html work for v3 plaintext.  It complains that it cannot encode a character in ascii, but I didn’t specify…

Ha, the tail of the traceback is:

 File "/usr/local/lib/python2.7/dist-packages/xml2rfc/util/postal.py", line 179, in get_normalized_address_info
    writer.note(x, "Postal address check failed for author %s." % full_author_name(author, latin))
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 1735, in note
    self.log(self.msg(e, label, text))
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 1677, in log
    xml2rfc.log.write(msg)
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/log.py", line 28, in write
    write_err.write(' '.join(args))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 95: ordinal not in range(128)

So it wanted to complain in ASCII about an author, but couldn’t, because the author isn’t an ASCII person.

(BTW, I’m still trying to figure out the postal address messages for the ASCII authors.)

Source file: https://tools.ietf.org/id/draft-ietf-core-resource-directory-23.xml

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 26 Oct 2019 19:01:42 +0200

Hi Carsten,

This is baffling.  If I download this file and run it locally, I don't get
any errors, but the web service should be using the latest release, so I
wonder where the difference is.  I'll dig further.

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 26 Oct 2019 19:57:24 +0200

Hi Carsten,

Ok, I've put a temporary fix in place for the web service.  A more
permanent fix that deals correctly with ascii-only log output media
will be part of the next release.

	Henrik

On 2019-10-26 19:01, Henrik Levkowetz wrote:
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>