Subject: [Tools-discuss] missing bibxml3 for draft-dkg-lamps-samples-01 (maybe https://xml2rfc.tools.ietf.org/public/rfc is stuck?)

From: Daniel Kahn Gillmor <[email-masked]>
Date: Thu, 28 Nov 2019 02:23:39 -0500

I'm using kramdown-rfc2629 to generate the next revision of
draft-autocrypt-lamps-protected-headers via xml2rfc, and the new version
wants an informative reference to draft-dkg-lamps-samples-01.

But the xml typically fetched by this toolchain is missing.

    kramdown-rfc2629 < draft-protected-headers.md > draft-protected-headers.xmlv2.tmp
    .refcache/reference.I-D.draft-dkg-lamps-samples-01.xml: fetching
    *** 404 Not Found while fetching https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-dkg-lamps-samples-01.xml
    *** No such file or directory @ rb_sysopen - .refcache/reference.I-D.draft-dkg-lamps-samples-01.xml for ${fn}
    make: *** [Makefile:14: draft-protected-headers.xmlv2] Error 66

Indeed, looking at the directory listing in
https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/ suggests that the
requested file isn't present, even though other (older) draft-dkg
documents do have a bibxml reference there.

I note that draft-dkg-lamps-samples-01 was uploaded as version 3
xml2rfc, though, and not as version 2.  I don't know whether that makes
a difference or not.

When i look a level up, though:

    https://xml2rfc.tools.ietf.org/public/rfc/?C=M;O=D

it looks like nothing in this folder has been updated since November
3rd, which is close to the submissions cutoff for IETF 106 referenced
here: https://datatracker.ietf.org/meeting/106/important-dates/.  And
draft-dkg-lamps-samples-01 was indeed submitted to the datatracker after
November 3rd.

Maybe whatever updates those references got stuck and hasn't been
restarted since the 106 submissions cutoff?

Is there anything i can do to get it working again?

   --dkg

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 28 Nov 2019 08:30:20 +0100

> Is there anything i can do to get it working again?

It seems the ancient scripts that generate bibxml3 need continuous manual love and care, so we need to solicit some more of this.

Henrik has done a prototype bibxml generation mechanism under datatracker, but that doesn’t help the existing tools.
(I just reviewed an I-D that had references to old versions of draft, apparently since the numberless files haven’t been updated either.)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 28 Nov 2019 16:34:48 +0100

Hi Daniel,

I think I've got the ancient TCL script that generates bibxml3 entries
working again.  The reference.I-D.draft-dkg-lamps-samples-01.xml file
should now be available.

Regards,

	Henrik

On 2019-11-28 08:23, Daniel Kahn Gillmor wrote:
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>