Subject: [Tools-discuss] Why is inline CSS editing on IETF mailing lists?

From: Mark Nottingham <[email-masked]>
Date: Mon, 4 Nov 2019 08:09:39 +1100

Hi,

I've noticed that mail sent to IETF lists appears to have its inline CSS edited; in the message below, an extra "." is prefixed onto these rules, with the effect that they aren't applied:

> ..repos { margin-bottom: 0; margin-top:0; line-height: 1.2; }
> ..new { color: red; }
> ..label { display: inline;
> 	padding: .2em .6em .3em;
> 	font-size: 75%;
> 	font-weight: 700;
> 	line-height: 1;
> 	color: #fff;
> 	text-align: center;
> 	white-space: nowrap;
> 	vertical-align: baseline;
> 	border-radius: .25em;
> }

Compare with <https://www.w3.org/mid/[email-masked]>.

Cheers,

> Begin forwarded message:
> 
> From: Repository Activity Summary Bot <[email-masked]>
> Subject: Weekly github digest ( Activity Summary)
> Date: 3 November 2019 at 6:33:05 pm AEDT
> To: [email-masked]
> Archived-At: <https://mailarchive.ietf.org/arch/msg/quic/1AuiZGyvn5u07O-obAlXV6-AooM>
> 
> Sunday November 03, 2019
> 
> Events without label "editorial"
> 
> Issues
> 
> quicwg/base-drafts (+1/-9/💬28)
> 1 issues created:
> 
> #3179 Duplicate NEW_TOKEN should only be on same connection <https://github.com/quicwg/base-drafts/issues/3179> (by mikkelfj) 
> 5 issues received 28 new comments:
> 
> #3173 TLS MUST NOT deliver server 1RTT Rx keys until getting Finished <https://github.com/quicwg/base-drafts/issues/3173> (10 by ghedo, kazuho, martinduke) -tls
> #3159 Server should not accept 1-RTT traffic before handshake completion <https://github.com/quicwg/base-drafts/issues/3159> (11 by ad-l, ghedo, ianswett, mikkelfj) -tls
> #3155 The method of identifying "the same server" <https://github.com/quicwg/base-drafts/issues/3155> (2 by kazuho, mikkelfj) -transport design proposal-ready
> #3151 loss detection timer description could be simplified by definining a timer mode <https://github.com/quicwg/base-drafts/issues/3151> (4 by ianswett, janaiyengar, marten-seemann) -recovery
> #3135 allow sending PADDING after receiving a non-ack-eliciting packet <https://github.com/quicwg/base-drafts/issues/3135> (1 by mnot) -transport
> 9 issues closed:
> 
> #3041 kMaxDatagramSize should use the PMTU rather than be fixed <https://github.com/quicwg/base-drafts/issues/3041> -recovery design
> #2928 Lift single-packet ClientHello requirement? <https://github.com/quicwg/base-drafts/issues/2928> -tls design has-consensus
> #2823 Do Initial secrets change after Retry packet? <https://github.com/quicwg/base-drafts/issues/2823> -tls design has-consensus
> #3046 Handling of Retire Prior To field <https://github.com/quicwg/base-drafts/issues/3046> -transport design has-consensus
> #3085 Stateless reset detection should be datagram-based <https://github.com/quicwg/base-drafts/issues/3085> -transport design has-consensus
> #2152 Why does stateless reset have to be checked after MAC failure <https://github.com/quicwg/base-drafts/issues/2152> -transport design has-consensus
> #3097 Is CONNECTION_CLOSE ACK-eliciting? <https://github.com/quicwg/base-drafts/issues/3097> -recovery -transport design has-consensus
> #2741 Re-visit initial keys discard <https://github.com/quicwg/base-drafts/issues/2741> -tls -transport design has-consensus
> #2944 Layout of PreferredAddress <https://github.com/quicwg/base-drafts/issues/2944> -transport design has-consensus
> Pull requests
> 
> quicwg/base-drafts (+3/-5/💬14)
> 3 pull requests submitted:
> 
> #3183 Limit CWND increase in slow start <https://github.com/quicwg/base-drafts/pull/3183> (by ianswett) -recovery
> #3182 Add an enum indicating the timer_mode <https://github.com/quicwg/base-drafts/pull/3182> (by ianswett) -recovery
> #3178 token-based greasing / initial packet protection (downgradable variant) <https://github.com/quicwg/base-drafts/pull/3178> (by kazuho) 
> 8 pull requests received 14 new comments:
> 
> #3183 Limit CWND increase in slow start <https://github.com/quicwg/base-drafts/pull/3183> (2 by ianswett, janaiyengar) -recovery
> #3182 Add an enum indicating the timer_mode <https://github.com/quicwg/base-drafts/pull/3182> (2 by ianswett, marten-seemann) -recovery
> #3166 token-based greasing / initial packet protection <https://github.com/quicwg/base-drafts/pull/3166> (1 by kazuho) -transport design
> #3120 Add retry integrity tag <https://github.com/quicwg/base-drafts/pull/3120> (3 by kazuho, martinthomson, mikkelfj) -tls -transport
> #3099 Idle timeout indicates you will timeout <https://github.com/quicwg/base-drafts/pull/3099> (1 by ianswett) -transport
> #3066 Change PTO to be per packet number space <https://github.com/quicwg/base-drafts/pull/3066> (1 by marten-seemann) -recovery design
> #3050 Rewrite key update section <https://github.com/quicwg/base-drafts/pull/3050> (3 by DavidSchinazi, martinthomson) -tls design
> #3042 Use the FRAME_ENCODING_ERROR for errors in frame encoding <https://github.com/quicwg/base-drafts/pull/3042> (1 by martinthomson) -transport design
> 5 pull requests merged:
> 
> #3167 kMaxDatagramSize -> max_datagram_size <https://github.com/quicwg/base-drafts/pull/3167> -recovery
> #3045 Allow ClientHello to span multiple QUIC packets <https://github.com/quicwg/base-drafts/pull/3045> -tls
> #3096 MUST retire Connection IDs becoming stale <https://github.com/quicwg/base-drafts/pull/3096> -transport design
> #2993 Stateless reset comparisons (constant time/any order/datagram) <https://github.com/quicwg/base-drafts/pull/2993> -transport design
> #3098 CONNECTION_CLOSE is non-ack-eliciting <https://github.com/quicwg/base-drafts/pull/3098> -recovery -transport design
> Repositories tracked by this digest:
> 
> https://github.com/quicwg/base-drafts <https://github.com/quicwg/base-drafts>
--
Mark Nottingham   https://www.mnot.net/

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 04 Nov 2019 14:37:18 +1100

I've seen an extra dot on numerous occasions, so this isn't just HTML mail.  It often causes problems for me when it appears in URLs.

On Mon, Nov 4, 2019, at 08:09, Mark Nottingham wrote:
> Hi,
> 
> I've noticed that mail sent to IETF lists appears to have its inline 
> CSS edited; in the message below, an extra "." is prefixed onto these 
> rules, with the effect that they aren't applied:
> 
> > padding: .2em .6em ..3em;
> > font-size: 75%;
> > font-weight: 700;
> > line-height: 1;
> > color: #fff;
> > text-align: center;
> > white-space: nowrap;
> Compare with 
> <https://www.w3.org/mid/[email-masked]>.
> 
> Cheers,
> 
> > Begin forwarded message:
> > 
> > *From: *Repository Activity Summary Bot <[email-masked]>
> > *Subject: **Weekly github digest ( Activity Summary)*
> > *Date: *3 November 2019 at 6:33:05 pm AEDT
> > *To: [email-masked]
> > *Archived-At: *<https://mailarchive.ietf.org/arch/msg/quic/1AuiZGyvn5u07O-obAlXV6-AooM>
> > 
> > Sunday November 03, 2019
> 
> >  * #3179 Duplicate NEW_TOKEN should only be on same connection <https://github.com/quicwg/base-drafts/issues/3179> (by mikkelfj) 
> >  * #3173 TLS MUST NOT deliver server 1RTT Rx keys until getting Finished <https://github.com/quicwg/base-drafts/issues/3173> (10 by ghedo, kazuho, martinduke) -tls
> >  * #3159 Server should not accept 1-RTT traffic before handshake completion <https://github.com/quicwg/base-drafts/issues/3159> (11 by ad-l, ghedo, ianswett, mikkelfj) -tls
> >  * #3155 The method of identifying "the same server" <https://github.com/quicwg/base-drafts/issues/3155> (2 by kazuho, mikkelfj) -transport design proposal-ready
> >  * #3151 loss detection timer description could be simplified by definining a timer mode <https://github.com/quicwg/base-drafts/issues/3151> (4 by ianswett, janaiyengar, marten-seemann) -recovery
> >  * #3135 allow sending PADDING after receiving a non-ack-eliciting packet <https://github.com/quicwg/base-drafts/issues/3135> (1 by mnot) -transport
> > 9 issues closed:
> 
> >  * #3041 kMaxDatagramSize should use the PMTU rather than be fixed <https://github.com/quicwg/base-drafts/issues/3041> -recovery design
> >  * #2928 Lift single-packet ClientHello requirement? <https://github.com/quicwg/base-drafts/issues/2928> -tls design has-consensus
> >  * #2823 Do Initial secrets change after Retry packet? <https://github.com/quicwg/base-drafts/issues/2823> -tls design has-consensus
> >  * #3046 Handling of Retire Prior To field <https://github.com/quicwg/base-drafts/issues/3046> -transport design has-consensus
> >  * #3085 Stateless reset detection should be datagram-based <https://github.com/quicwg/base-drafts/issues/3085> -transport design has-consensus
> >  * #2152 Why does stateless reset have to be checked after MAC failure <https://github.com/quicwg/base-drafts/issues/2152> -transport design has-consensus
> >  * #3097 Is CONNECTION_CLOSE ACK-eliciting? <https://github.com/quicwg/base-drafts/issues/3097> -recovery -transport design has-consensus
> >  * #2741 Re-visit initial keys discard <https://github.com/quicwg/base-drafts/issues/2741> -tls -transport design has-consensus
> >  * #2944 Layout of PreferredAddress <https://github.com/quicwg/base-drafts/issues/2944> -transport design has-consensus
> > Pull requests
> 
> >  * #3183 Limit CWND increase in slow start <https://github.com/quicwg/base-drafts/pull/3183> (by ianswett) -recovery
> >  * #3182 Add an enum indicating the timer_mode <https://github.com/quicwg/base-drafts/pull/3182> (by ianswett) -recovery
> >  * #3178 token-based greasing / initial packet protection (downgradable variant) <https://github.com/quicwg/base-drafts/pull/3178> (by kazuho) 
> >  * #3183 Limit CWND increase in slow start <https://github.com/quicwg/base-drafts/pull/3183> (2 by ianswett, janaiyengar) -recovery
> >  * #3182 Add an enum indicating the timer_mode <https://github.com/quicwg/base-drafts/pull/3182> (2 by ianswett, marten-seemann) -recovery
> >  * #3166 token-based greasing / initial packet protection <https://github.com/quicwg/base-drafts/pull/3166> (1 by kazuho) -transport design
> >  * #3120 Add retry integrity tag <https://github.com/quicwg/base-drafts/pull/3120> (3 by kazuho, martinthomson, mikkelfj) -tls -transport
> >  * #3099 Idle timeout indicates you will timeout <https://github.com/quicwg/base-drafts/pull/3099> (1 by ianswett) -transport
> >  * #3066 Change PTO to be per packet number space <https://github.com/quicwg/base-drafts/pull/3066> (1 by marten-seemann) -recovery design
> >  * #3050 Rewrite key update section <https://github.com/quicwg/base-drafts/pull/3050> (3 by DavidSchinazi, martinthomson) -tls design
> >  * #3042 Use the FRAME_ENCODING_ERROR for errors in frame encoding <https://github.com/quicwg/base-drafts/pull/3042> (1 by martinthomson) -transport design
> > 5 pull requests merged:
> 
> >  * #3167 kMaxDatagramSize -> max_datagram_size <https://github.com/quicwg/base-drafts/pull/3167> -recovery
> >  * #3045 Allow ClientHello to span multiple QUIC packets <https://github.com/quicwg/base-drafts/pull/3045> -tls
> >  * #3096 MUST retire Connection IDs becoming stale <https://github.com/quicwg/base-drafts/pull/3096> -transport design
> >  * #2993 Stateless reset comparisons (constant time/any order/datagram) <https://github.com/quicwg/base-drafts/pull/2993> -transport design
> >  * #3098 CONNECTION_CLOSE is non-ack-eliciting <https://github.com/quicwg/base-drafts/pull/3098> -recovery -transport design
> >  * https://github.com/quicwg/base-drafts
> 
> --
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>