Subject: [Tools-discuss] Fwd: SPF rejection of mail to chairs

From: Glen <[email-masked]>
Date: Wed, 20 Nov 2019 21:21:41 -0800

All -

I'm redirecting this message from Carsten (who is on this list) out of
IETF-Action and onto this list for discussion.

I'm hoping Henrik or Robert can shed light on the current and planned
implementation of this.

---------- Forwarded message ---------
From: Carsten Bormann

Is there a need for the DMARC hack for the chair aliases, too?

Grüße, Carsten

> Begin forwarded message:
>
> From: [email-masked] (Mail Delivery System)
> Subject: Undelivered Mail Returned to Sender
> Date: November 21, 2019 at 12:03:35 GMT+8
> To: [email-masked]
>
> This is the mail system at host ietfa.amsl.com.
>
> I'm sorry to have to inform you that your message could not
> be delivered to one or more recipients. It's attached below.
>
> For further assistance, please send mail to postmaster.
>
> If you do so, please include this problem report. You can
> delete your own text from the attached returned message.
>
>                   The mail system
>
> <[email-masked]> (expanded from <[email-masked]>):
>    host cloud7.spamtitan.com[52.15.128.102] said: 550 5.7.1 SPF Policy
>    Rejection t=[email-masked], s=mfrom, id=[email-masked] (in reply to
>    RCPT TO command)
> Reporting-MTA: dns; ietfa.amsl.com
> X-Postfix-Queue-ID: 1FA95120951
> X-Postfix-Sender: rfc822; [email-masked]
> Arrival-Date: Wed, 20 Nov 2019 20:03:32 -0800 (PST)
>
> Final-Recipient: rfc822; [email-masked]
> Original-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 5.7.1
> Remote-MTA: dns; cloud7.spamtitan.com
> Diagnostic-Code: smtp; 550 5.7.1 SPF Policy Rejection t=[email-masked],
>    s=mfrom, id=[email-masked]
> Return-Path: <[email-masked]>
> Received: by ietfa.amsl.com (Postfix, from userid 65534)
>       id 1FA95120951; Wed, 20 Nov 2019 20:03:32 -0800 (PST)
> X-Original-To: [email-masked]
> Delivered-To: [email-masked]
> Received: from localhost (localhost [127.0.0.1])
> by ietfa.amsl.com (Postfix) with ESMTP id B8DDC120944
> for <[email-masked]>; Wed, 20 Nov 2019 20:03:31 -0800 (PST)
> X-Virus-Scanned: amavisd-new at amsl.com
> X-Spam-Flag: NO
> X-Spam-Score: -4.2
> X-Spam-Level:
> X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5
> tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_HELO_NONE=0.001,
> SPF_PASS=-0.001] autolearn=ham autolearn_force=no
> Received: from mail.ietf.org ([4.31.198.44])
> by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024)
> with ESMTP id eSAUwBWvunbS for <[email-masked]>;
> Wed, 20 Nov 2019 20:03:29 -0800 (PST)
> Received: from gabriel-vm-2.zfn.uni-bremen.de (gabriel-vm-2.zfn.uni-bremen.de
> [134.102.50.17])
> (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits))
> (No client certificate requested)
> by ietfa.amsl.com (Postfix) with ESMTPS id 7FB26120955
> for <[email-masked]>; Wed, 20 Nov 2019 20:03:28 -0800 (PST)
> Received: from dhcp-9c88.meeting.ietf.org (dhcp-9c88.meeting.ietf.org
> [31.133.156.136])
> (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
> (No client certificate requested)
> by gabriel-vm-2.zfn.uni-bremen.de (Postfix) with ESMTPSA id 47JQs9168yzygB;
> Thu, 21 Nov 2019 05:03:24 +0100 (CET)
> From: Carsten Bormann <[email-masked]>
> Content-Type: multipart/mixed;
> boundary="Apple-Mail=_77956336-F9E3-4722-A9BE-E4BF91B1278F"
> X-Mao-Original-Outgoing-Id: 596001800.772862-aaf3c84df25315d1f550b91493ef0952
> Mime-Version: 1.0 (Mac OS X Mail 11.5 \(3445.9.1\))
> Date: Thu, 21 Nov 2019 12:03:22 +0800
> Subject: Rough CBOR slides
> Message-Id: <[email-masked]>
> To: [email-masked]
> X-Mailer: Apple Mail (2.3445.9.1)
> Resent-From: <[email-masked]>
> Resent-To: [email-masked], [email-masked]
> Resent-Message-Id: <[email-masked]>
> Resent-Date: Wed, 20 Nov 2019 20:03:32 -0800 (PST)

---

From: Michael Richardson <[email-masked]>
Date: Thu, 21 Nov 2019 17:52:52 +0800

> Is there a need for the DMARC hack for the chair aliases, too?

Oh crap, yes we do.
and on all of the Internet-draft author lists.

Maybe ARC is further along?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 29 Nov 2019 00:56:04 +0100

> I'm hoping Henrik or Robert can shed light on the current and planned

This is getting a bit long in the tooth; I’d also like to be able to use the draft…@ietf.org aliases but now realistically can’t with more strict SPF checks being implemented everywhere.

Grüße, Carsten