Subject: [Tools-discuss] HTML vs HTMLized

From: Michael Richardson <[email-masked]>
Date: Thu, 05 Dec 2019 08:47:54 -0500

Thank you for changing the default button to say "HTMLized" leaving room for
the "HTML" button.

A question: do I only get HTML version from XML if I upload v3 XML?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 5 Dec 2019 17:10:10 +0100

Hi Michael,

> On 5 Dec 2019, at 14:47, Michael Richardson <[email-masked]> wrote:
> 
> 

Yes, that's right. There are too many issues with the v2 HTML output.

Best,

    Henrik 

> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Thu, 5 Dec 2019 11:26:48 -0500

> Yes, that's right. There are too many issues with the v2 HTML output.

I upgraded the kramdown on my laptop, and generated a new .xml file.
I can't tell if it's v2 or v3 from a quick look at the file.
https://datatracker.ietf.org/doc/draft-richardson-anima-ipv6-lldp/

is missing HTML version.  I wonder if the DT should keep track of which 
format was considered authoriative when uploaded (.txt, xml.v2, xml.v3).

---

From: Michael Richardson <[email-masked]>
Date: Thu, 05 Dec 2019 11:38:21 -0500

> https://datatracker.ietf.org/doc/draft-richardson-anima-ipv6-lldp/

I've concluded that I'm doing something wrong with kramdown, and I'm getting
v2 XML output, even when I ask for v3.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 5 Dec 2019 17:42:04 +0100

> v2 XML output, even when I ask for v3.

I don't think kramdown can actually generate v3 (yet).

Best regards, Julian

---

From: Michael Richardson <[email-masked]>
Date: Thu, 05 Dec 2019 12:27:51 -0500

> I don't think kramdown can actually generate v3 (yet).

kramdown-rfc2629 version 1.2.13 says:

dooku-[~](2.6.5) mcr 10052 %kramdown-rfc2629 -h
Usage: kramdown-rfc2629 [options] file.md|file.mkd > file.xml
    -v, --[no-]verbose               Run verbosely
    -3, --[no-]v3                    Use RFCXML v3 processing rules

which is new compared to 1.2.12.  But, maybe it doesn't do very much yet :-)
I'm hoping Carsten will educate us... usually when I ask for some feature, he
answers with, "You mean --foobar which has been there since last year?"

(I believe Carsten has temporal ESP and is able to read our the brains of
 other people three to fifteen months in the future. He doesn't use this
 power for any visible evil, because he already knows when not to)

---

From: Julian Reschke <[email-masked]>
Date: Thu, 5 Dec 2019 18:51:19 +0100

On 05.12.2019 18:27, Michael Richardson wrote:
> ...

See:
<https://github.com/cabo/kramdown-rfc2629/commit/edfc05320270c609df1a9378086058e2f827bd25>

Best regards, Julian

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 5 Dec 2019 18:53:56 +0100

Hi Michael,

> v2 XML output, even when I ask for v3.

Running 'xml2rfc --v2v3 $draftname.xml' should give you $draftname.v2v3.xml
which should be valid v3 XML.

Of course it would be preferable to get v3 directly from kramdown, and not
have to do that every time.

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 Dec 2019 20:54:06 +0100

On Dec 5, 2019, at 18:27, Michael Richardson <[email-masked]> wrote:
> I'm hoping Carsten will educate us...

Indeed, the route towards v3 goes through v2 at this time.

As Henrik mentioned, xml2rfc has a compatibility mode and can process v2 and convert v2 to v3.
For now, this is likely to be a more stable approach than direct v3 generation.

I admit this is a somewhat lazy way of handling this, but I also believe this is in the best interest of kramdown-rfc’s users: stability is the most important feature of kramdown-rfc.

If you actually need a new v3 feature (artsets anyone?), you are better off writing the XML on your own, in particular during a period where these features aren’t really stable.  When patterns of usage emerge here that actually can be expressed in markdown, I’ll sure go ahead and implement them.  And when we have an approved document for v3, directly generating v3 is likely to be stable enough. 

I’m going to stop going into details here.  Note that there is a (very low volume(*)) rfc-markdown list that should be hosting any specific discussions:

https://www.ietf.org/mailman/listinfo/rfc-markdown

Grüße, Carsten

(*) Well, that might change slightly as we embrace v3.