Subject: [Tools-discuss] Error page returned by tools.ietf.org/html/bcp1

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 6 Dec 2019 17:18:30 +0000

Hi:

https://tools.ietf.org/html/bcp1 returns the following page:

[Docs<https://tools.ietf.org/html/>] [txt<https://tools.ietf.org/rfc/bcp/bcp1.txt>|pdf<https://tools.ietf.org/pdf/bcp1>]
--> -->

<type 'exceptions.TypeError'>
Python 2.7.10+: /srv/www/ietfdb/env/bin/python
Sun Dec 1 19:15:19 2019

A problem occurred in a Python script. Here is the sequence of function calls leading up to the error, in the order they occurred.
 /www/tools.ietf.org/tools/rfcmarkup/rfcmarkup<file://www/tools.ietf.org/tools/rfcmarkup/rfcmarkup> in ()
   1530         usage()
   1531         sys.exit()
   1532
=> 1533     markup()
   1534
markup = <function markup>

 /www/tools.ietf.org/tools/rfcmarkup/rfcmarkup<file://www/tools.ietf.org/tools/rfcmarkup/rfcmarkup> in markup()
   1513             args["padding"] = " "*(72 - len(re.sub("<.*?>", "", (topmenu % args))))
   1514             sys.stdout.write(topmenu % args)
=> 1515             if not draftname and int(rfc) > 8650:
   1516                 args["rfc"] = rfc
   1517                 sys.stdout.write(althtmlinfo % args)
draftname = None, builtin int = <type 'int'>, rfc = None

<type 'exceptions.TypeError'>: int() argument must be a string or a number, not 'NoneType'
      args = ("int() argument must be a string or a number, not 'NoneType'",)
      message = "int() argument must be a string or a number, not 'NoneType'"

  *   Bernie

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 7 Dec 2019 08:22:45 +1300

BCP1 and BCP2 don't exist in the RFC Index but return this error. Other
non-existent BCPs return a 404. I suspect that BCP1 and BCP2 have a
ghostly existence in the database used.

https://tools.ietf.org/html/rfc1818 was BCP1. It's marked as HISTORIC
in the RFC Index but has apparently never been formally obsoleted. It
probably should have been obsoleted by RFC 2026.

https://tools.ietf.org/html/rfc1871 was BCP2. It's marked as HISTORIC
in the RFC Index and as obsoleted by RFC 2026.

Regards
   Brian

On 07-Dec-19 06:18, Bernie Volz (volz) wrote:
> [Docs <https://tools.ietf.org/html/>] [txt <https://tools.ietf.org/rfc/bcp/bcp1.txt>|pdf <https://tools.ietf.org/pdf/bcp1>]                                                       
> --> -->
> 
>  
>  
> *<type 'exceptions.TypeError'>*
> 
> 	
> 
>  /www/tools.ietf.org/tools/rfcmarkup/rfcmarkup <file://www/tools.ietf.org/tools/rfcmarkup/rfcmarkup> in ()
> 
>    1530         usage()
> 
>    1531         sys.exit()
> 
>    1532 
> 
> => 1533     markup()
> 
>    1534     
> 
> *markup* = <function markup>
> 
>  
> 
>  /www/tools.ietf.org/tools/rfcmarkup/rfcmarkup <file://www/tools.ietf.org/tools/rfcmarkup/rfcmarkup> in *markup*()
> 
> *draftname* = None, /builtin/ *int* = <type 'int'>, *rfc* = None
> 
> *<type 'exceptions.TypeError'>*: int() argument must be a string or a number, not 'NoneType'
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 7 Dec 2019 16:00:45 +0100

HI Bernie,

This should be fixed now.  Thanks for the alert.  Please email issues
with tools.ietf.org to [email-masked].

	Henrik