Subject: Re: [Tools-discuss] SPF rejection of mail to chairs

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Dec 2019 08:14:04 +0100

On Nov 21, 2019, at 10:52, Michael Richardson <[email-masked]> wrote:
> 
>> Is there a need for the DMARC hack for the chair aliases, too?
> 
> Oh crap, yes we do.
> and on all of the Internet-draft author lists.

Just fell into the trap again (on a draft…@ietf.org alias).

Where do I need to report this bug to so it gets addressed?

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Fri, 20 Dec 2019 10:16:04 -0600

Hi Carsten -

We're aware of this problem. Unfortunately there is not any quick fix 
for it.

The path through the mail processing chain for the aliases is very 
different than the path for the mailing lists, and the way we are 
applying the current workaround isn't applicable there.

We are discussing what we can do instead.

RjS

On 12/20/19 1:14 AM, Carsten Bormann wrote:
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Dec 2019 18:33:00 +0100

Hi Robert,

> On Dec 20, 2019, at 17:16, Robert Sparks <[email-masked]> wrote:
> 
> Hi Carsten -
> 
> We're aware of this problem. Unfortunately there is not any quick fix for it.
> 
> The path through the mail processing chain for the aliases is very different than the path for the mailing lists, and the way we are applying the current workaround isn't applicable there.

I suspected so.

A lot of our processes are set up to make use of the aliases, so in the end this creates  (hidden-terminal like) problems for these as well.

I’m not sure the majority of mail servers are set up to report SPF failures as delivery status, so I’m not even sure I know the extent of this problem.  (So far, I have often resorted to the explanation that some people are too lazy to read my mail, but maybe SPF vs. forwarding is the real problem.)

> We are discussing what we can do instead.

I wonder if there is a way to stay informed about the progress of issues like this (that are not naturally rooted in the issue tracker of some piece of software).  I mostly brought this up again on the list because I have no visibility.

(I also need a better workaround.  I wonder if I need to move to sending IETF mail from a mail account with a ~all SPF setting, like it’s 2014 again…  Maybe I can just manually set my From address to cabo=[email-masked]?)

Grüße, Carsten

[1]: https://en.wikipedia.org/wiki/Hidden_node_problem