Subject: [Tools-discuss] extracting CODE BEGINS blocks

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Feb 2020 17:05:16 -0500

I thought that there was some trivial script pointed to on tools.ietf.org
that would do the right trick of extracing <CODE BEGINS> blocks, along with
the filenames.

I looked through all the links, but I couldn't see anything.
Yes, I can write my own... but..

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Warren Kumari <[email-masked]>
Date: Wed, 26 Feb 2020 17:08:03 -0500

I believe you are looking for rfcstrip, or the updated version at:
https://github.com/mbj4668/rfcstrip
"Extracts code components, YANG modules and SMIv2 modules from RFCs
and Internet Drafts"

W

On Wed, Feb 26, 2020 at 5:05 PM Michael Richardson
<[email-masked]> wrote:
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Feb 2020 17:42:04 -0500

Warren Kumari <[email-masked]> wrote:
    > https://github.com/mbj4668/rfcstrip "Extracts code components, YANG
    > modules and SMIv2 modules from RFCs and Internet Drafts"

Thank you. bookmarked now.

In the meantime, I wrote another version, now at:
    https://github.com/anima-wg/anima-bootstrap/blob/master/extract-figures

Pure-perl, with a different set of bugs.