Subject: [Tools-discuss] bad date math on https://www.ietf.org/registration/ietf107/ietfpayment.py

From: Daniel Kahn Gillmor <[email-masked]>
Date: Mon, 03 Feb 2020 10:50:22 -0500

On submitting a registration for IETF 107, in advance of the early bird
deadline, but before paying, i encountered this page:

 https://www.ietf.org/registration/ietf107/ietfpayment.py?confirmno=XXXXXXXXXX&confemail=YYYYYYYYYYYYYYYY

(query parameters redacted)

On that page, i see the following text:

-----------------
If left unpaid, your partial registration will be deleted at 2359 UTC Monday, February 03, 2020.

Time remaining to pay registration fee before your registration is deleted:
365 days 09h:16m:22s
-----------------

This appears to be wrong by 365 days -- either the current time or the
deadline is off by a year.

i believe the current time is probably wrong by a year -- because if the
deadline itself was off by a year instead, this would be 366 days (since
2020 is a leap year).

     --dkg

---

From: Alexa Morris <[email-masked]>
Date: Mon, 3 Feb 2020 07:54:32 -0800

Hi Daniel,

Thank you for reporting this. The registration system is a Secretariat-managed tool, so I have forwarded your email to the right person within our team for handling.

Best,
Alexa

> On Feb 3, 2020, at 7:50 AM, Daniel Kahn Gillmor <[email-masked]> wrote:
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]