Subject: Re: [Tools-discuss] Server Transition Briefing

From: Michael Richardson <[email-masked]>
Date: Thu, 02 Apr 2020 14:07:02 -0400

Russ Housley <[email-masked]> wrote:
    > Here is a summary of the discussion on the call that took place on
    > March 11th.

Thank you.

    > Q4. What are the next steps toward separation of services to reduce
    > fragility and increase flexibility?

    > It was suggested that the IETF leverage things that are available in the
    > market wherever possible.  That is, avoid building custom software where
    > possible.

    > It was suggested that public cloud services should be used instead of
    > private cloud services.

I think that your notes do not adequately capture this tussle.
I think that Richard Barnes feels quite strongly about this.

I think that many others, while enthusiastic about not duplicating effort,
are concerned about loss of control, in particular, inability to deploy our
specifications early, and to do it properly, rather than "popularily"

    > It was suggested that microservices be explored.  An OpenID Connect or
    > OAuth 2.0 identity provider could be used to enable microservices.  Some
    > things that might be migrated to microservices are the Internet-Draft
    > repository and the Datatracker database.

The submission system... got this today, not for the first time:

obiwan-[ietf/anima/bootstrap](2.6.5) mcr 10066 %make submit
curl -S -F "user=[email-masked]" -F "xml=@ALL-dtbootstrap-anima-keyinfra.xml" https://datatracker.ietf.org/api/submit
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>504 Gateway Timeout</title>
</head><body>
<h1>Gateway Timeout</h1>
<p>The gateway did not receive a timely response
from the upstream server or application.</p>
</body></html>

so I repeat:

obiwan-[ietf/anima/bootstrap](2.6.5) mcr 10067 %make submit
curl -S -F "user=[email-masked]" -F "xml=@ALL-dtbootstrap-anima-keyinfra.xml" https://datatracker.ietf.org/api/submit
Validation Error: {'__all__': ['A submission with same name and revision is currently being processed. <a href="/submit/status/111297/">Check the status here.</a>']}%

I don't know if status.io can help us with this :-(

    > Wrap Up: Was this discussion useful?  If so, how often should we hold a
    > similar discussion?

    > People felt the discussion was useful, and it was suggested that they
    > be held quarterly.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Wed, 08 Apr 2020 17:01:05 -0400

<#secure method=pgpmime mode=sign>

    > I think that Richard Barnes feels quite strongly about this.

To connect my incomplete dots better...

    > The submission system... got this today, not for the first time:

...

    > from the upstream server or application.</p>

I think that a place where we could benefit from public scalable cloud is the
submission and API (sub-)system(s).
There are a bunch of different ways that this could be done.

I wonder if, with the stretch out of the virtual meetings if the average DT
usage is higher in general, and if the number of IDs submitted per day is
also higher.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [