Subject: [Tools-discuss] setting up for code sprint tomorrow

From: "Salz, Rich" <[email-masked]>
Date: Mon, 18 May 2020 19:52:44 +0000

Just pulled the latest docker image, found ‘requirements.txt’ not ‘requirements3.txt’
Ran it and get errors. What am I missing? Tnx

DOCKER ~/dt/6.130.2.dev0$ ./docker/updatedb
Gathering info ...
Fetching database dump ...
--2020-05-18 15:46:53--  https://www.ietf.org/lib/dt/sprint/ietf_utf8.sql.gz
Resolving www.ietf.org (www.ietf.org)... 104.20.1.85, 104.20.0.85, 2606:4700:10::6814:55, ...
Connecting to www.ietf.org (www.ietf.org)|104.20.1.85|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 397663656 (379M) [application/x-gzip]
Saving to: '/home/rsalz/dt/6.130.2.dev0/data/ietf_utf8.sql.gz'

ietf_utf8.sql.gz    100%[===================>] 379.24M  6.41MB/s    in 57s

2020-05-18 15:47:50 (6.66 MB/s) - '/home/rsalz/dt/6.130.2.dev0/data/ietf_utf8.sql.gz' saved [397663656/397663656]

Loading database ...
Traceback (most recent call last):
  File "/home/rsalz/dt/6.130.2.dev0/ietf/manage.py", line 13, in <module>
    from django.core.management import execute_from_command_line
ImportError: No module named django.core.management
 72KiB [ 110MiB/s] [>                                         ]  0%
updatedb(137): Command failed with error code 1 ([982] ./docker/updatedb )

---

From: Jim Fenton <[email-masked]>
Date: Mon, 18 May 2020 17:07:50 -0700

I ran into the same thing. I pulled a copy of requirements3.txt from the
"Vancouver" code sprint and so far so good. Running tests now.

On 5/18/20 12:52 PM, Salz, Rich wrote:
> --2020-05-18 15:46:53-- 
> https://www.ietf.org/lib/dt/sprint/ietf_utf8.sql.gz
>
> 2020-05-18 15:47:50 (6.66 MB/s) -
> '/home/rsalz/dt/6.130.2.dev0/data/ietf_utf8.sql.gz' saved
> [397663656/397663656]
>
>  
>
> Loading database ...
>
>  72KiB [ 110MiB/s] [>                                         ] 
> 0%           
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 19 May 2020 00:30:52 +0000

Sam error, but I do see the Django files listed :(

From: Jim Fenton <[email-masked]>
Date: Monday, May 18, 2020 at 8:08 PM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Tools-discuss] setting up for code sprint tomorrow

I ran into the same thing. I pulled a copy of requirements3.txt from the "Vancouver" code sprint and so far so good. Running tests now.
On 5/18/20 12:52 PM, Salz, Rich wrote:
Just pulled the latest docker image, found ‘requirements.txt’ not ‘requirements3.txt’
Ran it and get errors. What am I missing? Tnx

DOCKER ~/dt/6.130.2.dev0$ ./docker/updatedb
Gathering info ...
Fetching database dump ...
--2020-05-18 15:46:53--  https://www.ietf.org/lib/dt/sprint/ietf_utf8.sql.gz<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_lib_dt_sprint_ietf-5Futf8.sql.gz&d=DwMDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=vge_0yXf1RGSxHQfO0GzEVeXcDhNPMSjWBnK1hoMrzE&s=TnApnnHg41Yab5Ip2MRftTlT9sMwRjGFi65hq6X-cXw&e=>
Resolving www.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.ietf.org&d=DwMDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=vge_0yXf1RGSxHQfO0GzEVeXcDhNPMSjWBnK1hoMrzE&s=LZ6i4njzuxIEstjCfg0jh-09e6ZUQirhfzVANzcrzCA&e=> (www.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.ietf.org&d=DwMDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=vge_0yXf1RGSxHQfO0GzEVeXcDhNPMSjWBnK1hoMrzE&s=LZ6i4njzuxIEstjCfg0jh-09e6ZUQirhfzVANzcrzCA&e=>)... 104.20.1.85, 104.20.0.85, 2606:4700:10::6814:55, ...
Connecting to www.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.ietf.org&d=DwMDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=vge_0yXf1RGSxHQfO0GzEVeXcDhNPMSjWBnK1hoMrzE&s=LZ6i4njzuxIEstjCfg0jh-09e6ZUQirhfzVANzcrzCA&e=> (www.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.ietf.org&d=DwMDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=vge_0yXf1RGSxHQfO0GzEVeXcDhNPMSjWBnK1hoMrzE&s=LZ6i4njzuxIEstjCfg0jh-09e6ZUQirhfzVANzcrzCA&e=>)|104.20.1.85|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 397663656 (379M) [application/x-gzip]
Saving to: '/home/rsalz/dt/6.130.2.dev0/data/ietf_utf8.sql.gz'

Loading database ...

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/tools-discuss<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tools-2Ddiscuss&d=DwMDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=vge_0yXf1RGSxHQfO0GzEVeXcDhNPMSjWBnK1hoMrzE&s=ZdxzYdRaDnIfWJNz4qIAgecvaCayzQkmEGiVROu_u7U&e=>

bugs at http://tools.ietf.org/tools/ietfdb<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_ietfdb&d=DwMDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=vge_0yXf1RGSxHQfO0GzEVeXcDhNPMSjWBnK1hoMrzE&s=CJJGTL93Cl_XHDjBbqIKbnnBdtirZcorBbhxge0LzyM&e=>

or send email to [email-masked]<mailto:[email-masked]>

http://tools.ietf.org/tools/issues<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_issues&d=DwMDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=vge_0yXf1RGSxHQfO0GzEVeXcDhNPMSjWBnK1hoMrzE&s=kWr5y0tJMRYzjmAgSa6z1jtU6_8grpnyolic0B2FSLI&e=>

or send email to [email-masked]<mailto:[email-masked]>

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 18 May 2020 21:12:29 -0400

I thought requirements.txt was the new requirements3.txt. Python 2 is dead. The  3 is no longer a necessary distinguisher. 

Tom

> On May 18, 2020, at 8:31 PM, Salz, Rich <rsalz=[email-masked]> wrote:
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 19 May 2020 12:31:23 +0200

Oh, bother.  I realise that I made the latest binary database dump from
trunk, but trunk now uses Django 2.0, which won't work with the 6.130.1
release which still has Django 1.11, and there's one field that has
changed with the revision change.  I'll do a new dump immediately.
Sorry for the extra bother!

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 19 May 2020 12:32:34 +0200

On 2020-05-19 03:12, Tom Pusateri wrote:
> I thought requirements.txt was the new requirements3.txt. Python 2 is
> dead. The 3 is no longer a necessary distinguisher.

That's correct.

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 19 May 2020 12:46:36 +0200

Hi Rich,

This seems like a different issue than I thought at first.  The issue with
the database dump is real, but I think your issue below is that your
environment isn't right.

As the first thing after starting and entering your docker container, please
run, at the top of your working copy directory tree:

  $ python3.6 -m venv env
  $ . env/bin/activate
  $ pip install -r requirements.txt

in order to make sure that 1) you have a Python 3.6 environment in your
container, and 2) you have the right python packages installed.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 19 May 2020 14:32:18 +0200

I've found one additional tweak that's needed:

After the release of 6.130.1, a new version of the 'django-cors-headers'
package has come out, and it's incompatible with Django 1.11.

In order to fix this, please run, in the docker container, after you've
run 'pip install -r requirements.txt', this command:

  $ pip install "django-cors-headers<3.3"

Best regards,

	Henrik

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 19 May 2020 13:29:21 +0000

Do I need to always run under the python venv?

On 5/19/20, 8:33 AM, "Henrik Levkowetz" <[email-masked]> wrote:

    Best regards,

    	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 19 May 2020 15:35:29 +0200

> Do I need to always run under the python venv?

Anything else courts unexpected issues, so pretty much 'Yes'.