Subject: [Tools-discuss] missing links in draft on tools.ietf.org

From: Dick Hardt <[email-masked]>
Date: Wed, 24 Jun 2020 14:16:12 -0700

Hello

My draft-hardt-xauth-protocol drafts are not showing up correctly on
tools.ietf.org

https://tools.ietf.org/html/draft-hardt-xauth-protocol

properly redirects to

https://tools.ietf.org/html/draft-hardt-xauth-protocol-10

but there are no links to -07, -08, -09 at the top

and any version shows up given the full URL, but 07 - 10 links are not
shown at the top, so someone with a full URL link will not know that -10 is
the latest.

FYI: 07 - 10 where all published close together in time.

/Dick

ᐧ

---

From: Dick Hardt <[email-masked]>
Date: Tue, 30 Jun 2020 18:19:39 -0700

Hello, checking in on this issue. Thanks!

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 1 Jul 2020 07:43:40 +0200

Hi Dick,

this is a long-standing problem with the (rather ancient) scripts that are being used to generate the htmlized pages, which sometimes hick up when generating cached pages.  Since these scripts are slow, easy recipes for overcoming caching problems, such as “regenerate every day”, don’t seem to work.
Manual intervention seems to be required.  I think we also have no way to automatically find these problems and their extent (I think by now the datatracker should have the necessary HTTP APIs to help in constructing something like this, but I don’t know for sure).

So until there is a general overhaul of this infrastructure, we will continue to see these problems, and we will continue to need to nudge people to do the fixing.

Grüße, Carsten

> On 2020-07-01, at 03:19, Dick Hardt <[email-masked]> wrote:
> 
> My draft-hardt-xauth-protocol drafts are not showing up correctly on tools.ietf.org
> 
> and any version shows up given the full URL, but 07 - 10 links are not shown at the top, so someone with a full URL link will not know that -10 is the latest.
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]