Subject: [Tools-discuss] bibxml7 -- referencing a book

From: Nico Williams <[email-masked]>
Date: Mon, 6 Jul 2020 16:36:59 -0500

How would I write a reference to a book, such as

  https://dl.acm.org/doi/10.5555/231070

?

Thanks,

Nico
--

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 7 Jul 2020 07:50:50 +0200

>  https://dl.acm.org/doi/10.5555/231070

In kramdown-rfc:

informative:
  mybook: DOI.10.5555/231070

Unfortunately, doi.org is broken wrt this book:

https://doi.org/10.5555/231070
➔
DOI Not Found

10.5555/231070

This DOI cannot be found in the DOI System. Possible reasons are:

	• The DOI is incorrect in your source. Search for the item by name, title, or other metadata using a search engine.
	• The DOI was copied incorrectly. Check to see that the string includes all the characters before and after the slash and no sentence punctuation marks.
	• The DOI has not been activated yet. Please try again later, and report the problem if the error continues.

I submitted an error report.

Grüße, Carsten

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 07 Jul 2020 15:59:37 +1000

I wonder if this is not at the ACM end.

https://doi.org/10.5555/551551 is similarly absent, but this is the identifier used by dl.acm.org.

On Tue, Jul 7, 2020, at 15:50, Carsten Bormann wrote:
> 	• The DOI is incorrect in your source. Search for the item by name, 
> title, or other metadata using a search engine.
> 	• The DOI was copied incorrectly. Check to see that the string 
> includes all the characters before and after the slash and no sentence 
> punctuation marks.
> 	• The DOI has not been activated yet. Please try again later, and 
> report the problem if the error continues.
> 
> 
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Nico Williams <[email-masked]>
Date: Tue, 7 Jul 2020 02:08:53 -0500

>   mybook: DOI.10.5555/231070

(BTW, I'm currently editing XML.  I know, I know..  I mean, I wrote
lyx2rfc, so I ought to be using _that_.  But I've let it rot.)

> [...]

Huh.  Thanks!

I wonder if that's why the bibxml7 links off the xml2rfc page aren't
working -- I always get "invalid DOI or type", even for the examples on
the page.

Also, it doesn't seem like there's any way to get the rendered I-D to
have this information visible, so it hardly seems to matter.  But it
ought to be visible, IMO.

Nico
--

---

From: "John Levine" <[email-masked]>
Date: 7 Jul 2020 23:02:25 -0400

>https://doi.org/10.5555/231070

That's because it's not a DOI, it's a catalog number in ACM's Digital
Library. Books don't have DOIs; they have ISBNs, in this case 978-0-201-54979-9

There is no free ISBN lookup system. Bowker, the company that issues
ISBNs, charges a lot for access to the database.

You might be able to fake it by looking books up in Worldcat, e.g.

https://www.worldcat.org/oclc/254120563