Subject: [Tools-discuss] 3GPP references

From: Michael Richardson <[email-masked]>
Date: Mon, 13 Jul 2020 17:05:28 -0400

I tell xml2rfc to reference reference.3GPP.51.011.xml and it gets it from .../bibxml5.
Then it says:

 <string>: Line 3: Type ID doesn't allow value '3GPP.51.011'
 <string>: Line 3: Element reference failed to validate attributes
 <string>: Line 650: Failure to process entity _3GPP.51.011
 <string>: Line 650: Entity '_3GPP.51.011' not defined

setting standalone: true in markdown, I look at the resulting XML,
and I see how the entity is inserted.
So I insert the reference.3GPP... contents myself, and change the anchor to _3GPP
since I think that leading digits are not allowed.

And it works.
Is it a known problem that the bibxml5 is not compliant?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 14 Jul 2020 06:53:45 +0200

On 2020-07-13, at 23:05, Michael Richardson <[email-masked]> wrote:
> Signed PGP part
> setting standalone: true in markdown,

Which you always should, unless you have weird firewall issues making it impossible to reach the bibxml server from kramdown-rfc.

> I look at the resulting XML,

This works for me (the 3GPP is properly, if uglily, escaped, as it should be).

   [_3GPP.51.011]
              3GPP, "Specification of the Subscriber Identity Module -
              Mobile Equipment (SIM-ME) interface", 3GPP TS 51.011
              4.15.0, 15 June 2005,
              <http://www.3gpp.org/ftp/Specs/html-info/51011.htm>.

> since I think that leading digits are not allowed.

Kramdown-rfc does that already for you.

> And it works.

Yes.

> Is it a known problem that the bibxml5 is not compliant?

It is a known problem that xml2rfc v1 was rather lenient in its XML processing.
Bibxml5 apparently is from that time.

kramdown-rfc fixes that up properly, so I think I’m already done here?

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Tue, 14 Jul 2020 17:50:44 -0400

> Which you always should, unless you have weird firewall issues making
    > it impossible to reach the bibxml server from kramdown-rfc.

I'm unclear of the advantages or disadvantages of whether kramdown or xml2rfc
pulls the references :-)

    > This works for me (the 3GPP is properly, if uglily, escaped, as it

maybe I need an update to kramdown.

    > Kramdown-rfc does that already for you.

It didn't.

I seem to have kramdown-rfc2629 vesion 1.2.13. (There is no --version)
I seem have xml2rfc version 2.23.1.

I wasn't thinking that this was a kramdown bug.
It might be an xml2rfc bug, but it seems like it is a .xml file bug.

I now have kramdown-rfc2629 version 1.3.8, and now it works.

It seems that kramdown is working around a problem in the .xml file.