Subject: [Tools-discuss] Meet echo test today

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Jul 2020 18:03:57 +0200

I was in an interim for the first 2/3, so sorry if this was asked.

(1) How do I know whether I’m muted (or, more appropriately, I’m not muted)?
There should be MASSIVE visual feedback when you are at an open microphone.
(ABSOLUTELY ESSENTIAL.)

(2) How do I know who is speaking at the moment?  
(PRETTY MUCH ESSENTIAL.)
(Look at BigBlueButton to see how to do this right.  Certainly not at Webex.)

Can we have tool tips on all the the icons?

Some of the buttons don’t react immediately, so it looks like they didn’t register, and you are likely to press them twice.

(Hums: too complicated UI, clicking around in different parts of the screen under a time limit, easy to get wrong.)

Use the term “mute” for input OR for output, not for both.
These days, it is usually used for muting the microphone input.

Sorry if this little list sounds negative, to the contrary, I’m impressed.
But the places I’m shouting about above really need to be fixed.

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 15 Jul 2020 18:09:00 +0200

On Wed, Jul 15, 2020 at 06:03:57PM +0200, Carsten Bormann wrote:
> (1) How do I know whether I???m muted (or, more appropriately, I???m not muted)?

On the bottom of the sceen you will see "audio in: X kbps" when you are muted
On the bottom of the sceen you will see "audio in: X kbps  audio out: X kbps" when you are unmuted

Not sure if this meets your requirments.

> (Look at BigBlueButton to see how to do this right.  Certainly not at Webex.)

+1 Have not figured that out.

> Can we have tool tips on all the the icons?

+1.

> Some of the buttons don???t react immediately, so it looks like they didn???t register, and you are likely to press them twice.
> 

We should just invite experienced gamers to IETF. Times are a changing.

> Use the term ???mute??? for input OR for output, not for both.
> Sorry if this little list sounds negative, to the contrary, I???m impressed.
> But the places I???m shouting about above really need to be fixed.

I think the new meetecho is impressive work already.
I agree and +1 most of your observations. 

Cheers
    Toerless

---

From: Bob Hinden <[email-masked]>
Date: Wed, 15 Jul 2020 09:53:57 -0700

Hi,

I was on the call too, overall I think new Meetecho is a great improvement, but with some rough edges.  My comments inline below and a few more at the end.

Bob

> On Jul 15, 2020, at 9:09 AM, Toerless Eckert <[email-masked]> wrote:
> 

No, I think that is too subtle.

The icons could be improved, for example, mute/unmute icons in other apps tend to use a slash through them to mute/unmute.

> +1 Have not figured that out.

I agree.

>> Can we have tool tips on all the the icons?

Yes, took me a while to figure out that the other box that changed, tool tips on the icons would be much better.

>> (Hums: too complicated UI, clicking around in different parts of the screen under a time limit, easy to get wrong.)

Agree.  Might also be better for the hum tool to just be a new window that pops up, instead of a pop up window that says to go to a different tab.

>> These days, it is usually used for muting the microphone input.

Agree

> I think the new meetecho is impressive work already.

Yes, kudos to the Meetecho team!!

Other comments:

Running it on Chrome on MacOS 10.14, it did not give me a choice of audio and video devices.

I have two screens, I didn’t see any way to move the different parts to different windows.  As a w.g. chair, I would like to be able to see the participant list (w/ queue requests) and the chat at the same time.  The current UI doesn’t seem to allow that.   I think it is a big issue for chairing a session.

I didn’t understand the separation between requesting audio and video.   I think requesting video should include audio, maybe the audio one should be audio-only.   This is going to be confusing.   Does the chair have to approve both?

The humming tool needs some work, I think it needs a no-hum button because otherwise I can’t tell the difference between someone not-humming or walking away from the computer.  As a w.g. chair, I also want to see how many people hummed.   One loud hum from one person is very different than everyone in the room humming loudly.  Ideally a bar graph would allow the chair to get a much better sense of the room.   Also, why are w.g. chairs not allowed to hum, but Area Directors are?

Great to see it working with IPv6!!

Bob

> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 Jul 2020 12:56:53 -0400

> There should be MASSIVE visual feedback when you are at an open microphone.

I understand that this will be added.
I hope that at least some of it will be driven by the server receiving audio.
(It would be even better if all clients calculated a quality number and fed
that back)
They key is for the local user to know if they are transmitting successfully
to the network, and also for them to know if they have unmutted everything.

    > Can we have tool tips on all the the icons?

The location of the tool tip on the top is a bit surprising.
The "Request Audio" tool tip for entering the queue did not immediately tell
me what was going on.

Please do not remove the unmute button when I enter the queue as it is
confusing.  Shade it out if you must.

    > These days, it is usually used for muting the microphone input.

Agreed.

    > But the places I’m shouting about above really need to be fixed.

I am also very happy.

I would be happy to use it *as-is* for all future virtual interim meetings.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 Jul 2020 20:27:36 -0400

> Running it on Chrome on MacOS 10.14, it did not give me a choice of

It's in the settings for that page usually.
You won't be asked if you previously approved things.

    > I have two screens, I didn’t see any way to move the different parts to
    > different windows.  As a w.g. chair, I would like to be able to see the
    > participant list (w/ queue requests) and the chat at the same time.
    > The current UI doesn’t seem to allow that.   I think it is a big issue
    > for chairing a session.

I don't think that they are going to be able to easily "undock" these boxes.
Chairs will have to
  1) start a jabber client on their second screen and connect to the jabber channel.
  2) connect to the codimg in a browser tab on their second screen.

It would be nice if the codimg link was made clickable so facilitate (2)
without digging through DT pages.

    > I didn’t understand the separation between requesting audio and video.
    > I think requesting video should include audio, maybe the audio one
    > should be audio-only.   This is going to be confusing.   Does the chair
    > have to approve both?

I also didn't get that.

    > One loud hum from one person is very different than everyone in the
    > room humming loudly.

    > Ideally a bar graph would allow the chair to get a much better sense of
    > the room.   Also, why are w.g. chairs not allowed to hum, but Area
    > Directors are?

I don't know, but it doesn't bother me.