Subject: [Tools-discuss] Meetecho feedback

From: Jordi Palet Martínez <[email-masked]>
Date: Tue, 28 Jul 2020 14:26:26 +0200

When you refresh the screen (in my case was moving my laptop and connecting an external monitor, mic and speaker, a "Media preflight" window ask for the "Audio" device, while it is actually asking for the mic device. I think "mic" instead of audio should be used, to avoid confusion.

Also, it is missing a "Speaker" selection. If you have several speakers, you need to be able to choose one.

Regards,
Jordi
@jordipalet

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Chris Morrow <[email-masked]>
Date: Tue, 28 Jul 2020 13:43:30 +0000

On Tue, 28 Jul 2020 12:26:26 +0000,
Jordi Palet Martínez <jordi.palet=[email-masked]> wrote:
> 
> When you refresh the screen (in my case was moving my laptop and
> connecting an external monitor, mic and speaker, a "Media preflight"
> window ask for the "Audio" device, while it is actually asking for
> the mic device. I think "mic" instead of audio should be used, to
> avoid confusion.
> 
> Also, it is missing a "Speaker" selection. If you have several
> speakers, you need to be able to choose one.

This is a version of my feedback as well:

  "Please clearly delineate (and permit choosing) between the input
  and output audio devices"

> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Tue, 28 Jul 2020 10:20:44 -0400

Another usability issue with Meetecho is that when you go to talk, it _then_ asks for permission to use the microphone, but also immediately removes you from the queue because permission wasn’t already granted. So you have to give permission to use the mic and then re-enter the queue. This is what happens on Safari, anyway.  I noticed several people having issues with this, and realized why when it happened to me.

A further issue is that for some reason the presenter screen seems to be going through some kind of analog connection, which is noisy, and that noise then has to be encoded; as a result, the slides for 6man this morning were streaming at an impressive 500kbps.

> On Jul 28, 2020, at 9:43 AM, Chris Morrow <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Jul 2020 16:26:56 +0200

On 2020-07-28, at 16:20, Ted Lemon <[email-masked]> wrote:
> Safari

Oh.  This should have been made much clearer ahead of time.
When you need WebRTC:

Do not use (desktop) Safari (MUST NOT).
Use Firefox in a pinch (SHOULD NOT), getting better recently.
Do use chromium browsers (SHOULD), e.g. Chrome or Brave.

(Mobile Safari seems to be better, by the way, but I don’t have a lot of experience with that.)

Hard-earned experience from a semester turned online.

Grüße, Carsten

---

From: Ted Lemon <[email-masked]>
Date: Tue, 28 Jul 2020 10:29:24 -0400

It’s possible but unlikely that every other person who had the same issue was using Safari. Aside from this one issue, I had no trouble. The analog video issue is a Meetecho issue, not a Safari issue. 

> On Jul 28, 2020, at 10:26, Carsten Bormann <[email-masked]> wrote:
>

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 28 Jul 2020 20:43:07 +0200

Hi Ted,

> Another usability issue with Meetecho is that when you go to talk, it _then_ asks for permission to use the microphone, but also immediately removes you from the queue because permission wasn’t alr…

this is not the expected behavior and doesn't happen with any of the 
browsers we tested (which include Safari). At the very moment the 
application tries to access your microphone you are prompted to grant 
permission. This permission cannot be "cached" in Safari like in other 
browsers where you can check "don't ask me again". Anyway, this does 
remove you from the queue only because you're moved into the "sending 
media" section, as you've been allowed to speak. So no need at all to 
re-enter the queue, which in fact does nothing when you're already 
sending audio other than displaying a warning message "audio already 
requested".

> A further issue is that for some reason the presenter screen seems to be going through some kind of analog connection, which is noisy, and that noise then has to be encoded; as a result, the slides…

I'm not sure I understand this. What you mean by going through an analog 
connection? There's no such think in Meetecho, the shared screen is just 
a WebRTC video feed as provided by the browser via the getDisplayMedia 
API call. 500k is indeed the upper bound we enforce to avoid overloading 
clients' networks, but it's up to the browser (and the software encoder 
it uses) to pick the bandwidth it thinks is needed to properly encode 
the content of the screen.

Alessandro

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 28 Jul 2020 20:54:21 +0200

Hi Chris, Jordi

>    and output audio devices"

this has been added to our todo list already. Thanks for your feedback.

Alessandro