Subject: [Tools-discuss] Using Datatracker for authentication

From: Eric Rescorla <[email-masked]>
Date: Fri, 10 Jul 2020 06:12:19 -0700

If one wanted to write a new tool that leveraged Datatracker authentication
(presumably via OAuth) would that be possible? What would one need to do?

-Ekr

---

From: Robert Sparks <[email-masked]>
Date: Fri, 10 Jul 2020 09:34:55 -0500

From a technical pov, you add an openid connect client to your tool. A 
record in the datatracker would need to be created that established a 
clientid and secret for that tool (and a few other bits of information). 
You'd configure your tool with these things and all should be good. The 
provider can also do oauth2, at the cost of more configuration at both ends.

We are building a policy around how to decide how to answer when someone 
asks for something to be added as a client. For the moment, the tools 
team will sanity-check and make a recommendation, and the IESG approves.

On 7/10/20 8:12 AM, Eric Rescorla wrote:
> If one wanted to write a new tool that leveraged Datatracker 
> authentication (presumably via OAuth) would that be possible? What 
> would one need to do?
>
> -Ekr
>
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Fri, 10 Jul 2020 11:01:45 -0400

Robert Sparks <[email-masked]> wrote:
    > From a technical pov, you add an openid connect client to your tool. A record
    > in the datatracker would need to be created that established a clientid and
    > secret for that tool (and a few other bits of information).

I guess that we could probably test against the sandbox, or against our own
copy.  Is there instruction to tell us where that record is?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Robert Sparks <[email-masked]>
Date: Mon, 13 Jul 2020 10:27:37 -0500

The place to start is reading 
https://django-oidc-provider.readthedocs.io/en/latest/

You can add clients to your test instance using the admin at 
http://localhost:8000/admin/oidc_provider/

RjS