Subject: Re: [Tools-discuss] Meetecho rooms being opened to chairs 10 minutes before sessions would be _really_ helpful

From: Toerless Eckert <[email-masked]>
Date: Wed, 29 Jul 2020 16:48:16 +0200

Adding tools-discuss as the authoritative group for MeetEcho feature requests, bcc wgchairs

I want to be offensive-ranter (ok, better on smaller groups like BIER):

I find these strict timelines that MeetEcho introduces extremely terrible.

We had in BIER a poor presenter cut off just because we had a great presentation
and discussion in a slot in before and therefore ran out of time.

How is it possible that in a physcial meeting we are able to utilize all possible
before andd after meeting times, and now going virtual where we should have
FEWER time constraints, we enforce MORE ?

No, i don't think 10 minutes before/after is sufficient. I think it should be
AT MINIMUM IMHO 30 minutes on both sides, before and after.

Pls. do not understand this big criticism as a big criticism of the tool.
It is not. It is just a criticism of this feature. The tool itself is on a great trajectory!

Cheers
    Toerless

On Wed, Jul 29, 2020 at 03:46:46PM +0200, Tony Przygienda wrote:
> That's my 2nd middle name ...
> 
> lack-of-discipline is yours ;-)
> 
> -- tony
> 
> On Wed, Jul 29, 2020 at 3:34 PM Greg Shepherd <[email-masked]> wrote:
> 
> > Coward. :)
> >
> > On Wed, Jul 29, 2020 at 6:10 AM Tony Przygienda <[email-masked]>
> > wrote:
> >
> >> I think the 5 mins before hour cut-off keeps things tight and is a good
> >> thing ...
> >>
> >> -- tony
> >>
> >>
> >> On Wed, Jul 29, 2020 at 3:08 PM Jay Daley <[email-masked]> wrote:
> >>
> >>>
> >>>
> >>> On 30/07/2020, at 1:01 AM, Greg Shepherd <[email-masked]> wrote:
> >>>
> >>> Having them stay open 10min after, or even to the actual WG ending hour
> >>> would be great too. Not everyone is running off to the next meeting.
> >>>
> >>>
> >>> They can only be kept open for 5 minutes after the scheduled close of
> >>> the meeting as the same server/room is then used for another session and
> >>> the 5 minute gap is used to close down the audio stream and other tidying
> >>> up.
> >>>
> >>> Jay
> >>>
> >>>
> >>> Greg
> >>>
> >>> On Wed, Jul 29, 2020 at 3:54 AM Jay Daley <[email-masked]> wrote:
> >>>
> >>>>
> >>>>
> >>>> On 29/07/2020, at 10:47 PM, Tony Przygienda <[email-masked]>
> >>>> wrote:
> >>>>
> >>>> Topic says it all. Rather than scrambling to figure out whether
> >>>> audio/preso/internet works right @ beginning of session 10 minutes dry-run
> >>>> grace period would be very helpful
> >>>>
> >>>>
> >>>> They are now open 10 mins ahead of the session starting.  It wasn???t
> >>>> like that on day 1 but was changed for day 2 onwards.
> >>>>
> >>>> Jay
> >>>>
> >>>>
> >>>> -- tony
> >>>>
> >>>>
> >>>> --
> >>>> Jay Daley
> >>>> IETF Executive Director
> >>>> [email-masked]
> >>>>
> >>>>
> >>> --
> >>> Jay Daley
> >>> IETF Executive Director
> >>> [email-masked]
> >>>
> >>>

-- 
---
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Jul 2020 10:56:02 -0400

> FEWER time constraints, we enforce MORE ?

Poor chair discipline does sometimes result in chairs trying to run their meetings into the break. This is a failure on the part of the chairs, not a feature.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 29 Jul 2020 17:02:49 +0200

> Poor chair discipline does sometimes result in chairs trying to run their meetings into the break. This is a failure on the part of the chairs, not a feature.

Sure, but are we trying to virtualize our common experiences, requirements or
trying to create a more strict regime ?

I see far fewer reasons for strict meetecho session limits than there are fo physical rooms.

Sorry, but this makes totally no sense to me.

Cheers
    toerless

---

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Jul 2020 11:07:25 -0400

> I see far fewer reasons for strict meetecho session limits than there are fo physical rooms.

The reason is that we need a bio break and then to go to the next meeting. Forcing people to stay late or miss out is not a good solution.

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 29 Jul 2020 08:09:08 -0700

On the first day of IETF-108 Meetcho closed the SPRING WG meeting on the
clock. It was announced that five minutes grace period will be added. BIER
meeting, to the best of my knowledge, was closed not at +5 but -5 minutes.
Unannounced change of policy?

Regards,
Greg

On Wed, Jul 29, 2020 at 8:03 AM Toerless Eckert <[email-masked]> wrote:

> > Poor chair discipline does sometimes result in chairs trying to run
> their meetings into the break. This is a failure on the part of the chairs,
> not a feature.
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Jay Daley <[email-masked]>
Date: Thu, 30 Jul 2020 03:13:00 +1200

> On 30/07/2020, at 3:09 AM, Greg Mirsky <[email-masked]> wrote:
> 
> On the first day of IETF-108 Meetcho closed the SPRING WG meeting on the clock. It was announced that five minutes grace period will be added. BIER meeting, to the best of my knowledge, was closed not at +5 but -5 minutes. Unannounced change of policy?

Greg - are you sure it wasn’t five minutes before the top of the hour, which is five minutes after the meeting is scheduled to finish?

Jay

> 
> Regards,
> Greg
> 
> On Wed, Jul 29, 2020 at 8:03 AM Toerless Eckert <[email-masked] <mailto:[email-masked]>> wrote:
> > On Jul 29, 2020, at 10:48 AM, Toerless Eckert <[email-masked] <mailto:[email-masked]>> wrote:
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
> 
> Please report datatracker.ietf.org <http://datatracker.ietf.org/> and mailarchive.ietf.org <http://mailarchive.ietf.org/>
> bugs at http://tools.ietf.org/tools/ietfdb <http://tools.ietf.org/tools/ietfdb>
> or send email to [email-masked] <mailto:[email-masked]>
> 
> Please report tools.ietf.org <http://tools.ietf.org/> bugs at
> http://tools.ietf.org/tools/issues <http://tools.ietf.org/tools/issues>
> or send email to [email-masked] <mailto:[email-masked]>

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Wed, 29 Jul 2020 08:17:48 -0700

Jay,

> On Jul 29, 2020, at 8:13 AM, Jay Daley <[email-masked]> wrote:
> 

In the 6man session, it ran for 5 min 15 seconds after the scheduled end of the session.  Just as expected.

Bob

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 29 Jul 2020 08:18:51 -0700

Hi Jay,
it could be. I was not taking notes at the moment.

Regards,
Greg

On Wed, Jul 29, 2020 at 8:13 AM Jay Daley <[email-masked]> wrote:

> Greg - are you sure it wasn’t five minutes before the top of the hour,
> which is five minutes after the meeting is scheduled to finish?
>
> Jay
>
>
>
> Regards,
> Greg
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 29 Jul 2020 15:24:36 +0000

Good point, Toerless. For consideration post-108:
- It would be nice if each meeting session could have its own Meetecho conference ID/URL - rather than a small number that are shared. The key is to remove the limited number of shared rooms.
- Allow users to enter a meeting session 60 mins beforehand and for the session to run for 120 mins afterwards before the session terminates. (Seems logical that they must terminate to free up server resources - but enable some normal meeting time run over as well as post-meeting banter/wrap up.)

Jason

PS - I agree that MeetEcho has done a great job for 108! So these are minor suggestions to improve something already working quite well.

On 7/29/20, 10:54 AM, "WGChairs on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    Cheers
        Toerless

    --
    ---
    [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Jul 2020 11:27:52 -0400

> - Allow users to enter a meeting session 60 mins beforehand and for the session to run for 120 mins afterwards before the session terminates. (Seems logical that they must terminate to free up serv…

Please no. This would be a real abuse of the IETF process. A 120 minute meeting afterwards would be a side meeting, not the WG meeting. It should be handled explicitly as a side meeting.

If we want WGs to have more time, this isn’t the way to do it.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 29 Jul 2020 17:32:29 +0200

I think we where given 5 minutes in BIER.

But seriously,  5 minutes ? Are we working here or is this going to deteriorate
to something like a death-by-powerpoint on the clock sessions ?
This is not my practical experience from in-person meetings.

The last round of EU politication negotiations went over time by just a couple of days of real work.

Seriously: IMHO sessions could/should expand much more flexibly in a virtual environment:

Good chairs would try to manage time by asking the room when they see that they are tight
if/how attendees can stay over.

Chairs can also figure out if they can call quickly a WG side meeting when agenda overflows.
etc. pp. All of these things would be possible if WG chairs are given the authority to
create their own meeting sessions like it was possible with webex.

Sessions could start 30 minutes earlier for testing, chit/chat, p2p questions to chairs etc. pp.

Of course, WG chairs just serve on the pleasure of ADs, so i just raised this also with the IESG.

Cheers
    Toerless

On Thu, Jul 30, 2020 at 03:13:00AM +1200, Jay Daley wrote:
> Greg - are you sure it wasn???t five minutes before the top of the hour, which is five minutes after the meeting is scheduled to finish?
> 
> Jay
> 
> 
> > 
> > Regards,
> > Greg
> > 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 29 Jul 2020 17:36:31 +0200

Ted,

I need to check more how much of the usual in-between session break time we have in the
agenda. If it's similar, then we could emulate common physcial meeting experience to
allow past-meeting time for that period.

As said in other mail, we should ahve meetecho for ad-hoc WG side meetings later in the
week for specific topics. These where greeat in physcial meetings, albeit they where
not "official". But we have no way for non-chairs to set up a quick side meeting
without getting on top of all-private tooling. Hence WG-chairs could at least
help to set these up and allow them to use official WG tooling. Remember last such
side meeting being ANIMA/ACME and LAMPs derived...

Cheers
    Toerless

On Wed, Jul 29, 2020 at 11:27:52AM -0400, Ted Lemon wrote:
> If we want WGs to have more time, this isn???t the way to do it.
> 

-- 
---
[email-masked]

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 29 Jul 2020 08:45:59 -0700

It's okay, Toerless. He's probably never had you at the mic. :)

- Shep

---

From: Meetecho IETF support <[email-masked]>
Date: Wed, 29 Jul 2020 17:57:46 +0200

The BIER meeting has been closed 15 minutes after the scheduled end 
time. You can clearly see that from the Jabber logs:

	https://www.ietf.org/jabber/logs/bier/2020-07-29.html

See my message at 12:55:45.

Alessandro

Il 29/07/20 17:18, Greg Mirsky ha scritto:
> On Wed, Jul 29, 2020 at 8:13 AM Jay Daley <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
> 
>>     On 30/07/2020, at 3:09 AM, Greg Mirsky <[email-masked]
>>     <mailto:[email-masked]>> wrote:
>>
>>     On the first day of IETF-108 Meetcho closed the SPRING WG meeting
>>     on the clock. It was announced that five minutes grace period will
>>     be added. BIER meeting, to the best of my knowledge, was closed
>>     not at +5 but -5 minutes. Unannounced change of policy?
> 
>     Greg - are you sure it wasn’t five minutes before the top of the
>     hour, which is five minutes after the meeting is scheduled to finish?
> 
>     Jay
> 
> 
>>
>>     Regards,
>>     Greg
>>
>>         > Poor chair discipline does sometimes result in chairs trying
>>         to run their meetings into the break. This is a failure on the
>>         part of the chairs, not a feature.
>>
>>         Please report datatracker.ietf.org
>>         <http://datatracker.ietf.org/> and mailarchive.ietf.org
>>         <http://mailarchive..ietf.org/>
>>         <mailto:[email-masked]>
>>
>>         <mailto:[email-masked]>
>>
>>     Please report datatracker.ietf.org <http://datatracker.ietf.org>
>>     and mailarchive.ietf.org <http://mailarchive.ietf.org>
>>     bugs at http://tools..ietf.org/tools/ietfdb
>>     <http://tools.ietf.org/tools/ietfdb>
>>     <mailto:[email-masked]>
>>
>>     Please report tools.ietf.org <http://tools.ietf.org> bugs at
>>     or send email to webmaster@tools..ietf.org
>>     <mailto:[email-masked]>
> 
>     -- 
>     Jay Daley
>     IETF Executive Director
>     [email-masked] <mailto:[email-masked]>
> 
>

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 29 Jul 2020 09:07:25 -0700

The Meetecho session for the BIER meeting closed 5mins before the hour. I
could clearly see the Meetecho screen telling me the meeting was over.

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 29 Jul 2020 18:11:24 +0200

Il 29/07/20 18:07, Greg Shepherd ha scritto:
> The Meetecho session for the BIER meeting closed 5mins before the hour. 
> I could clearly see the Meetecho screen telling me the meeting was over.

Correct. And it was supposed to end 20 minutes before the hour as per 
the schedule, so it went 15 minutes overtime like I said ;).

A.

> On Wed, Jul 29, 2020 at 8:57 AM Meetecho IETF support <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     <mailto:[email-masked]>
>      > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >
>      >
>      >
>      >>     On 30/07/2020, at 3:09 AM, Greg Mirsky
>     <[email-masked] <mailto:[email-masked]>
>      >>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >>
>      >>     On Wed, Jul 29, 2020 at 8:03 AM Toerless Eckert
>     <[email-masked] <mailto:[email-masked]>
>      >>     <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >>
>      >>         > On Jul 29, 2020, at 10:48 AM, Toerless Eckert
>     <[email-masked] <mailto:[email-masked]>
>      >>         <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >>         > > How is it possible that in a physcial meeting we are
>     able
>      >>         to utilize all possible
>      >>         > > before andd after meeting times, and now going virtual
>      >>         where we should have
>      >>         > > FEWER time constraints, we enforce MORE ?
>      >>         >
>      >>         > Poor chair discipline does sometimes result in chairs
>     trying
>      >>         Sure, but are we trying to virtualize our common
>     experiences,
>      >>         requirements or
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     <http://datatracker.ietf.org>
>     <http://mailarchive.ietf.org>
>      >>         <http://mailarchive..ietf.org/ <http://ietf.org/>>
>      >>         <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >>
>      >>         Please report tools.ietf.org <http://tools.ietf.org>
>     <http://tools.ietf.org/> bugs at
>      >>         <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     <http://datatracker.ietf.org> <http://datatracker.ietf.org>
>     <http://mailarchive.ietf.org>
>     <http://ietf.org/tools/ietfdb>
>      >>     <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >>
>      >>     Please report tools.ietf.org <http://tools.ietf.org>
>     <http://tools.ietf.org> bugs at
>      >>     or send email to webmaster@tools..ietf.org <http://ietf.org>
>      >>     <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >
>      >     --
>      >     Jay Daley
>      >     IETF Executive Director
>      > [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >
>      >

-- 
Meetecho s.r.l.
www.meetecho.com

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 29 Jul 2020 18:12:03 +0200

yepp, it was generous enough, thanks

On Wed, Jul 29, 2020 at 6:11 PM [email-masked] <[email-masked]> wrote:

> >      >>         > On Jul 29, 2020, at 10:48 AM, Toerless Eckert
> >      >>         > > How is it possible that in a physcial meeting we are
> >     able
> >      >>         to utilize all possible
> >      >>         > > before andd after meeting times, and now going
> virtual
> >      >>         where we should have
> >      >>         I see far fewer reasons for strict meetecho session
> limits
> >      >>         than there are fo physical rooms.
> >      >>

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 29 Jul 2020 12:05:40 -0700

Well, years of in-person meetings, where 5min before the hour we are all
ejected, wholesale, scattered throughout the reception area to scrounge for
cookies, has certainly sharpened my timing skills to a tee. :)

That said, the meetecho performance was excellent and the ui was easy to
learn. Thanks!

- Shep

On Wed, Jul 29, 2020 at 9:12 AM Tony Przygienda <[email-masked]> wrote:

>> >      >>     or send email to webmaster@tools..ietf.org <http://ietf.org
>> >

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 30 Jul 2020 19:58:46 -0400

On Jul 29, 2020, at 10:48 AM, Toerless Eckert <[email-masked]> wrote:
> before andd after meeting times

Courteous chairs do not utilize all possible after meeting times, especially when they have a session following theirs. And yes, my groups have run over on occasion, but we try not to, and we try to clear the room afterwards.

Granted that this constraint wouldn’t appear to apply in the virtual world (although Jay says otherwise).

—John

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 31 Jul 2020 03:42:32 +0200

John,

I asked on a different thread about any technical reasons for the
necessity to end the sessions but did not receive a reply from meetecho. 

I am primarily concerned about unnecessary technical restrictions,
even if they match the model we had in physcial meetings for official
meeting times.

Your courteousity observation are correct for how we run our schedule
today, but a) we already have good uses for overtime within that courteosity,
and b) i do not like technology to stand in the way of us being able
to experiment and adopt to the virtual environment.

For example, with physical meeting rooms, they are a great informal
place to catch up with work when attendees join early. I am seeing this
regularily in physical IETFs on the first morning and afternoon meetings.
Likewise of course after the meetings, last meeting before lunch or in the
evening. Do we really need to argue overcoming every single unnecessry
technical limitation ?

Do i remember correctly a long time ago in some IETF meeting where the
venue decided to lock rooms outside of official meeting times, even
during lunch time ? This is a bit like that.

Thats just the rear view mirror. I am sure there are more courteous 
options for virtual rooms we have yet to explore.

For example, i am quite unhappy with official meeting time often
not being very productive because it deteriorates just into status
update time. But as chairs i think we fear claiming too much time of
WG attendees. Sp IMHO we as a group need to really think how to facilitate
more effective ad-hoc collab options. And voice/video channls through 
meetecho or webex are IMHO right now something attendees like latch onto
easier than gather.town.  

Cheers
   Toerless

On Thu, Jul 30, 2020 at 07:58:46PM -0400, John G. Scudder wrote:
> Granted that this constraint wouldn???t appear to apply in the virtual world (although Jay says otherwise).
> 
> ???John

-- 
---
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Fri, 31 Jul 2020 15:01:30 +1200

Toerless

First some background - there are a number of moving parts here that each impact each other:

1. The before/after periods for the rooms to be open.  

2.  The 'structure' of the agenda, which includes
- length of breaks between sessions
- length of the sessions
- overall length of the meeting day

The feedback from the meeting planning survey [1] led to a five day compressed format of shorter session length, shorter breaks  shorter days and a shorter day than an in-person meeting.  

3.  Conflicts between sessions.  This is an issue regularly identified by participants and significant resources go into assessing and preventing conflicts both operationally and in the development of our agenda tools.

4.  The resources to help people test/prepare, which includes
- pre-meeting sessions
- in-meeting test room
- pre-session set up time

5.  The sessions management skills of chairs and the support they get to develop those.  Training for chairs is an ongoing project and there was due to be a one-day training sessions for chairs before 107 that was unfortunately cancelled along with other things.

With that in mind, what follows are some of the questions that need to be thought through around extending the overrun after a session and, in particular, what impact will that have if it goes over the preparatory time for the next set of sessions or even the session time?  

- Does the agenda need to be structured to ensure that there are no conflicts from one session to the next, not just between parallel sessions?
- What impact will that have on the other sessions if people are unable to prepare?
- Is this going to be sufficiently common that the break needs to be extended and if so then is the working day extended or are the session lengths shortened?
- Could the pre-session preparatory times be shortened to allow for a longer overrun by expecting people to use the in-meeting test session to try things out?
- Should the choice of session lengths at 50/100 minutes be changed to better accommodate sessions that might overrun one of those lengths?
- Do the participants perceive the overruns as avoidable with better chairing skills?

To summarise, my point is not to say that the current setup is the best and cannot be tweaked, but to note that this is not a matter of just turning one knob up to 11 to fix a specific issue as that approach can have unintended consequences elsewhere.

Jay

[1] https://www.ietf.org/blog/ietf108-survey-results-informed-planning/

> On 31/07/2020, at 1:42 PM, Toerless Eckert <[email-masked]> wrote:
> 
> John,
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]