Subject: Re: [Tools-discuss] missing links in draft on tools.ietf.org

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 1 Jul 2020 18:39:07 +0200

Hi Dick,

Please see the list footer about reporting issues related to tools.ietf.org.

You'll get faster response that way ...

It looks like things broke a bit when -08 was submitted so soon after
-07 that the servers at tools.ietf.org didn't have time to sync it
from the master repository before it was gone.

I've updated the information about existing versions on the tools servers,
so things should look better now.

Regards,

	Henrik

On 2020-07-01 03:19, Dick Hardt wrote:
> Hello, checking in on this issue. Thanks!
> 
> On Wed, Jun 24, 2020 at 2:16 PM Dick Hardt <[email-masked]> wrote:
> 
>> Hello
>>
>> My draft-hardt-xauth-protocol drafts are not showing up correctly on
>> tools.ietf.org
>>
>> https://tools.ietf.org/html/draft-hardt-xauth-protocol
>>
>> properly redirects to
>>
>> https://tools.ietf.org/html/draft-hardt-xauth-protocol-10
>>
>> but there are no links to -07, -08, -09 at the top
>>
>> and any version shows up given the full URL, but 07 - 10 links are not
>> shown at the top, so someone with a full URL link will not know that -10 is
>> the latest.
>>
>> FYI: 07 - 10 where all published close together in time.
>>
>>
>> /Dick
>>
>> ᐧ
>>
> 
> 
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Dick Hardt <[email-masked]>
Date: Thu, 2 Jul 2020 10:00:02 -0700

Hi Henrik

Thanks for getting the issue!

FYI: The links are now fixed for 05 - 10. The 00 - 04 pages only list 00 -
06 versions in the header. The -02 version is what Google shows first, but
fortunately when someone clicks -06 they now see -10.

ALSO: I had sent an email to [email-masked] and got no response.
It was not clear to me how to file an issue at Trac.

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 2 Jul 2020 21:18:54 +0200

Hi Dick,

> fortunately when someone clicks -06 they now see -10.

The 00-04 pages will also be regenerated, with full information, but it
will take a little more time.  I didn't poke those manually.

> It was not clear to me how to file an issue at Trac.

Huh.  Ok; I guess it ran into the spam filter, then.  That doesn't happen
too often with mail from IETFers, but could happen.  I'll investigate.

	Henrik