Subject: [Tools-discuss] ics feeds -- default things

From: Michael Richardson <[email-masked]>
Date: Thu, 23 Jul 2020 15:14:42 -0400

I use https://datatracker.ietf.org/meeting/108/agenda.ics?group,group,group
to feed my calendar.  This includes a bunch of things that I didn't ask for:
  - Technology Deep Dive, Code Spring, AD Office Hours.
  These mostly don't bother me.

  - NOC Help Desk Hours.
  This bothers me, because I think that I'm busy every day :-)

I wonder if these extra items could be made into some kind of pseudo-group
that I could subscribe to?  I don't mind if it's in the URL by default.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Jim Fenton <[email-masked]>
Date: Thu, 23 Jul 2020 12:27:22 -0700

> that I could subscribe to?  I don't mind if it's in the URL by default.
On a related note, I haven't been able to find a way to get a .ics file
for just a given WG meeting. On the agenda, there's a set of buttons to
Download as .ics for each of the areas, but that gets me a lot of
meetings that I'm not interested in.

Or are there more people (besides the ADs) that are interested in all of
the meetings in a given area?

-Jim

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 23 Jul 2020 19:36:41 +0000

I would love to see an ICS icon for each individual agenda entry.

---

From: Robert Sparks <[email-masked]>
Date: Thu, 23 Jul 2020 14:46:34 -0500

> I would love to see an ICS icon for each individual agenda entry.
Come to saturday's sprint and make one!
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Thu, 23 Jul 2020 17:39:26 -0400

> for just a given WG meeting.

That's sorta related to my complaint about the extra stuff that is there:

%curl https://datatracker.ietf.org/meeting/108/agenda.ics?asdf | grep SUMMARY
SUMMARY:Hackathon Kickoff
SUMMARY:IEPG Meeting
SUMMARY:Newcomers' Quick Connections (Open to Newcomers. https://ietf.gather.town/z6N2SDxHebMdDAfo/IETF-108)
SUMMARY:Technology Deep Dive: DNS
SUMMARY:Hackathon Closing
SUMMARY:TSV AD Office Hours
SUMMARY:Code Sprint
SUMMARY:NOC Help Desk Hours
SUMMARY:NOC Help Desk Hours
SUMMARY:IANA Office Hours
SUMMARY:RFC Editor Office Hours
SUMMARY:NOC Help Desk Hours
SUMMARY:Newcomers' Coffee Break
SUMMARY:asdf - A Semantic Definition Format for Data and Interactions of Things
SUMMARY:IANA Office Hours
SUMMARY:RFC Editor Office Hours
SUMMARY:NOC Help Desk Hours
SUMMARY:IANA Office Hours
SUMMARY:RFC Editor Office Hours
SUMMARY:IETF Plenary
SUMMARY:NOC Help Desk Hours
SUMMARY:IANA Office Hours
SUMMARY:RFC Editor Office Hours
SUMMARY:Newcomers' Coffee Break
SUMMARY:NOC Help Desk Hours

You are right, that there isn't a way to get them for an area, except by
enumerating them all.  Most ADs will want just the WGs that they are
responsible for, and that's not every group in the area.

And that's likely not their entire list of things to do either.

---

From: Lars Eggert <[email-masked]>
Date: Fri, 24 Jul 2020 09:21:24 +0300

>  This bothers me, because I think that I'm busy every day :-)

+1

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 24 Jul 2020 13:02:42 +0200

Hi Jim,

> meetings that I'm not interested in.

There are links to individual files off of each group's 'Meetings' tab, e.g.,

  https://datatracker.ietf.org/group/sacm/meetings/

and also off of each session materials page; e.g., 

  https://datatracker.ietf.org/meeting/108/session/sacm

On the latter page there are 2 icons: one top right, a calendar month icon,
which leads to all sessions for the meeting, and one at the right of the
icon line to the right of the session date; that's for that session only.

I did discuss putting individual session icons on the main agenda page some
time ago (when I put in place the ones on the session materials pages), but
we were a bit hesitant to do so, since there were already a long line of
icons for each session.

FWIW, after that discussion I did some visual de-cluttering of the main
agenda page by removing the borders around each individual icon in the
per-session icon link line, so maybe it would be more acceptable to add
an .ics link now.

Best regards,

	Henrik

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 14:16:16 +0000

Right now it's 50-50 odds of me being there today.  Sorry.

On 7/24/20, 7:03 AM, "Henrik Levkowetz" <[email-masked]> wrote:

    Hi Jim,

    Best regards,

    	Henrik