Subject: [Tools-discuss] A couple meetecho annoyances

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Jul 2020 15:54:41 +0200

# Annoyances, part N+1

When you have a private chat, and the peer leaves (often people announce just that in a private chat), the dismiss button gets grayed out with the rest of the chat window, so you can’t get rid of it.  Less space for videos (which is already too small).

The Chiron (title) under the screen sharing (which is good!) actually obscures part of the slides.  That is supposed to go away, but in some cases just doesn’t.

The queueing system makes the current speaker appear at the end of the list, at least most of the time. The new speaker jumps from the top of the queue to the end of the “sending media” list.  That requires cognitive effort to follow.  (See also speaker indication below.)

"Open in new tab" on the “show note taking tool” icon creates another meetecho window that tries to log me in.  Why can’t it take me to codimd?

Lots of chairs’ clicks to the queue/media list go to the wrong field as that expands and shrinks all the time while people are clicking.  Again, wrong order…

Make sure that the defaults are set for each form, i.e. press enter for “Join using datatracker account” (and why doesn’t it just try???), yes I want my hum to take, ...

Besides a hum tool, a polling tool (with a non-anonymous option) would speed up some things (“who is willing to review”…).  Again, see BBB how to do this right.
Right now, people fake audio requests to get in the “YES” list, ouch.

# Things that have been said before:

Video or screen sharing needs to imply audio, unless explicitly switched off.
How about a MUTE BUTTON, which also can be used to retain speaker rights while muting for hearing a question?

The media request icons are WAY TOO SMALL, with the important part white on light blue.

The hum tool icon is not a musical note, which it should be; “HUM” also would work.

Absolutely essential: Speaker indication.  
Who is speaking?  I’ve heard chairs ask that question because they couldn’t find out either.
(Look at 1992’s vat tool or BigBlueButton to get this right, it’s NOT trivial.)

---

From: Michael Richardson <[email-masked]>
Date: Tue, 28 Jul 2020 10:33:10 -0400

Carsten Bormann <[email-masked]> wrote:
    > Besides a hum tool, a polling tool (with a non-anonymous option) would
    > speed up some things (“who is willing to review”…).  Again, see BBB how
    > to do this right.

Also, for this query, it would be nice if it stayed on the screen somewhere
until the chairs dismiss it.

    > Right now, people fake audio requests to get in the “YES” list, ouch.

:-)

    > Video or screen sharing needs to imply audio, unless explicitly

There are definitely some uses when this does not work.
Having a panel of people with video on, but locally muted makes sense.
So really, I agree with you: it should imply audio PERMISSION, but then let
me locally mute.

    > How about a MUTE BUTTON, which also can be used to retain speaker
    > rights while muting for hearing a question?

Agreed.

    > The hum tool icon is not a musical note, which it should be; “HUM” also would work.

My experience is that 30s is just too short for most people.

    > Absolutely essential: Speaker indication.

Yes. Three things:
1) who is speaking for everyone else to see.
2) I am speaking feedback (already there)
3) the network is receiving me (needed)

I would suggest that the mixer calculate the MOS (ITU-T PESQ P.862 ) on the
data it receives, and feed this back to the speaker.  Anything less than 1
means that the uplink is broken.
I would further suggest that every receiver calculate the MOS on received
data, and then send that to the mixer.

a) anyone whose receive MOS is two sigmas out from the average would get
   signaled that they have downlink issues.
b) the average of all speakers would be reported to everyone.

This won't help us solve the problems that various people have, but would at
least help people realize if it is their rig, or the sender's rig, or
something else.

    > (Look at 1992’s vat tool or BigBlueButton to get this right, it’s NOT trivial.)

Yes.  Maybe you can share some screen shots.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 28 Jul 2020 15:21:19 +0000

>    The Chiron (title) under the screen sharing (which is good!) actually obscures part of the slides.  That is supposed to go away, but in some cases just doesn’t.

You have to move your cursor to one of the (unmarked, no border) side panels like the chat or the far right.

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 28 Jul 2020 20:52:33 +0200

Hi Carsten,

> When you have a private chat, and the peer leaves (often people announce just that in a private chat), the dismiss button gets grayed out with the rest of the chat window, so you can’t get rid of i…

this has been fixed already. Maybe your browser was caching the 
javascript files? You may want to try a hard refresh if this happens again.

> The Chiron (title) under the screen sharing (which is good!) actually obscures part of the slides.  That is supposed to go away, but in some cases just doesn’t.

This is exactly the reason why tooltips don't appear on top of the 
elements but in a well-defined position...

> The queueing system makes the current speaker appear at the end of the list, at least most of the time. The new speaker jumps from the top of the queue to the end of the “sending media” list.  That…

Noted. I do agree that moving people from top of the queue to top of the 
sending media list is better.

> "Open in new tab" on the “show note taking tool” icon creates another meetecho window that tries to log me in.  Why can’t it take me to codimd?

Because that's an iframe.

> Lots of chairs’ clicks to the queue/media list go to the wrong field as that expands and shrinks all the time while people are clicking.  Again, wrong order…

Noted.

> Make sure that the defaults are set for each form, i.e. press enter for “Join using datatracker account” (and why doesn’t it just try???), yes I want my hum to take, ...

Noted.

> Right now, people fake audio requests to get in the “YES” list, ouch.

Noted, but it's not our call which new tools (if any) will be 
implemented in future versions.

> How about a MUTE BUTTON, which also can be used to retain speaker rights while muting for hearing a question?

Yet another mic button to mute locally? I've heard A LOT of complains 
about having too many buttons already...

> The media request icons are WAY TOO SMALL, with the important part white on light blue.

Noted.

> The hum tool icon is not a musical note, which it should be; “HUM” also would work.

Noted.

> (Look at 1992’s vat tool or BigBlueButton to get this right, it’s NOT trivial.)

On our todo list already.

Cheers,
Alessandro

> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Jul 2020 22:56:02 +0200

Hi Alessandro,

Thanks for the quick reply.

Let me add three additional comments...

> On 2020-07-28, at 20:52, Meetecho IETF support <[email-masked]> wrote:
> 

That’s equivalent to “that’s how we implemented it”.

This should be a native a/href to codimd (on _blank), with Javascript overlaid that takes you to the iframe.  So if I use the browser right click, I get the native href, and if I click normally, I get the JavaScript effect.

>> Lots of chairs’ clicks to the queue/media list go to the wrong field as that expands and shrinks all the time while people are clicking. Again, wrong order…

Maybe keeping some “history” (instead of being deleted, field loses its color and slides closed) would help.
(That could also help with making the speaker indication sticky for a few seconds.)

> Yet another mic button to mute locally? I've heard A LOT of complains about having too many buttons already…

I know, but there are just too many different special requirements, and a single-click button for joining the queue with the right requests set is valuable.

Grüße, Carsten

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 28 Jul 2020 23:05:19 +0200

> That’s equivalent to “that’s how we implemented it”.

Indeed, that's how it's currently implemented.

> This should be a native a/href to codimd (on _blank), with Javascript overlaid that takes you to the iframe.  So if I use the browser right click, I get the native href, and if I click normally, I…

This is a very good suggestion and should also be easy enough to 
implement in the next version.

> (That could also help with making the speaker indication sticky for a few seconds.)

The plan is to slowly fade them out rather then moving abruptly from 
queue to sending media.

-- 
Meetecho s.r.l.
www.meetecho.com