Subject: [Tools-discuss] Mailman login vs. datatracker login

From: Carsten Bormann <[email-masked]>
Date: Sun, 9 Aug 2020 14:57:24 +0200

It is a bit hard to search for mailman issues in tools-discuss (every message contains “mailman”), so I apologize if this is a repeat:

Are we up now for a future where we can couple our mailman logins to our datatracker logins? Today, mailman passwords need to be all different because they are shared with different groups.  However, they cannot use normal password manager support.
Not needing to remember them would be a step forward.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Sun, 09 Aug 2020 16:29:44 -0400

Carsten Bormann <[email-masked]> wrote:
    > However, they
    > cannot use normal password manager support.

Specifically, since mailman does not have a "username" equivalent field, the
browser password managers can not distinguish passwords for different lists.
Chrome will let me input a "username" when I save the password, but I still
have to find the right password each time.

If there is a patch upstream in mailman, I haven't seen it yet.
There is some discussion that google finds, which says that there is nothing.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Ted Lemon <[email-masked]>
Date: Sun, 9 Aug 2020 16:49:09 -0400

I just never save or use that password. What do you need it for?

> On Aug 9, 2020, at 4:29 PM, Michael Richardson <[email-masked]> wrote:
> 
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Jay Daley <[email-masked]>
Date: Mon, 10 Aug 2020 08:53:59 +1200

> On 10/08/2020, at 12:57 AM, Carsten Bormann <[email-masked]> wrote:
> 

An even better way forward would be for you to manage your mailing list subscriptions from within Datatracker as that can provide an overall view and consistency check that is not available anywhere in the mailman interface.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 10 Aug 2020 09:55:21 +1200

> mailman passwords need to be all different because they are shared with different groups

Do you mean admin passwords? Subscription passwords can be all the same, if you accept the obvious risk.

Regards
   Brian

---

From: "Paul Hoffman" <[email-masked]>
Date: Sun, 09 Aug 2020 15:07:26 -0700

On 9 Aug 2020, at 13:53, Jay Daley wrote:

>> It is a bit hard to search for mailman issues in tools-discuss (every 
>> message contains “mailman”), so I apologize if this is a repeat:
>>
>> Are we up now for a future where we can couple our mailman logins to 
>> our datatracker logins? Today, mailman passwords need to be all 
>> different because they are shared with different groups.  However, 
>> they cannot use normal password manager support.
> An even better way forward would be for you to manage your mailing 
> list subscriptions from within Datatracker as that can provide an 
> overall view and consistency check that is not available anywhere in 
> the mailman interface.

Are you saying that aspirationally? Otherwise, I don't see how to do 
that, although I could clearly be missing something.

--Paul Hoffman

---

From: Jay Daley <[email-masked]>
Date: Mon, 10 Aug 2020 10:12:51 +1200

Yes aspirationally - that would be a better direction to go than attempting to add oauth to mailman. 

-- 
Jay Daley
IETF Executive Director

> On 10/08/2020, at 10:07 AM, Paul Hoffman <[email-masked]> wrote:
> 
> Are you saying that aspirationally? Otherwise, I don't see how to do that, although I could clearly be missing something.
> 
> --Paul Hoffman
>

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 9 Aug 2020 23:36:14 +0000

Yes, havng a dummy/unused username field would help password managers a great deal.  I've asked for that before but maybe not in the right places.

---

From: Michael Richardson <[email-masked]>
Date: Sun, 09 Aug 2020 19:51:35 -0400

> I just never save or use that password. What do you need it for?

yes, there is also a per-list, mailman membership password, but I'm not
talking about that.
If you are the list moderator (WG chair), then you might need to do things.