Subject: [Tools-team] Requirement Specification - I-D Submission Tool, IETF Secretariat Part

From: Michael Lee <[email-masked]>
Date: Wed, 01 Sep 2004 10:22:51 -0400

Dear TOOLS Team Members:

Attached is the Secretariat's draft Software Requirements Specification 
(SRS) for the I-D Submission and Posting Tool.  The requirements assume 
that the tool will implement the procedures that the Secretariat 
currently uses to process Internet-Drafts.  Please note that the SRS 
does not include requirements for features that the TOOLS Team is 
already addressing in the initial draft of its proposed I-D 
"draft-ietf-tools-draft-submission," for example, requirements for 
validation of I-Ds and authentication of submitters.

Please let us know if you have any questions or comments about this SRS.

Regards,

Michael.
_______________________________________________
Tools-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-team

---

From: Alex Rousskov <[email-masked]>
Date: Wed, 1 Sep 2004 12:19:12 -0600 (MDT)

Michael,

 	Thank you for generating this SRS on such a short notice! 
Could you please post a plain text or HTML version? It is awkward for 
me to read MS Word files (but I can find a MS Windows box if the 
document depends on Word-exclusive features).

Thank you,

Alex.

On Wed, 1 Sep 2004, Michael Lee wrote:

> Dear TOOLS Team Members:
>
> Attached is the Secretariat's draft Software Requirements Specification (SRS) 
> for the I-D Submission and Posting Tool.  The requirements assume that the 
> tool will implement the procedures that the Secretariat currently uses to 
> process Internet-Drafts.  Please note that the SRS does not include 
> requirements for features that the TOOLS Team is already addressing in the 
> initial draft of its proposed I-D "draft-ietf-tools-draft-submission," for 
> example, requirements for validation of I-Ds and authentication of 
> submitters.
>

---

From: Michael Lee <[email-masked]>
Date: Wed, 01 Sep 2004 14:48:08 -0400

I converted this file to Web format using MS Word.
Try attached file and let me know how it works for you.

Michael

Alex Rousskov wrote:

> Michael,
>
>     Thank you for generating this SRS on such a short notice! Could 
> you please post a plain text or HTML version? It is awkward for me to 
> read MS Word files (but I can find a MS Windows box if the document 
> depends on Word-exclusive features).
>
> Thank you,
>
> Alex.
>
>
>> Attached is the Secretariat's draft Software Requirements 
>> Specification (SRS) for the I-D Submission and Posting Tool.  The 
>> requirements assume that the tool will implement the procedures that 
>> the Secretariat currently uses to process Internet-Drafts.  Please 
>> note that the SRS does not include requirements for features that the 
>> TOOLS Team is already addressing in the initial draft of its proposed 
>> I-D "draft-ietf-tools-draft-submission," for example, requirements 
>> for validation of I-Ds and authentication of submitters.
>>
Software Requirements Specification

I-D Submission Tool (IETF Secretariat Part)

I.
Meta Data

Field Name

Rule

I-D Title

Title of I-D should match the title in the I-D text.

Filename

Filename (draft-ietf-<wg acronym>-… for a WG submission and
draft-<author’s last name>-… for an individual submission) should match
the filename in the I-D text.

Version

I-D version number (in “NN” format where N is a numeric character):

- should match the version number in the I-D text.

- should be either “00” (for a new I-D) or a number that is one greater
than the version number of the latest version of the existing I-D (for an
update).

WG Acronym

WG acronym (only required for a WG submission) should match the WG
acronym part of the filename (see “Filename” above).

Number of Pages

Numeric value.

Abstract

I-D Abstract text.

List of Authors

Rules are specified in Section V below.

II.
I-D Text

1.      Copy and Paste Method

·
A text area will be provided so that an author can
copy and paste the entire text of the I-D that is being submitted.

o
Only good for plain text.

o
Required field.

2.      Upload method

·
An author can choose an I-D from his or her computer’s
local file system and upload it.

o
Only accept .txt, .ps, .pdf, and .xml file types.

o
.txt file of I-D MUST be submitted.

o
Can upload up to all four different file types of same
I-D.

o
Validation NOT required for .ps, .pdf, and .xml file
types.

III.
I-D Approval and Posting

If an I-D is new (i.e., version -00) and is the
product of a WG, then the I-D must be approved by a WG chair in order to be
posted.  In such a case, after the author
submits all of the Meta Data and the I-D text, the tool will display a screen
with the names of the chairs of the WG whose acronym is specified in the Meta
Data template.  The author then selects a
WG chair to approve the I-D for posting.

When the WG chair has been selected, an email message will be sent to that WG
chair along with a randomly generated seed.
The selected WG chair can simply reply to the message if he or she
approves the I-D for posting. The system will verify the approval message by
matching the returned seed with the one stored in the system.  Once an approval message is verified, the I-D
that was submitted previously will be posted and an announcement will be sent.

Independent submissions and updates to WG
submissions do not require approval by a WG chair prior to posting.  These I-Ds will be posted and announced
immediately.

IV.
Changes to Revised I-D

An author is not allowed to change the filename
when submitting a revised I-D (i.e., version -01 or higher).  If the author wants to change the filename,
then he or she must submit a new version -00 I-D.

V.
Authors

Two fields will be provided for entering an
author’s name: one for the first name and one for the last name.  Five sets of these two fields will be provided
to accommodate multiple authors.  When
the names of the authors have been entered, the next screen will be used to confirm,
update, or enter their email address(es).
The system will display the email addresses of any authors whose
information has been entered previously, and will provide empty fields for
those who are new to the system.  The
submitter can confirm, update, or enter the email addresses of the authors, as
appropriate.

VI.
I-D Status and Version Number

All I-Ds that are posted to the I-D database
via this tool will have a status of “Active.”

There are five possible cases:

1.      Submission of a New
I-D – When a version -00 I-D is posted, its status will always be “Active.”

2.      Submission of an
Update to an “Active” I-D – When a version -01 or higher I-D that updates an
“Active” I-D is posted, its status will always be “Active.”

3.      Replacing an “Active”
I-D with a New I-D – Via this tool, one can replace an active I-D with a new
I-D with a different filename.  The
status of the new I-D will always be “Active.” The following actions will be
performed:

The status
of the existing I-D will be changed from “Active” to “Replaced by
<filename of new I-D>.”

A
tombstone for the replaced I-D, whose version number is one greater than
that of the I-D itself, will be created in the I-D directory.

The
replaced I-D will be moved to the I-D archives.

4.      I-D Resurrection
– Via this tool, one can resurrect an I-D that was previously expired.  The following actions will be performed:

The status
of the I-D will be changed from “Expired” to “Active.”

The most
recent version of the I-D (i.e., one version before the tombstone) will
be restored to the I-D directory from the I-D archives.

The tombstone
will be deleted.

5.      I-D Resurrection
with New Version – Via this tool, one can resurrect and update an I-D that was
previously expired.  If one submits a
revised version of an expired I-D, then the following actions will be
performed:

·
The status of the I-D will be changed from “Expired” to
“Active.”

·
The updated I-D will be assigned the same version
number as the tombstone that was created when the I-D was expired.

·
The updated I-D will replace the tombstone in the I-D
directory.

Via this tool, the author or the IESG can
withdraw an “Active” I-D.  The following
actions will be performed:

·
The status of the I-D will be changed from “Active” to
“Withdrawn by the submitter” or “Withdrawn by the IETF,” as appropriate.

·
A tombstone for the withdrawn I-D, whose version
number is one greater than that of the I-D itself, will be created in the I-D
directory.

·
The withdrawn I-D will be moved to the I-D archives.

VII.
Dates

1.      New Date – Date that
version -00 was submitted. This date will be automatically set to the date that
the I-D is being submitted.

2.      Revision Date –
Date that revised I-D was submitted. This will be automatically set to the date
that the I-D is being submitted.

3.      Expiration Date –
Date that the I-D expires.  The system
will calculate this date by adding 185 days (equivalent to 6 months) to the
date that the I-D was submitted.

VIII.
Requesting Publication via I-D Submission Tool
(Suggested Feature)

Using this tool, one can request that an I-D be
published as an RFC and added to the I-D Tracker in state “Publication
Requested.” Only WG chairs would be able to request publication of I-Ds that
are products of their WGs.  Independent
authors would be able to request publication of standards-track documents and
BCPS.  If the TOOLS Team is interested in
including this feature in the I-D submission tool, then the Secretariat will
provide more detailed specifications.

---

From: Alex Rousskov <[email-masked]>
Date: Wed, 1 Sep 2004 13:34:55 -0600 (MDT)

> Try attached file and let me know how it works for you.

Thank you, I can read it. I will start working on incorporating your 
requirements and reconciling our differences in our ID Submission 
draft.

Alex.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 01 Sep 2004 21:34:51 +0200

> Try attached file and let me know how it works for you.

Looks good to me, Michael.  Much more easily accessible.
And Thunderbird converted the HTML to text in turn, for
this reply (see below :)

	Henrik

> ------------------------------------------------------------------------
> 
> *Software Requirements Specification*
> 
> I.                    Meta Data
> *Field Name*
> *Rule*
> than the version number of the latest version of the existing I-D (for 
> an update).
> 
> WG Acronym
> 
> 	
> 
> II.                 I-D Text
> ·        A text area will be provided so that an author can copy and 
> paste the entire text of the I-D that is being submitted.
> 
> o       Only good for plain text.
> 
> o       Required field.
> 
> 2.      Upload method
> 
> ·        An author can choose an I-D from his or her computer’s local 
> file system and upload it.
> 
> o       Only accept .txt, .ps, .pdf, and .xml file types.
> 
> o       .txt file of I-D MUST be submitted.
> 
> o       Can upload up to all four different file types of same I-D.
> 
> o       Validation NOT required for .ps, .pdf, and .xml file types.
> 
>  
> 
> III.               I-D Approval and Posting
> 
> If an I-D is new (i.e., version -00) and is the product of a WG, then 
> the I-D must be approved by a WG chair in order to be posted.  In such a 
> case, after the author submits all of the Meta Data and the I-D text, 
> the tool will display a screen with the names of the chairs of the WG 
> whose acronym is specified in the Meta Data template.  The author then 
> selects a WG chair to approve the I-D for posting.
> 
> When the WG chair has been selected, an email message will be sent to 
> that WG chair along with a randomly generated seed.  The selected WG 
> chair can simply reply to the message if he or she approves the I-D for 
> posting. The system will verify the approval message by matching the 
> returned seed with the one stored in the system.  Once an approval 
> message is verified, the I-D that was submitted previously will be 
> posted and an announcement will be sent.
> 
> Independent submissions and updates to WG submissions do not require 
> approval by a WG chair prior to posting.  These I-Ds will be posted and 
> announced immediately.
> 
>  
> 
> IV.              Changes to Revised I-D
> 
> An author is not allowed to change the filename when submitting a 
> revised I-D (i.e., version -01 or higher).  If the author wants to 
> change the filename, then he or she must submit a new version -00 I-D.    
> 
>  
> 
> V.                 Authors
> 
> Two fields will be provided for entering an author’s name: one for the 
> first name and one for the last name.  Five sets of these two fields 
> will be provided to accommodate multiple authors.  When the names of the 
> authors have been entered, the next screen will be used to confirm, 
> update, or enter their email address(es).  The system will display the 
> email addresses of any authors whose information has been entered 
> previously, and will provide empty fields for those who are new to the 
> system.  The submitter can confirm, update, or enter the email addresses 
> of the authors, as appropriate.
> 
>  
> 
> VI.              I-D Status and Version Number
> 
> All I-Ds that are posted to the I-D database via this tool will have a 
> status of “Active.”
> 
> 1.      Submission of a New I-D – When a version -00 I-D is posted, its 
> status will always be “Active.”
> 
> 2.      Submission of an Update to an “Active” I-D – When a version -01 
> or higher I-D that updates an “Active” I-D is posted, its status will 
> always be “Active.”
> 
> 3.      Replacing an “Active” I-D with a New I-D – Via this tool, one 
> can replace an active I-D with a new I-D with a different filename.  The 
> status of the new I-D will always be “Active.” The following actions 
> will be performed:
> 
>           * The status of the existing I-D will be changed from “Active”
>             to “Replaced by <filename of new I-D>.”
>           * A tombstone for the replaced I-D, whose version number is
>             one greater than that of the I-D itself, will be created in
>             the I-D directory.
>           * The replaced I-D will be moved to the I-D archives.
> 
> 4.      I-D Resurrection – Via this tool, one can resurrect an I-D that 
> was previously expired.  The following actions will be performed:
> 
>           * The status of the I-D will be changed from “Expired” to
>             “Active.”
>           * The most recent version of the I-D (i.e., one version before
>             the tombstone) will be restored to the I-D directory from
>             the I-D archives.
>           * The tombstone will be deleted.
> 
> 5.      I-D Resurrection with New Version – Via this tool, one can 
> resurrect and update an I-D that was previously expired.  If one submits 
> a revised version of an expired I-D, then the following actions will be 
> performed:
> 
> ·        The status of the I-D will be changed from “Expired” to “Active.”
> 
> ·        The updated I-D will be assigned the same version number as the 
> tombstone that was created when the I-D was expired.
> 
> ·        The updated I-D will replace the tombstone in the I-D directory.
> 
> Via this tool, the author or the IESG can withdraw an “Active” I-D.  The 
> following actions will be performed:
> 
> ·        The status of the I-D will be changed from “Active” to 
> ·        A tombstone for the withdrawn I-D, whose version number is one 
> greater than that of the I-D itself, will be created in the I-D directory.
> 
> ·        The withdrawn I-D will be moved to the I-D archives.
> 
>  
> 
> VII.            Dates
> 
> 1.      New Date – Date that version -00 was submitted. This date will 
> be automatically set to the date that the I-D is being submitted.
> 
> 2.      Revision Date – Date that revised I-D was submitted. This will 
> be automatically set to the date that the I-D is being submitted.
> 
> 3.      Expiration Date – Date that the I-D expires.  The system will 
> calculate this date by adding 185 days (equivalent to 6 months) to the 
> VIII.         Requesting Publication via I-D Submission Tool (Suggested 
> Feature)
> 
>  
> 
> Using this tool, one can request that an I-D be published as an RFC and 
> added to the I-D Tracker in state “Publication Requested.” Only WG 
> chairs would be able to request publication of I-Ds that are products of 
> their WGs.  Independent authors would be able to request publication of 
> standards-track documents and BCPS.  If the TOOLS Team is interested in 
> including this feature in the I-D submission tool, then the Secretariat 
> will provide more detailed specifications.
> 
> 
> ------------------------------------------------------------------------
>