Subject: [Tools-team] Update TOOLS-team charter proposal

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Jun 2005 19:21:45 +0200

Hi,

I've put together a proposal for an updated TOOLS-team charter
which includes a IETF website reorganisation proposal as a work-item,
as well as another item requested by Brian.  The proposal is here: 

  http://tools.ietf.org/charters/charter-2005-06-17.html

Comments are welcome.

Regards,

	Henrik

_______________________________________________
Tools-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-team

---

From: Larry Masinter <[email-masked]>
Date: Fri, 17 Jun 2005 10:40:24 -0700

I am somewhat more animated by the prospects of tools for
RFC, Standards, BCP, Interoperability, IPR information, 
which I think is more narrow and perhaps has a different
audience than the general "improving usability of the
IETF web site" question.

Personally, I think many of the requirements that
NEWTRK is struggling with could be partially addressed
by better web-based information on the status of
IETF standards and related documents. But NEWTRK
is chartered only to look at "changes to standards
process", so I think that "tools for working with
web-based information" is probably in the domain
of this group instead.

Secondly, I wish it were in scope to look at IANA tools,
while we're looking at tools. The IANA registry
information is very hard to use and hard to
figure out how to update.

Larry

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Jun 2005 20:17:36 +0200

Hi Larry,

  For your second point, it seems like the opportunities
to look at IANA tools may come, as a result of the Admin
Reorg., but we're not there quite yet.

For the first point, I guess all of the areas you mention
are in scope.  Is there a particular tool you'd like to
take on, to specify or prototype, among these?

	Henrik

---

From: Larry Masinter <[email-masked]>
Date: Fri, 17 Jun 2005 16:49:14 -0700

# Is there a particular tool you'd like to
# take on, to specify or prototype, among these?

Well, looking through the 'newtrk' mailing list archive,
I think I might start with:

"Means of reporting implementations and interoperability,
feature-by-feature:"

http://darkwing.uoregon.edu/~llynch/newtrk/msg01109.html

but I'd also like to consider "means of reporting relationship
between RFCs and 'sub-areas'".

http://www.ietf.org/internet-drafts/draft-ietf-newtrk-repurposing-isd-03.txt

Larry

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 20 Jun 2005 21:48:03 +0200

> http://darkwing.uoregon.edu/~llynch/newtrk/msg01109.html

Sounds good.  Go for it.

> http://www.ietf.org/internet-drafts/draft-ietf-newtrk-repurposing-isd-03.txt

Well, I'll leave it up to you to decide if you go for this
one, too :-)

	Henrik

---

From: Alex Rousskov <[email-masked]>
Date: Wed, 22 Jun 2005 10:00:49 -0600

> > http://darkwing.uoregon.edu/~llynch/newtrk/msg01109.html

I hope the interface will include compliance claims in addition to
interoperability claims. You have probably seen my rants why one is
pretty much pointless without the other.

It may also be a good idea to add "implementation comments" or similar
interface.

In other words, we need a "feature-indexed" reporting tool, with several
kinds of "reports" attached to each protocol feature of interest.

It would be interesting to see how we can solve the
feature-versus-requirement scoping problem (each level may be important
depending on the protocol or even implementation).

Alex.