Subject: [Tools-team] Event schema

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 30 Aug 2005 01:01:17 +0200

Hi,

  Here is a proposal for a schema for an xml representation of an
event.  This only covers events related to drafts; events related
to WGs or other entities would need an alternative object element
schema.

------------------------------------------------------------------------
element event {
    element id { text }			# text should be an uuid:
    & element date { text }		# text should be an RFC 3339 date
    & element source { text }		# tag identifying the source
    & element object {
	element type { text }		# tag identifying the type, e.g. draft
	& element tag { text }		# draft filename without extension and version
	& element date { text }		# an RFC 3339 date
	& element rev { xsd:integer }
	& element authors { text }?
	& element title { text }?
	& element abstract { text }?
	& element state { text }	# a state text tag
	& element substate { text }?	# a sub-state text tag
	& element pages { xsd:integer }?
	& element url { text }?		# an url

    }
}
------------------------------------------------------------------------

Here's a recent sample extracted from the ID-tracker:

------------------------------------------------------------------------
  <event xmlns="http://tools.ietf.org/xmlns/events/0.1">
    <id>uuid:2e840e42-18db-11da-9ea0-00b0d0b07e87</id>
    <date>2005-08-30T00:20+02:00</date>
    <source>tracker</source>
    <object>
      <type>draft</type>
      <tag>draft-ietf-secsh-dh-group-exchange</tag>
      <date>2005-08-29</date>
      <rev>05</rev>
      <state>Approved-announcement_sent</state>
    </object>
  </event>
------------------------------------------------------------------------

	Henrik

_______________________________________________
Tools-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-team

---

From: Larry Masinter <[email-masked]>
Date: Mon, 29 Aug 2005 20:08:06 -0700

If you're going to use XML, shouldn't you use XML datatypes?

>     element id { text }			# text should be an uuid:

Why not anyURI
http://www.w3.org/TR/2004/REC-xmlschema-2-20041028/datatypes.html#anyURI 

which can be a UUID URN?

>     & element date { text }		# text should be an RFC 3339 date

why not 
http://www.w3.org/TR/2004/REC-xmlschema-2-20041028/datatypes.html#date

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 30 Aug 2005 09:08:41 +0200

> If you're going to use XML, shouldn't you use XML datatypes?

Yes :-)

But I'm not that experienced in XML, and when I looked through
the xsd: types in XML Schema Datatypes I didn't find anything
appropriate, and I wanted to get this out fast.  Of course, with
your advise below in hand, I know that there's a Second Edition,
and I looked in the first...

> http://www.w3.org/TR/2004/REC-xmlschema-2-20041028/datatypes.html#anyURI 

Because I actually want a time-based uuid, specifically; permitting
extraction of event generation time from the uuid.  But apart from
that, anyURI is pretty close.

> http://www.w3.org/TR/2004/REC-xmlschema-2-20041028/datatypes.html#date

Mmm - I think it's an xsd:dateTime for the event, and an xsd:date for
the object.

Here's an update - I'd love to declare a proper datatype for the uuid
uri, but have no time (and not the knowledge) today...

Further contributions are welcome!

------------------------------------------------------------------------
element event {
    element id { xsd:anyURI }		# actually, timebased uuid...
    & element date { xsd:dateTime }
    & element source { text }		# tag identifying the source
    & element object {
	element type { text }		# tag identifying the type, e.g. draft
	& element tag { text }		# draft filename without extension and version
	& element date { xsd:date }
	& element rev { xsd:integer }
	& element authors { text }?
	& element title { text }?
	& element abstract { text }?
	& element state { text }	# a state text tag
	& element substate { text }?	# a sub-state text tag
	& element pages { xsd:integer }?
	& element url { xsd:anyURI }?	# actually, an URL...

    }
}