Subject: [Tools-team] Web interface for feedback on candidates

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Thu, 2 Mar 2006 10:40:14 -0500

Hi,

I'd like to provide some feedback on the web interface tool for feedback to the nomcom on candidates, which I used to comment on INT AD candidates this past nomcom cycle. Due to the nature of this interface, I provided poorer feedback than I have with previous nomcoms.

In the past, when asked for feedback on candidates, I've generally prepared one email message. The preparation of this email message has never been linear for me. Commenting on one candidate makes me think of things that I had not mentioned about other candidates. In some cases, I decide to go back and comment on some aspect of all of the names I have been presented with after mentioning this aspect on some later candidates in the list when I had not mentioned it on earlier ones in my first pass.

I'm sure having the tool split out comments by candidate, which I assume it does, is more convenient for the nomcom than getting aggregate text messages. But, if I am any guide, the nomcom is getting nicely sorted but inferior quality feedback.

At an absolute minimum, the tool should display text telling the person providing feedback that they might find it better to compose all of their comments separately as one document and then cut and paste from their to the web tool. But, in fact, it gives no such hint and just sucks your comments one at a time into a black hole giving no feedback on who you have already commented on or what your comments were or that your submission succeeded. So you can't even glance at your previous comments in preparing later ones. In fact, the almost total lack of user feedback from the tool initially gave me the impression that it wasn't working. I had no positive confirmation that comments were accepted nor any idea what would happen if I provided comments twice on the same candidate. Would later ones override earlier ones or would they just be appended? There was no way to tell. And, in fact, to this day, I have no actual evidence that my comments got through.

The right design would provide a commenter with simultaneous entry fields for all those they have been asked to comment on, allow them to repeatedly edit the various comments on the various candidates until they thought they were good (which would be the normal characteristic of an HTML FORM with multiple entry fields), and then, after special confirmation by the commenter, send them to the nomcom with a clear success message back to the commenter both on the web page and via email including a copy of their comments. There must be a clear statement of what happens if you comment again later, which I assume should be to append your later comments to your earlier comments.

If I'm presented with this interface in the future, I sure hope I'll remember separately compose one document commenting on all the candidates and them cut and paste from the document into the multiple web forms...

Donald

 =========================================================
 Donald E. Eastlake III       [email-masked]
 Motorola Laboratories              +1-508-786-7554 (work)
 111 Locke Drive                    +1-508-634-2066 (home)
 Marlboro, MA 01752 USA

_______________________________________________
Tools-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-team

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 03 Mar 2006 08:33:56 +0800

Hi Donald,

  These are good points.  Together with the current and next nomcom
chair I'll try to fix all of these except for the possibility of
going back later to review what said.  This is not possible without 
changing one fundamental characteristic of the system, which is that
all comments are GPG encrypted with the nomcom public GPG key before
being committed to disk in order to ensure that only nomcom will be
able to read them.

Regards,

	Henrik

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 03 Mar 2006 08:50:09 +0100

Henrik,

The inability to see what one said is fundamentally annoying.
After I was caught by this on the first round of feedback,
I prepared all my comments on the second round in advance and
saved to disk; but I *still* wish I had the comments from the
first round. At the very least, they should be displayed
unencrypted for confirmation, with an explicit warning that
pressing the next button will render them into garbage.

It made the job much, much harder than in previous years and
makes it impossible to do intelligent follow up if something changes.

     Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 03 Mar 2006 21:38:45 +0100

Right, point taken.  We'll have to work out some way of making this
part of the NomCom feedback tool better.

	Henrik