
From nobody Sat Mar 10 08:07:30 2018
Return-Path: <worley@alum.mit.edu>
X-Original-To: urn@ietfa.amsl.com
Delivered-To: urn@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 868071267BB for <urn@ietfa.amsl.com>; Sat, 10 Mar 2018 08:07:29 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.685
X-Spam-Level: 
X-Spam-Status: No, score=-1.685 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HEADER_FROM_DIFFERENT_DOMAINS=0.25, RCVD_IN_DNSWL_LOW=-0.7, SPF_SOFTFAIL=0.665] autolearn=no autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id sRrnRHKJKlvb for <urn@ietfa.amsl.com>; Sat, 10 Mar 2018 08:07:28 -0800 (PST)
Received: from resqmta-ch2-12v.sys.comcast.net (resqmta-ch2-12v.sys.comcast.net [IPv6:2001:558:fe21:29:69:252:207:44]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 0D66712426E for <urn@ietf.org>; Sat, 10 Mar 2018 08:07:27 -0800 (PST)
Received: from resomta-ch2-08v.sys.comcast.net ([69.252.207.104]) by resqmta-ch2-12v.sys.comcast.net with ESMTP id uh1Zet6rclAzJuh1reY2Bm; Sat, 10 Mar 2018 16:07:27 +0000
Received: from hobgoblin.ariadne.com ([65.96.206.41]) by resomta-ch2-08v.sys.comcast.net with SMTP id uh1peXnO2tM3xuh1qecKak; Sat, 10 Mar 2018 16:07:26 +0000
Received: from hobgoblin.ariadne.com (hobgoblin.ariadne.com [127.0.0.1]) by hobgoblin.ariadne.com (8.14.7/8.14.7) with ESMTP id w2AG7P7Y023392; Sat, 10 Mar 2018 11:07:25 -0500
Received: (from worley@localhost) by hobgoblin.ariadne.com (8.14.7/8.14.7/Submit) id w2AFN3aL018550; Sat, 10 Mar 2018 10:23:03 -0500
X-Authentication-Warning: hobgoblin.ariadne.com: worley set sender to worley@alum.mit.edu using -f
From: worley@ariadne.com (Dale R. Worley)
To: R Atarius <r_atarius@yahoo.com>
Cc: urn@ietf.org, ben@nostrum.com, aallen@blackberry.com, r_atarius@yahoo.com
In-Reply-To: <308985701.3158291.1517287508258@mail.yahoo.com> (r_atarius@yahoo.com)
Sender: worley@ariadne.com (Dale R. Worley)
Date: Sat, 10 Mar 2018 10:23:03 -0500
Message-ID: <87zi3g0xbc.fsf@hobgoblin.ariadne.com>
X-CMAE-Envelope: MS4wfLv88yfScIPnByFrsfsmb+U0cLgQwTtp5QEjpUAVDbR7PGjxyb2tc837QOD8nI/fThH5NOsRd+r6Z50D1AZRJWPaQP3huGJ4G2HUBnFRyxYSemYZv4gi zQzX9/9IzYx2XVKVulx8nvcV7uF0azEH3AbQIHC9vu+DbtqPT0DDTfeaauf8p7+YFikVu/urXAsolRKhzi5lHYRPf7E3A0ol9DnjmCvGZ+HjcFml1HECAAVm qxOgOO6DxTTvcYHWpsa9cw==
Archived-At: <https://mailarchive.ietf.org/arch/msg/urn/Aprwpy2J6C7FaSz2N85at-wNC1o>
Subject: Re: [urn] Expert review needed
X-BeenThere: urn@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: Revisions to URN RFCs <urn.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/urn>, <mailto:urn-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/urn/>
List-Post: <mailto:urn@ietf.org>
List-Help: <mailto:urn-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/urn>, <mailto:urn-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 10 Mar 2018 16:07:29 -0000

My apologies for losing track of this.

R Atarius <r_atarius@yahoo.com> writes:
> Hi Dale,
> I have segmented your comments by adding
> ******************************************************* line
> and the second comment that you had on the first comment, is marked by 
> ---------------------------------------------------------------- line
>
> My comments and proposed text are marked by <Roozbeh>
> ThanksRoozbeh

The text version of your e-mail didn't come through very well.  I've had
to reformat it to reply to it.

Just to verify:  It looks like few of these changes were incorporated
into the -15 version.

There are an array of wording changes that you've made.  They take care
of most of the items I pointed out, with the exception of the few that I
mention below.

>> As far as I can tell, the MEID check digit is "not transmitted" in
>> thesense that it's not part of the URN itself.  [...]

> <Roozbeh> How about having this in two sections:

Your new language makes this matter clear.

> Dale's INITIAL COMMENT:
>> If you allow that future changes will only be done via RFC, then
>> youcan omit all mention of future-pp2-specifier in this RFC, as they
>> willbe defined in later RFCs.  That could allow you to simplify this
>> RFCconsiderably (especially the ABNF), as it would only have to deal
>> withthe one identifier class ("meid") that has already been defined.

> <Roozbeh>:This draft was initially written to be aligned with the text
> inRFC 7254. In that document the future changes  were introduced and
> that is the reason this document also contains
> those.

OK, I can see the value in aligning with 7254.

But oh, my, I never noticed that 7254 has a "naked" %:

         gsma-urn-char         = ALPHA / DIGIT
                                 / "-" / "." / "_" / "%" / ":"

Someone should have caught that mistake!

> <Roozbeh>: With the previous comment you gave about replacing "%"
> withpct-encoded, then the text is modified to 
>
>    pp2-urn              = "urn:" pp2-NID ":" pp2-NSS
>    pp2-NID              = "3gpp2"   
>    pp2-NSS              = meid-specifier / future-pp2-specifier
>    meid-specifier       = "meid:" meidval   
>    future-pp2-specifier = future-specifier [ ":" 1*( pchar / "/" ) ]
>    future-specifier     = 1*pp2-char
>    pp2-char             = ALPHA / DIGIT / "-" / "." / "_" / pct-encoded
>    ALPHA                = %x41-5A / %x61-7A; A-Z / a-z
>    DIGIT                = %x30-39; 0-9

That looks like a good solution.  (Although I think "ALPHA" and "DIGIT"
are defined in ABNF (RFC 5234 appendix B.1) so you don't have to define
them.  (RFC 7254 does not.))

>>     <future-pp2-specifier> and <pp2-defined-nonempty> can comprise
>>     any  ASCII characters compliant with URN syntax in [RFC5234].
>>
>> This is not correct, as the URN syntax allows any pchar, whereas
>> the pp2-defined-nonempty does not allow the sub-delims "!", "$",
>> "&", "'","(", ")", "*", "+", and ",", which are all valid pchars.
>
> <Roozbeh> Perhaps you have looked at revision 14 of this document. The
> refernce is RFC 8141 in revision 15 of the document, i.e.
>     <future-pp2-specifier> and <pp2-defined-nonempty> can comprise any
>     ASCII characters compliant with URN syntax in [RFC8141].

Rereading what I said previously, it was mistaken in a complicated way:
The ABNF (from your version above) is

    pp2-NSS              = meid-specifier / future-pp2-specifier

    future-pp2-specifier = future-specifier [ ":" 1*( pchar / "/" ) ]
    future-specifier     = 1*pp2-char
    pp2-char             = ALPHA / DIGIT / "-" / "." / "_" / pct-encoded

As a result, <future-pp2-specifier> as a whole can contain "any ASCII
characters compliant with URN syntax".  However, the initial
<future-specifier> portion of <future-pp2-specifier> has a more limited
character set.

However, <pp2-defined-nonempty> (as defined in -14) has the limited
character set of pp2-char.  However, you've removed
<pp2-defined-nonempty> in the above revised ABNF, although it's in the
-15 version.

In regard to the "Rules for Lexical Equivalence", I think your changes
are generally beneficial, but I'd have to see the new version of the
section as a whole to make a useful judgment on it.

However, in regard to

   Any identifier in '3gpp2' NSS can be compared using the normal
   mechanisms for percent-encoded UTF-8 strings, where the UTF-8
   is defined in [RFC3629].

The reference to RFC 3629 isn't very useful, since 3629 only tells how to
represent characters as sequences of octets, i.e., it doesn't describe
the percent-encoding.  A better reference is RFC 3986 ("Uniform Resource
Identifier (URI): Generic Syntax"), which does go into the details of
how a non-ASCII character is represented in a URI as a sequence of
%-encodings.

But I think you want to be more explicit about how the comparison is
done, with something like:

   Two identifiers in '3gpp2' NSSs are equivalent if they represent the
   same string of Unicode characters via the normal mechanism for
   percent-encoded UTF-8 strings [RFC3986].

That avoids the complexities around the various ways that Unicode
strings can be compared for equivalence, by just declaring that NSS
equivalence only comes from being the same string of Unicode characters.

Dale


From nobody Sat Mar 17 18:27:14 2018
Return-Path: <r_atarius@yahoo.com>
X-Original-To: urn@ietfa.amsl.com
Delivered-To: urn@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id AAAEB124239 for <urn@ietfa.amsl.com>; Sat, 17 Mar 2018 18:27:12 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: 0.691
X-Spam-Level: 
X-Spam-Status: No, score=0.691 tagged_above=-999 required=5 tests=[BAYES_50=0.8, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=yahoo.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id nSIeORICQLFd for <urn@ietfa.amsl.com>; Sat, 17 Mar 2018 18:27:11 -0700 (PDT)
Received: from sonic303-29.consmr.mail.gq1.yahoo.com (sonic303-29.consmr.mail.gq1.yahoo.com [98.137.64.210]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id A9FB3120725 for <urn@ietf.org>; Sat, 17 Mar 2018 18:27:11 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s2048; t=1521336430; bh=lAMhMpkstKwWajTjoqw8E4Kp75HGSQb0cw/b8gYp+R0=; h=Date:From:Reply-To:To:In-Reply-To:References:Subject:From:Subject; b=cPbV9Lddf6NKf4HprS0lihxZbEBGsJG8skUYDz4jGfJWc92DSDJSP91jNXHzOCAS9Ac8v295/5JfITR7ovJ7E797mJG9K6eh200FxxWx8rMSHU4fNbgInktt5A9sb76bbFZCyKQlgSHRHIEkvE3tATZ5rV3lag0/yenaVttwYR4Gx/grJe52ZsPuN39FiqjBdHe9ER6jB/vRUqcJuBcnHdbzMeHYWY9FMiwjUpUf7JS3c4wlNZ08a/8HiJe6QOW4io6TLpKaSvoJkAr7b123KlbSFYdQqVnlrTv2mzBlOA7lfVUEaMICj9ZaU3YvBmlDF7M3HZ4zeh9fk4zlFQYmbw==
X-YMail-OSG: rDOE170VM1nq_s9MruxtAumFMYtVn5N4AyeRAmG3dWswyU3Tz540tJQX_eE37dU KHQr8bzHsr4NUxqmkEOFsMx4QfPv_0bf7MQ6_1hrCFdohdXElh961ILDAglQKETIKozBoOCjGMba Z1Y.6Hd6vYmYsu7b9HtiT87dIs..hUKNFv5gdC8u0bmZTL2D.RNjGXt6mZigbaE.p1XBJH0gQZ.S dcALmpG6nLP8JnUvfvIOKhCbGHOq1MC.9OiID6QjJW54_ELDwdGqMurcydgJij_kBj21BOXnP3qq 0npM5c9F_XTOWu.HT2e9.GaJPzq8expW8RiYH2kqAdqtwVpoX_pSrdO48ldn6wxNsIZoFXJLP8S8 Jj6bd84YLs2hWhFPDFMGWhhkBtZFKyuGA933n0QhvDSWM.hjGYzgugFrYQoNeYODRIiSf2DFOJH7 23zlyz9JjdJ5WPl1gsSfkJMOgwnCC7lRXainWRB58qssHaS6a0H6RweB0rALCnCdopu.N7936bI6 ReLea4rVOkL70vAT9lo.d7R_I6ONyWkLUkS7YR2leKYPkWhl3pQeZbx3Cg6ag2taUNT4-
Received: from sonic.gate.mail.ne1.yahoo.com by sonic303.consmr.mail.gq1.yahoo.com with HTTP; Sun, 18 Mar 2018 01:27:10 +0000
Date: Sun, 18 Mar 2018 01:26:59 +0000 (UTC)
From: R Atarius <r_atarius@yahoo.com>
Reply-To: R Atarius <r_atarius@yahoo.com>
To: "Dale R. Worley" <worley@ariadne.com>, "urn@ietf.org" <urn@ietf.org>,  Lars Svensson <l.svensson@dnb.de>,  Georg Mayer <georg.mayer.huawei@gmx.com>,  "ben@nostrum.com" <ben@nostrum.com>,  John-Luc Bakker <jbakker@blackberry.com>
Message-ID: <698733931.1704912.1521336419037@mail.yahoo.com>
In-Reply-To: <87zi3g0xbc.fsf@hobgoblin.ariadne.com>
References: <308985701.3158291.1517287508258@mail.yahoo.com> <87zi3g0xbc.fsf@hobgoblin.ariadne.com>
MIME-Version: 1.0
Content-Type: multipart/alternative;  boundary="----=_Part_1704911_1948002523.1521336419036"
X-Mailer: WebService/1.1.11588 YahooMailNeo Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36
Archived-At: <https://mailarchive.ietf.org/arch/msg/urn/ihMqcz6SDkFM7PoUQNcnZTtUUu4>
Subject: [urn]  Expert review needed
X-BeenThere: urn@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: Revisions to URN RFCs <urn.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/urn>, <mailto:urn-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/urn/>
List-Post: <mailto:urn@ietf.org>
List-Help: <mailto:urn-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/urn>, <mailto:urn-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sun, 18 Mar 2018 01:27:13 -0000

------=_Part_1704911_1948002523.1521336419036
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit

Hello all,
The new revision (16) is now available.
https://www.ietf.org/id/draft-atarius-dispatch-meid-urn-16.txt

ThanksRoozbeh
------=_Part_1704911_1948002523.1521336419036
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit

<html><head></head><body><div style="color:#000; background-color:#fff; font-family:Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif;font-size:13px"><div id="yui_3_16_0_ym19_1_1521213018940_123877">Hello all,</div><div id="yui_3_16_0_ym19_1_1521213018940_123877"><br></div><div id="yui_3_16_0_ym19_1_1521213018940_123877">The new revision (16) is now available.</div><div id="yui_3_16_0_ym19_1_1521213018940_123877"><br></div><div id="yui_3_16_0_ym19_1_1521213018940_123877" dir="ltr"><a href="https://www.ietf.org/id/draft-atarius-dispatch-meid-urn-16.txt" id="yui_3_16_0_ym19_1_1521213018940_125620">https://www.ietf.org/id/draft-atarius-dispatch-meid-urn-16.txt</a><br></div><div id="yui_3_16_0_ym19_1_1521213018940_123877" dir="ltr"><br></div><div id="yui_3_16_0_ym19_1_1521213018940_123877" dir="ltr">Thanks</div><div id="yui_3_16_0_ym19_1_1521213018940_123877" dir="ltr">Roozbeh</div></div></body></html>
------=_Part_1704911_1948002523.1521336419036--


From nobody Tue Mar 27 19:50:33 2018
Return-Path: <worley@alum.mit.edu>
X-Original-To: urn@ietfa.amsl.com
Delivered-To: urn@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7AAD9126BF3 for <urn@ietfa.amsl.com>; Tue, 27 Mar 2018 19:50:31 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.686
X-Spam-Level: 
X-Spam-Status: No, score=-1.686 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HEADER_FROM_DIFFERENT_DOMAINS=0.249, RCVD_IN_DNSWL_LOW=-0.7, SPF_SOFTFAIL=0.665] autolearn=no autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Si5eX4Ie_vs0 for <urn@ietfa.amsl.com>; Tue, 27 Mar 2018 19:50:29 -0700 (PDT)
Received: from resqmta-ch2-12v.sys.comcast.net (resqmta-ch2-12v.sys.comcast.net [IPv6:2001:558:fe21:29:69:252:207:44]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 9F28F120724 for <urn@ietf.org>; Tue, 27 Mar 2018 19:50:29 -0700 (PDT)
Received: from resomta-ch2-10v.sys.comcast.net ([69.252.207.106]) by resqmta-ch2-12v.sys.comcast.net with ESMTP id 11ALf47PSxo3S11ASfEpfS; Wed, 28 Mar 2018 02:50:28 +0000
Received: from hobgoblin.ariadne.com ([IPv6:2601:192:4603:9471:222:fbff:fe91:d396]) by resomta-ch2-10v.sys.comcast.net with SMTP id 11APf7KFbf6vu11AQfREC2; Wed, 28 Mar 2018 02:50:27 +0000
Received: from hobgoblin.ariadne.com (hobgoblin.ariadne.com [127.0.0.1]) by hobgoblin.ariadne.com (8.14.7/8.14.7) with ESMTP id w2S2oQdi012837; Tue, 27 Mar 2018 22:50:26 -0400
Received: (from worley@localhost) by hobgoblin.ariadne.com (8.14.7/8.14.7/Submit) id w2S2oOQa012822; Tue, 27 Mar 2018 22:50:24 -0400
X-Authentication-Warning: hobgoblin.ariadne.com: worley set sender to worley@alum.mit.edu using -f
From: worley@ariadne.com (Dale R. Worley)
To: R Atarius <r_atarius@yahoo.com>
Cc: urn@ietf.org, l.svensson@dnb.de, georg.mayer.huawei@gmx.com, ben@nostrum.com, jbakker@blackberry.com
In-Reply-To: <698733931.1704912.1521336419037@mail.yahoo.com> (r_atarius@yahoo.com)
Sender: worley@ariadne.com (Dale R. Worley)
Date: Tue, 27 Mar 2018 22:50:24 -0400
Message-ID: <87605gsykv.fsf@hobgoblin.ariadne.com>
X-CMAE-Envelope: MS4wfKTD+wUdWI3nocnV+ZsIRVCrn38fE/EEBTxPRaREb0snJMUenar18c51jQ+cG94Liwf5F8WWCoh90yfGqBfkIZEFjJ/ReebTQsiW0ZKfeZeGYDY2bMUw Ue7WJ4IYOTJg/DckwiM69GIuzO/yBrUjgtd74OYfHGAlxAnWW6k5j1tkOleLd430nfDCsrEAsdj9CUG56wYm1r2d0DZiO8+VusWAX3M+jPnWNxHAkJQ3g2SK 7roDTuMSoLYZg3/KCBjMIDy5UC2nE2P80ZhidNSLOX6Jfstf6jRxYl8FD9iSjeGaFLVLXjZhosdirUpkXQs3Yw==
Archived-At: <https://mailarchive.ietf.org/arch/msg/urn/rFMTUpVfZbBPsVspNu2-HMvUJrY>
Subject: Re: [urn] Expert review needed
X-BeenThere: urn@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: Revisions to URN RFCs <urn.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/urn>, <mailto:urn-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/urn/>
List-Post: <mailto:urn@ietf.org>
List-Help: <mailto:urn-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/urn>, <mailto:urn-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 28 Mar 2018 02:50:31 -0000

R Atarius <r_atarius@yahoo.com> writes:
> The new revision (16) is now available.
> https://www.ietf.org/id/draft-atarius-dispatch-meid-urn-16.txt

The new version looks quite good.  I've a few comments, listed in text
order:

Abstract

   This document defines a Uniform Resource Name (URN) namespace for the
   Third Generation Partnership Project (3GPP2) and a Namespace Specific
   String (NSS) for the Mobile Equipment Identity (MEID).

I may have the terminology wrong, but comparing to the next sentence,
you might want to change "Third Generation Partnership Project (3GPP2)"
to "Third Generation Partnership Project 2 (3GPP2)".

3.  Namespace Registration Template

   Registration organization:

   Name: 3GPP2

You might want to spell this out as "Third Generation Partnership
Project 2 (3GPP2)".

   future-pp2-specifier = future-specifier *( ":" 1*( pchar / "/" ))

This ABNF is correct, but somewhat obscure.  Looking at it quickly, it
appears to specify a sequence of "words" separated by ":", where each
word contains at least one character which is not ":".  But in fact,
<pchar> can be ":", so this has the same effect as

   future-pp2-specifier = future-specifier [ ":" 1*( pchar / "/" ) ]

That is, the <future-specifier> (which cannot contain ":") can be followed
by ":" and then by one or more (pchar / "/"), with the latter containing
":" in arbitrary places.

So if the ABNF specifies what you want, you might consider the latter
formulation as being more expressive of your intentions.

   <future-pp2-specifier> can comprise any ASCII characters compliant
   with URN syntax in [RFC8141].

Actually, there are sequences of ASCII characters compliant with URN
syntax in [RFC8141] which cannot be <future-pp2-specifier> -- RFC 8141
prescribes that the NSS is "pchar *(pchar / "/")", but
<future-pp2-specifier> can only start with <pp2-char>, which does not
include "~", <sub-delims>, ":", or "@", which are all included in
<pchar>.

You might want to omit this sentence.  Alternatively, it is true that
the part of <future-pp2-specifier> after ":" can be any NSS string.
Though that part is slightly more general than NSS, since it can start
with "/", and NSS cannot.  But it's not clear to me that anything you
can say along these lines is both completely accurate and easier to
understand than the ABNF.

   Rules for Lexical Equivalence:

   Two 3GPP2 MEID URNs are equivalent if they have the same 'meidval' in
   the same sequential order.  Two future 3GPP2 MEID URNs are equivalent
   if they have the same 'meidval'and 'future-pp2-specifier' in the same
   sequential order.

The second sentence needs to be rewritten, because of course, no URN
contains both <meidval> and <future-pp2-specifier>.  Indeed, it seems
like you can get the effect you want by simply saying:

   Two 3GPP2 MEID URNs are equivalent if they have the same character
   string as <pp2-NSS>.

4.2.3.  Check Digit

   This is a single hexadecimal digit (bits 1-4 of octet 8) and is used
   as assurance of integrity in error-prone operations, e.g. when used
   with certain types of readers during inventory management operations.
   The check digit is not transmitted by the mobile equipment and are
   not used in the MEID URN.

In section 4.2, for completeness, you give a lot of information that is
not strictly required.  However you don't give the really non-trivial
bit of information:  the formula for the check digit.  After reading
this section, I was left curious what the check digit formula actually
is!

Dale

