Subject: Re: #1300 was Admin: Resolution of WG

From: Harald Alvestrand <[email-masked]>
Date: Sun, 02 Jul 2006 23:37:22 -0700

[email-masked] wrote:
>
>
>> | A newsgroup may be "moderated", in which case submissions
>> | are not posted directly, but mailed to a "moderator" for
>> | consideration and possible posting. Moderators are
>> | typically human but may be implemented partially or
>> | entirely in software.
>
>> The word "moderated" occurs only once,
>> in the "Approved" section.
>
> Moderators are ALWAYS human.
>
> Suggested replacement text:
>
> A newsgroup may be "moderated". Articles are not posted directly to a 
> moderated group, but are submitted (usually by email) to one or more 
> moderators for approval and eventual posting. Some moderators have 
> implemented automated systems to help them perform this function.
>
>
Hm.

I've seen mailing lists gatewayed to Netnews where the "moderator" was 
set to be the mailing list - the result was that all messages posted to 
the newsgroup were sent to the mailing list, and eventually came back to 
the newsgroup. No human moderator anywhere in sight.

This document shouldn't try to mandate a human in the loop.

                      Harald

---

From: Seth Breidbart <[email-masked]>
Date: Mon, 3 Jul 2006 03:00:28 -0400 (EDT)

> Moderators are ALWAYS human.

Even when the RFD and CFV say that the group will be robomoderated,
and it is?  (typically to prevent crossposts)

Seth

---

From: Graham Drabble <[email-masked]>
Date: Mon, 03 Jul 2006 14:01:56 +0100

> and it is?  (typically to prevent crossposts)

Yes. The moderator is whoever controls the modbot. Being robomoderated 
merely means the moderator has decided to let software do all the work.

-- 
Graham Drabble
http://www.drabble.me.uk/

---

From: Graham Drabble <[email-masked]>
Date: Mon, 03 Jul 2006 14:03:07 +0100

On 03 Jul 2006 Harald Alvestrand <[email-masked]> wrote in
news:[email-masked]: 

>> A newsgroup may be "moderated". Articles are not posted directly
>> to a moderated group, but are submitted (usually by email) to one
>> or more moderators for approval and eventual posting. Some
>> moderators have implemented automated systems to help them
>> perform this function. 
>>
>>
> Hm.
> 
> I've seen mailing lists gatewayed to Netnews where the "moderator"
> was set to be the mailing list 

No, the moderator submission address was the mailing list. The 
moderator was whoever controlled that list.

> - the result was that all messages
> posted to the newsgroup were sent to the mailing list, and
> eventually came back to the newsgroup. No human moderator anywhere
> in sight. 
> 

The human doesn't have to be in the loop but they have to exist and 
ultimately are responsible if things go wrong.

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 3 Jul 2006 09:05:09 GMT

>implemented automated systems to help them perform this function.

I think the original text more accurately reflects reality. That wording
has been around for more years than I care to remember, and it is odd that
John has just noticed this.

I could accept some intermediate wording (e.g. s/typically/usually/ (or
'generally').

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Russ Allbery <[email-masked]>
Date: Mon, 03 Jul 2006 09:31:32 -0700

Graham Drabble <[email-masked]> writes:
> Seth Breidbart <[email-masked]> wrote:

> merely means the moderator has decided to let software do all the work.

Hm, well, this is certainly true from the perspective of Big Eight policy,
but there isn't any inherent reason why some hierarchy couldn't have a
central automated moderation service in which the software works the same
for every group.  Indeed, the linux.* hierarchy is essentially that case.

It's semantic quibbling to a degree since you can always then argue that
the hierarchy administrator is the moderator.

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>

---

From: Seth Breidbart <[email-masked]>
Date: Mon, 3 Jul 2006 14:02:46 -0400 (EDT)

> merely means the moderator has decided to let software do all the work.

Except that (1) no one person decided on the bot, the group (by vote)
did.  (2) Who is "whoever controls the modbot"?  One of the five
people with access to that account?  Them plus the sysadmins of the
site it runs on?  Or just the owner of the site, who has the final
say?  (3) What happens if everybody who controls the bot goes away,
and it keeps running just fine on autopilot?  Can an active moderated
group have no moderator?

Seth

---

From: Richard Clayton <[email-masked]>
Date: Mon, 3 Jul 2006 19:23:00 +0100

In message <[email-masked]>, Seth Breidbart
<[email-masked]> writes

>Can an active moderated

alt.hackers used to be the canonical example ...  marked as moderated,
but anyone could post provided that they worked out how to do so

seems to still exist in that form...

- -- 
richard @ highwayman . com                       "Nothing seems the same
                          Still you never see the change from day to day
                                And no-one notices the customs slip away"

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 12 Jul 2006 06:42:00 +0200

Russ Allbery wrote:

> there isn't any inherent reason why some hierarchy couldn't
> have a central automated moderation service in which the
> software works the same for every group.  Indeed, the linux.*
> hierarchy is essentially that case.

Slightly abusing the term "hierarchy", all gmane.* articles
have Approved: [email-masked] when _read_ on GMaNe.  Including
anything I read in gmane.ietf.usenet.format

A special case, readers are supposed to know when to contact
GMane administrators, and when to discuss issues with the list
owners, and how to debug it.

It can get rather interesting if the list software changes its
behaviour, and nobody incl. the list owner expected problems
wrt MAIL FROM = Sender (GMane, subscribed) != From (poster, not
subscribed).

Bye, Frank

---

From: Ken Murchison <[email-masked]>
Date: Wed, 12 Jul 2006 16:30:01 -0400

> implemented automated systems to help them perform this function.

FWIW, I (as editor) am in favor of the replacement text.  Setting aside 
the "human" argument, can anyone make an argument that the new text is 
fundamentally wrong?

-- 
Kenneth Murchison
Systems Programmer
Project Cyrus Developer/Maintainer
Carnegie Mellon University

---

From: Russ Allbery <[email-masked]>
Date: Wed, 12 Jul 2006 14:50:10 -0700

> the "human" argument, can anyone make an argument that the new text is

Looks fine to me.

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 12 Jul 2006 23:58:21 +0200

Ken Murchison wrote:
> FWIW, I (as editor) am in favor of the replacement text.  Setting 
> aside the "human" argument, can anyone make an argument that the new 
> text is fundamentally wrong?
>
If we are not ready to declare consensus on whether or not moderators 
are human, I would prefer......

   A newsgroup may be "moderated". Articles are not posted directly to a 
moderated group, but are submitted (usually by email) to one or more
   moderation addresses for approval and eventual posting.

(there may be a better word than "moderation address" somewhere in the 
documents).

That describes the function - that articles to moderated groups go 
"elsewhere", not directly to the group - but doesn't attempt to get into 
the space of defining what the process is that has to exist when it gets 
there, or to what degree humans are involved. The discussion has shown 
that this varies widely.

                   Harald

---

From: [email-masked] (Ralph Babel)
Date: Thu, 13 Jul 2006 07:36:00 +0200 (CEST)

Harald Alvestrand suggested:

> A newsgroup may be "moderated". Articles are not posted
> directly to a moderated group, but are submitted (usually
> by email) to one or more moderation addresses for approval
> and eventual posting.

As Richard already pointed out, the entire terminology
is completely fuzzy and inconsistent. When Joe A. User's
client connects to port 119 and sends an article without
"Approved" header field to a "moderated" group, is it
"submitted"? "posted"? "injected"? "generated"? What if
a moderator does - after having included an "Approved"
header field? What about server-to-server communication?

What a total mess!

The word "moderated" occurs only once, in the "Approved"
section. So simply get rid of it in the list of definitions.
If you really insist on retaining something like the current
definition, try the following _technical_ _description_
instead:

| A news server typically will not forward to other news
| servers articles destined for at least one newsgroup
| locally marked as "moderated" unless an Approved header
| field is included. Articles without Approved header field
| received by such a news server are typically e-mailed
| to a so-called "moderator" (the e-mail address of which
| is configured locally) if and only if that article has
| been received directly from the sender. If not received
| directly from the sender, articles without an Approved
| header field destined for a moderated newsgroup MUST NOT
| be forwarded to the "moderator"; such articles are
| typically discarded.

Gee, folks, it's not rocket science - once you cut the
political crap. (See my Last Call comments regarding
the current "author"/"sender"/"poster" fuck-up.)

Can we disband now, please?

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 13 Jul 2006 17:57:17 +0200

Ralph Babel wrote:

> try the following _technical_ _description_ instead

Possible.  Make sure that I'm still entiteled to (try to)
approve my own cancel messages for articles claiming to
be "from" me whenever I feel like it.

Bye, Frank

---

From: "Charles Lindsey" <[email-masked]>
Date: Thu, 13 Jul 2006 16:11:16 GMT

>the "human" argument, can anyone make an argument that the new text is 

Neither text is fundamentally wrong, and in any case both are just trying
to give a brief introduction to a topic upon which you need to go to
USEPRO to see all the gory details.

Text #1 underestimates the humanity of the moderator
(s/tpyically/generally/ would help). Text #2 overestimates it. It is no
huge deal either way, but I prefer #1 over #2. Change the last sentence of
#2 to "Moderators often set up automated systems to perform part or all of
their task." and I will be happy.