Subject: Re: Some late -08 nits

From: Frank Ellermann <[email-masked]>
Date: Sat, 05 Aug 2006 14:41:47 +0200

In addition to the "IANA considerations" nits:

> Three RFC 850 header fields are mentioned in section 3.3, but
> not covered by section 6 (= IANA considerations).  Let's just
> formally kill them and be done with it:
 
>       Header field name: Relay-Version
>       Applicable protocol: netnews
>       Status: obsoleted
>       Author/change controller: IETF
>       Specification document(s): [RFC 850] (2.1.1)
 
>       Header field name: Posting-Version
[...see above...]
>       Header field name: Date-Received
[...see above...]

In draft 08 we have this:

|     Header field name: NNTP-Posting-Host
|     Applicable protocol: netnews
|     Status: obsoleted
|     Author/change controller: IETF
|     Specification document(s): none

Please replace "none" by "[RFC 2980] (3.4.1)" and add 2980 to
the informative references.  We could mention RFC 2980 (3.4.2)
also in the first note of 3.2.13 (User-Agent), but it doesn't
offer any further insights.

Frank

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 7 Aug 2006 09:26:09 GMT

>offer any further insights.

Well spotted. RFC 2980 is sufficiently obscure that few people are aware
of that. Though oddly he did not cover NNTP-Posting-Date.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Russ Allbery <[email-masked]>
Date: Mon, 07 Aug 2006 08:42:58 -0700

Charles Lindsey <[email-masked]> writes:
> Frank Ellermann <[email-masked]> writes:

> of that. Though oddly he did not cover NNTP-Posting-Date.

RFC 2980 isn't particularly obscure in the NNTP community.  I'd just
completely forgotten that it defined any headers, since it's really an
NNTP document.

NNTP-Posting-Host predates NNTP-Posting-Date by possibly a decade.

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>