Subject: Where are my Issues?

From: "Charles Lindsey" <[email-masked]>
Date: Thu, 15 Mar 2007 16:39:14 GMT

On February 14th, I requested five ISSUE numbers:

1. ISSUE: Possibility to use non-resolvable domain name as path-identity
2. ISSUE: content of Approved header
3. ISSUE: Format of batched news in response to sendme
4. ISSUE: consistency of Injection-Info
5. ISSUE: Moderators SHOULD retain existing message-id

Harald requested a seconder for the first three. It is my understanding that
Frank agreed to second #1 on Feb 19th (though maybe as a continuation of
Issue 1093, though I think it is better kept separate).

There has been no seconder for #2, so I accept it is dead.

There was discussion of #3, after which I withdrew it.

But that still leaves no action taken on #4 and #5, and I see that Frank
has recently raised that same matter again.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 16 Mar 2007 17:01:37 +0100

> 5. ISSUE: Moderators SHOULD retain existing message-id
[...] 
> that still leaves no action taken on #4 and #5, and I
> see that Frank has recently raised that same matter again.

I recall doing that for #5, but not for #4 as posted in
<http://permalink.gmane.org/gmane.ietf.usenet.format/31621>

#4 is about the old rat-hole of "privacy vs. kill-file",
and whether servers should have the ability to enforce
rules behind the backs of their users.  Your proposal:

| Each injecting agent SHOULD use a consistent form of the
| Injection-Info header field for all articles originating
| from the same or similar origins.

I don't second this, actually I think SHOULD is a bad idea.

It's interesting enough that UAs with more than a minimum
of self-esteem will offer to forge Dates using 00:00 UTC
or similar for privacy reasons - relevant in conjunction
with a no nonsense From address, some servers like GMaNe
or T-Online (used to) enforce this.

We shouldn't recommend obscure alternatives to the From-
address in the form of "public user IDs hidden in the
Injection-Info in a form still working with killfiles".

That's occultism already covered by USEFOR with not less
than three SHOULDs for the "posting-account" parameter,
plus a privacy link to USEAGE at the end of the section
(not to USEPRO).

Of course Harald and Alexey are busy at the moment, with
lots of drafts (and planned meeting agenda) in various
stages between "almost ready for last call" and "not yet
approved" - I guess nothing will happen with your issues
before April when IETF 68 is finished, and drafts for
resulting minutes have been posted.

I like it when we only discuss one big issue like #1416,
that's already very complex.  So far the discussion did
not manage to convince me that more accuracy than the
date (ignoring the time) is strictly necessary for news
to survive.

Frank

---

From: "Forrest J. Cavalier III" <[email-masked]>
Date: Fri, 16 Mar 2007 13:07:53 -0400

> date (ignoring the time) is strictly necessary for news

That comment really frosts me.  This is supposed to be
ENGINEERING of a protocol not the lottery.

Is "survival" the criteria we use now to weigh choices on
the draft? Is that the goal you and Charles are trying to reach
here?  (I mean, after figuring out how things work now.)

Sorry. Some things written here in seriousness just make
my jaw drop.  I don't miss John Stanley's vitriol, but
his well written cluebats were a welcome read sometimes.

This WG is too small to finish, I fear, with current
participants.  Russ is trying to be careful, and you and
Charles are just, just, ... not.

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 19 Mar 2007 14:36:42 GMT

><http://permalink.gmane.org/gmane.ietf.usenet.format/31621>

Sorry, that sentence was intended to refer to #5 only as regards your
position on it.

>I don't second this, actually I think SHOULD is a bad idea.

OK, that's an opinion (better than silence).

>Injection-Info in a form still working with killfiles".

If people want to remain anonymous, that is fine. They can adopt a
pseudonym and post from [email-masked]. What I don't like is one person
with umpteen pseudonyms which rotates randomly between them, or which
conduct pseudo discussions amongst themselves on a group. One just needs
some way to be aware when that is happening (not that consistent
Injection-Date will solve all such problems, but consistenly showing a
correct posting-host would help a lot).

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 20 Mar 2007 01:12:55 +0100

Charles Lindsey wrote:

> What I don't like is one person with umpteen pseudonyms which
> rotates randomly between them, or which conduct pseudo discussions
> amongst themselves on a group.

Yes, I also don't like this.  But I think your technical solution
of this social problem is a legal nightmare.  If the server admins
want to enforce unique IDs per user they could focus their efforts
on enforcing unique From addresses and/or publishing a clear AUP.

The trolls (in the new sense of it as trollish persons) I've in
mind would probably know or learn fast that they need tricks like
more accounts or more news servers no matter what you try on the
technical side.

OTOH normal users of one server can have legit reasons why they
use an ordinary From address in a programming language group,
and something else in a "critical" group (I hope examples of
such "critical" groups are clear).

Now if the server inserts a unique ID in theory good enough for
"global" (over all groups) killfiling behind their back these 
normal users could be identified as posters in such "critical"
groups.

And IMO the normal users are more important than identifying a
few trolls too stupid to figure Injection-Info parameters out.

Besides implementing killfiles based on Injection-Info with all
its RFC 2231 features isn't straight forward.  I doubt that it
works for your purpose, and I think that it will be harmful for
legit users.

Frank