Subject: Commit in docs/usefor (usepro.xml)

From: [email-masked]
Date: Thu, 11 Dec 2008 20:03:09 -0800 (PST)

Date: Thursday, December 11, 2008 @ 20:03:08
  Author: eagle
Revision: 5531

Add a specification for the Original-Sender header field as requested
during Last Call comments and have incoming gateways use it to preserve
the original Sender header field.  Include its registration in the
IANA Considerations section.

This specification may move to USEFOR as part of the final publication
process of both documents.

Modified:
  docs/usefor/usepro.xml

Modified: docs/usefor/usepro.xml
===================================================================
--- docs/usefor/usepro.xml	2008-12-12 04:00:20 UTC (rev 5530)
+++ docs/usefor/usepro.xml	2008-12-12 04:03:08 UTC (rev 5531)
@@ -1384,9 +1384,45 @@
           this &lt;mailbox> SHOULD indicate that the entity responsible
           for injection of the message is a gateway.  If the original
           message already had a Sender header field, it SHOULD be renamed
-          so that its contents can be preserved.</t>
+          to Original-Sender so that its contents can be preserved.  See
+          <xref target="orig-sender" /> for the specification of that
+          header field.</t>
         </section>
 
+        <section anchor="orig-sender" title="Original-Sender header
+          field">
+          <t>The Original-Sender header field holds the content of a
+          Sender header field in an original message received by an
+          incoming gateway, preserving it while the incoming gateway adds
+          its own Sender header field.  The content syntax makes use of
+          syntax defined in <xref target="USEFOR" /> and <xref
+          target="RFC2822" />.</t>
+
+          <figure>
+            <artwork type="abnf">
+      header              =/ Original-Sender-header
+      Original-Sender-header
+                          = "Original-Sender" ":" SP
+                               Original-Sender-content 
+      Original-Sender-content
+                          = mailbox
+            </artwork>
+          </figure>
+
+          <figure>
+            <preamble>The Permanent Message Header Field Repository entry
+            for this header field is:</preamble>
+
+            <artwork>
+   Header field name:          Original-Sender
+   Applicable protocol:        Netnews
+   Status:                     standard
+   Author/Change controller:   IETF
+   Specification document(s):  RFC&rfc.number;
+            </artwork>
+          </figure>
+        </section>
+
         <section title="Gateway Example">
           <t>To illustrate the type of precautions that should be taken
           against loops, here is an example of the measures taken by one
@@ -2219,6 +2255,10 @@
       <t>application/news-transmission is a change to a previous
       registration.</t>
 
+      <t>IANA is requested to register the new header field
+      Original-Sender in the Permanent Message Header Field Repository
+      using the template in <xref target="orig-sender" />.</t>
+
       <t>IANA is also requested to change the status of the message/news
       media type to "OBSOLETE".  message/rfc822 should be used instead.
       An updated template is included in <xref target="media" />.</t>

---

From: Russ Allbery <[email-masked]>
Date: Thu, 11 Dec 2008 20:10:17 -0800

> process of both documents.

This was the last major change before releasing a new draft.  Please
double-check.  I'll upload a new I-D this coming weekend.

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>

---

From: "Charles Lindsey" <[email-masked]>
Date: Fri, 12 Dec 2008 18:02:15 GMT

>double-check.  I'll upload a new I-D this coming weekend.

Can we not at least s/MUST/SHOULD/ for the (apparently acceptable)
multiple POSTED in Paths, while we continue to debate whether or not to
reduce it even further.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: "Charles Lindsey" <[email-masked]>
Date: Fri, 12 Dec 2008 17:59:48 GMT

>IANA Considerations section.

BTW, were those Last Call comments ever published on this list?

>process of both documents.

And that would be good. No other problem with the change (though it might
make good sense in email also, if that could somehow be managed - indeed,
some generic Original-X for all possible X might be a useful feature for
all 2822-like objects, but this WG is not the place for that.

---

From: Russ Allbery <[email-masked]>
Date: Fri, 12 Dec 2008 21:20:47 -0800

> BTW, were those Last Call comments ever published on this list?

Yeah, it was part of the conversation with SM.

---

From: Russ Allbery <[email-masked]>
Date: Fri, 12 Dec 2008 21:21:58 -0800

> multiple POSTED in Paths, while we continue to debate whether or not to

Oh, sure, good point.  Done.