Subject: Review of Bindings

From: Yaron Goland <[email-masked]>
Date: Sun, 16 Jan 2000 17:24:14 -0800

I have just finished a detailed review of the bindings spec.

After having given it a lot of thought I have come to agree with the
conclusions given in the bind spec, the WebDAV collection model is broken
and needs to be fixed. I further agree that the proposed model in BIND is a
definite improvement. While I'm still not convinced of some of the mostly
philosophical details (is a bind recorded in the collection or on the
resource?, for example), none of these details are sufficiently weighty to
merit holding up the spec. If we find that some of the niggling issues
aren't correct then we will fix it later.

After reviewing the draft I find that I have 17 issues. I have identified
each issue with a name. Following WebDAV mailing list tradition each issue
is addressed in its own letter.

The complete list of issues I am raising, in no particular order, are:

Yaron.PublishBind
Yaron.WeScrewedUp
Yaron.4Huh?
Yaron.5.3Huh?
Yaron.5.4Huh?
Yaron.507
Yaron.Insulting2616
Yaron.AtomicMove
Yaron.AtomicDelete
Yaron.NoSlash
Yaron.BindSyntax
Yaron.403
Yaron.ApplePie
Yaron.MrIntegrity
Yaron.ApplePie3
Yaron.BindingsProperty
Yaron.ApplePieToo

---

From: "Eric Sedlar" <[email-masked]>
Date: Mon, 17 Jan 2000 11:44:57 -0800

Review of BindingsI second all of Yaron's motions, with the exception of Yaron.BindSyntax (addressed separately) and Yaron.Insulting2616, which I have no comment on.

--Eric
  ----- Original Message ----- 
  From: Yaron Goland 
  To: [email-masked] 
  Sent: Sunday, January 16, 2000 5:24 PM
  Subject: Review of Bindings

  After having given it a lot of thought I have come to agree with the conclusions given in the bind spec, the WebDAV collection model is broken and needs to be fixed. I further agree that the proposed model in BIND is a definite improvement. While I'm still not convinced of some of the mostly philosophical details (is a bind recorded in the collection or on the resource?, for example), none of these details are sufficiently weighty to merit holding up the spec. If we find that some of the niggling issues aren't correct then we will fix it later.

  After reviewing the draft I find that I have 17 issues. I have identified each issue with a name. Following WebDAV mailing list tradition each issue is addressed in its own letter.

  Yaron.PublishBind 
  Yaron.WeScrewedUp 
  Yaron.4Huh? 
  Yaron.5.3Huh? 
  Yaron.5.4Huh? 
  Yaron.507 
  Yaron.Insulting2616 
  Yaron.AtomicMove 
  Yaron.AtomicDelete 
  Yaron.NoSlash 
  Yaron.BindSyntax 
  Yaron.403 
  Yaron.ApplePie 
  Yaron.MrIntegrity 
  Yaron.ApplePie3 
  Yaron.BindingsProperty 
  Yaron.ApplePieToo