Subject: RE: is DELETE "best effort"?

From: Yaron Goland <[email-masked]>
Date: Thu, 27 Jan 2000 13:09:42 -0800

Yes.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, January 27, 2000 11:46 AM
> To: [email-masked]
> Subject: is DELETE "best effort"?
> 
> 
> RFC-2518 doesn't come right out and say so, but I think it implies
> that a DELETE on a collection is on a "best effort" basis, where you
> can deduce what got DELETEd versus what didn't (and why) from a
> possible multistatus response.
> 
> Suppose I request a DELETE of /zoo/, where /zoo/ contains /zoo/mammals
> and /zoo/birds.  Suppose there is a problem with the DELETE of
> /zoo/mammals (it's locked by my corporate rival, Snidely Whiplash).
> Should the server, having discovered this, go ahead and attempt a
> DELETE of /zoo/birds?
> 
> Section 8.6.2 says that if you can't DELETE a resource, you shouldn't
> DELETE its ancestors (for the sake of namespace consistency).  It is
> silent on what you should do about the resource's siblings, though
> (the example in 8.6.2 isn't bushy enough to show it).  There is a hint
> that some of the DELETEs may be allowed to succeed while others fail
> in that 204 response codes are to be omitted from the multistatus
> because they are the default success code.
> 
> Is DELETE intended to be "best effort"?
> -- 
> [email-masked]   (WJCarpenter)           PGP
> [email-masked]                    0x91865119
> 38 95 1B 69 C9 C6 3D 25  73 46 32 04 69 D6 ED F3
>

---

From: "Geoffrey M. Clemm" <[email-masked]>
Date: Thu, 27 Jan 2000 17:01:58 -0500

This topic is currently being hotly debated in the thread:
"WebDAV Bindings - Issue Yaron.AtomicDelete"

Although 2518 currently implies "yes", the authors of the BIND protocol
extension have proposed that the answer be changed to "no".  Stay tuned (:-).

Minimally, we shall insist that a server be *allowed* to
leave all member collections unmodified if it cannot delete
the collection specified in the DELETE request.

Cheers,
Geoff

   From: Yaron Goland <[email-masked]>

   Yes.