Subject: RE: WebDAV Bindings - Issue Yaron.MrIntegrity

From: "Slein, Judith A" <[email-masked]>
Date: Fri, 21 Jan 2000 10:35:31 -0500

> -----Original Message-----
> From: Roy T. Fielding [mailto:[email-masked]]
> Sent: Thursday, January 20, 2000 7:39 PM
> To: Slein, Judith A
> Cc: [email-masked]
> Subject: Re: WebDAV Bindings - Issue Yaron.MrIntegrity 
> 
> 
> >A binding is a relation between a segment S in a collection 
> C and a resource
> >R, represented C:(S->R).  We are saying that when a server 
> agrees to create
> >a binding, it MUST guarantee that the binding will continue 
> to exist until
> >one of the following happens:
> > 
> >DELETE with a Request-URI whose final segment is S and the 
> rest of the URI
> >identifies collection C
> >MOVE with a Request-URI whose final segment is S and the 
> rest of the URI
> >identifies collection C
> >BIND with a Destination whose final segment is S and the 
> rest of the URI
> >identifies collection C, and Overwrite is T
> >DELETE the last binding to collection C
> > 
> >It is not acceptable for a binding to be destroyed as a side 
> effect of any
> >other operation.
> 
> I don't understand why this is a requirement of bindings.  It 
> certainly
> isn't a requirement of normal resources.  Why should the 
> requirements on
> bound names be stronger than the names they bind to?
> 
> ....Roy
> 

There are applications that depend upon the integrity of bindings.  In
particular, the versioning protocol being developed by the Delta-V working
group depends upon it.  In versioning, there are many orthogonal ways of
grouping information: by activity, by version tree, by configuration, etc.
Clients depend upon the integrity of this information.

As others have suggested recently, we may want to define weak bindings
eventually, but we've started in this specification with strong bindings.

--Judy

---

From: "Roy T. Fielding" <[email-masked]>
Date: Fri, 21 Jan 2000 11:46:55 -0800

>Clients depend upon the integrity of this information.

They depend on the integrity of versioned resources.  That is a
requirement on the resource, not on the protocol.  There is nothing
stopping delta-v from requiring that the bindings created for the
purpose of versioning be strongly bound and verifiable.

....Roy