Subject: driveway.com / cadaver interop

From: Joe Orton <[email-masked]>
Date: Thu, 27 Jan 2000 19:33:55 +0000

In the response to a PROPFIND with the following body:

<?xml version="1.0"?>
<propfind xmlns="DAV:">
  <prop><getcontentlength/><getlastmodified/><resourcetype/></prop>
</propfind>

the driveway.com server will include the DAV:supportedlock element for
non-collection resources, which seems wrong, although I can't find
anywhere in 2518 which actually says so. There should be some kind of
requirement that servers only return the *requested* properties for this
type of PROPFIND requests, shouldn't there? A MUST requirement would be
nice.

joe

---

From: [email-masked]
Date: Sat, 29 Jan 2000 16:54:42 -0500

> Does the WG still want to be seeing these reports?

Although I gloss over them for now, I like to have these compatibility and
bug reports handy in the archives for reference later.  So IMO, keep on
sending them.

---

From: Yaron Goland <[email-masked]>
Date: Sun, 30 Jan 2000 23:34:24 -0800

Actually the spec is extremely clear on what to do with unexpected/unknown
elements - ignore them.

> -----Original Message-----
> From: Joe Orton [mailto:[email-masked]]
> Sent: Sat, January 29, 2000 8:02 AM
> To: Yaron Goland
> Cc: [email-masked]
> Subject: Re: driveway.com / cadaver interop
> 
> 
> > That having been said, I wouldn't support specifying that a 
> server MUST NOT
> > return extra properties as I don't think this requirement 
> would enhance
> > interoperability and it would prevent some potentially 
> useful scenarios.
> 
> The fact that the spec is silent on this point has caused this interop
> problem; it needs to say something, whether it is MUST NOT or 
> SHOULD NOT
> or just a comment.
> 
> joe
>