Subject: RE: Minor nits for redirectref-02

From: "Slein, Judith A" <[email-masked]>
Date: Tue, 1 Feb 2000 11:28:43 -0500

> -----Original Message-----
> From: Joe Orton [mailto:[email-masked]]
> Sent: Wednesday, January 26, 2000 5:17 PM
> To: [email-masked]
> Subject: Minor nits for redirectref-02
> 
> 
> 1) In the MKRESOURCE response status codes, 423 Locked and 507
> Insufficient storage are included; this seems unnecessary. 
> 2518 specifies
> what these mean. You can't include the full set of valid 
> status codes in
> responses to MKRESOURCE, else you'd have to include all the 
> normal HTTP
> codes too, so why not just stick to new or changed codes?
> 

If anyone finds the inclusion of 423 and 507 helpful, I'd just as leave keep
them.  Greg has indicated that he does think it's useful to mention existing
response codes that might be expected and the circumstances that might cause
them to be returned.

> 2) MKRESOURCE responses "SHOULD NOT be cached" implies there 
> are odd cases
> when it's okay to cache them, is this right?

I know there was no discussion of this issue among the authors of the
Redirect References spec.  The definition of MKRESOURCE also appears in the
DeltaV spec, for which it was originally drafted.  Geoff, was there any
discussion of SHOULD NOT vs. MUST NOT in the DeltaV working group?  Unless
there was some good reason for making the weaker statement, we should
probably change it to MUST NOT in both specs.

> joe

---

From: [email-masked] (Geoffrey M. Clemm)
Date: Tue, 1 Feb 2000 12:47:07 -0500

There has been no discussion of this issue in the versioning design
team.  I personally see no problem with the change from "SHOULD NOT"
to "MUST NOT".  I believe the wording was originally from Jim Whitehead.
Jim?

Cheers,
Geoff

> From [email-masked] Tue Feb  1 11:29 EST 2000
>