Subject: 423 Locked

From: "Rickard Falk" <[email-masked]>
Date: Thu, 3 Feb 2000 09:46:52 +0100

If a resource is locked with a exclusive lock, and another user tries to
lock if. The response then is 423 Locked. But, is there any way for the
client to know who owns the lock?
I would like the response to look something like this :
421 Locked
Date: ...
Server: ...
Connection: ...
LockOwner : user
LockDate  : date
LockType  : exclusive
LockedUntil : date         // if specified when locked

Comments?

/Rickard

---

From: Kevin Wiggen <[email-masked]>
Date: Thu, 03 Feb 2000 01:03:17 -0800

If you do a Propfind against the resource looking for the lockdiscovery
property, the resource should return an Owner and Timeout to the client (if
permissions allow).

Unfortunately the Owner tag is left undefined, and I am sure each
implementation has its own sets of values.

Kevin

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rickard Falk
Sent: Thursday, February 03, 2000 12:47 AM
To: [email-masked]
Subject: 423 Locked

Comments?

/Rickard

---

From: "Rickard Falk" <[email-masked]>
Date: Thu, 3 Feb 2000 13:01:25 +0100

Maybe the 423 Locked response should contain a XML body with the
lockdiscovery property. Then the client doesn't need to do a second request
to the server, and there will not be a time gap.

/Rickard

> [mailto:[email-masked]]On Behalf Of Kevin Wiggen
> Sent: den 3 februari 2000 10:03
> To: Rickard Falk; [email-masked]
> Subject: RE: 423 Locked
>
>
>

---

From: "Geoffrey M. Clemm" <[email-masked]>
Date: Thu, 3 Feb 2000 08:44:41 -0500

From: "Rickard Falk" <[email-masked]>

There are many would would agree that an XML body with detailed information
about the cause of the error would be a good thing (Yaron, for sure).

In this particular case, the overhead of an extra PROPFIND request
and the time gap probably don't matter much.

Cheers,
Geoff