Subject: RE: WebFolders case sensitive

From: "Tim Ellison/OTT/OTI" <[email-masked]>
Date: Fri, 28 Apr 2000 13:41:43 -0400

Martin is right.  I tried with "OK" and "Ok" in the propstat status
element.

When the status was
     <status>HTTP/1.1 200 OK</status>
then webfolders was 'OK', however, when the status was
     <status>HTTP/1.1 200 Ok</status>
then webfolders was not 'Ok' (sic), and the results were displayed as
nameless icons (in the details view).

When the first line (of the response) status message is changed, the
webfolders continue to work ok.

Regards,
Tim

-----------------------------
Here's the breaking interaction (Webfolders request folled by the server's
response):

PROPFIND /dav HTTP/1.1
Accept-Language: en-us
Content-Type: text/xml
Translate: f
Content-Length: 380
Depth: 1
User-Agent: Microsoft Data Access Internet Publishing Provider DAV
Host: localhost:8080
Connection: Keep-Alive

<?xml version="1.0" ?>
<propfind xmlns="DAV:">
<prop>
<name/>
<parentname/>
<href/>
<ishidden/>
<iscollection/>
<isreadonly/>
<getcontenttype/>
<contentclass/>
<getcontentlanguage/>
<creationdate/>
<lastaccessed/>
<getlastmodified/>
<getcontentlength/>
<resourcetype/>
<isstructureddocument/>
<defaultdocument/>
<displayname/>
<isroot/>
</prop>
</propfind>

HTTP/1.0 207 Ok
content-type: text/xml;;charset=UTF8
Date: Fri, 28 Apr 2000 13:32:32 GMT
Server: DAV4JV/Europa
Connection: close

<?xml version="1.0" encoding="UTF-8"?>
<multistatus xmlns="DAV:">
  <response>
    <propstat>
      <prop>
        <name/>
        <parentname/>
        <href/>
        <ishidden/>
        <iscollection/>
        <isreadonly/>
        <getcontenttype/>
        <contentclass/>
        <getcontentlanguage/>
        <lastaccessed/>
        <isstructureddocument/>
        <defaultdocument/>
        <isroot/>
      </prop>
      <status>HTTP/1.1 404 Not Found</status>
    </propstat>
    <propstat>
      <prop>
        <creationdate>2000-04-12T16:19:00-04:00</creationdate>
        <getlastmodified>2000-04-12T16:19:00-04:00</getlastmodified>
        <getcontentlength>0</getcontentlength>
        <resourcetype>
  <workspace-resourcetype/>
</resourcetype>
        <displayname>A WebDAV resource.</displayname>
      </prop>
      <status>HTTP/1.1 200 Ok</status>
    </propstat>
    <href>/dav/default-workspace</href>
  </response>
  <response>
    <propstat>
      <prop>
        <name/>
        <parentname/>
        <href/>
        <ishidden/>
        <iscollection/>
        <isreadonly/>
        <getcontenttype/>
        <contentclass/>
        <getcontentlanguage/>
        <lastaccessed/>
        <isstructureddocument/>
        <defaultdocument/>
        <isroot/>
      </prop>
      <status>HTTP/1.1 404 Not Found</status>
    </propstat>
    <propstat>
      <prop>
        <creationdate>2000-04-17T10:18:21-04:00</creationdate>
        <getlastmodified>2000-04-17T10:18:21-04:00</getlastmodified>
        <getcontentlength>0</getcontentlength>
        <resourcetype>
  <collection/>
</resourcetype>
        <displayname>A WebDAV resource.</displayname>
      </prop>
      <status>HTTP/1.1 200 Ok</status>
    </propstat>
    <href>/dav/New%20Folder/</href>
  </response>
  <response>
    <propstat>
      <prop>
        <name/>
        <parentname/>
        <href/>
        <ishidden/>
        <iscollection/>
        <isreadonly/>
        <getcontenttype/>
        <contentclass/>
        <getcontentlanguage/>
        <lastaccessed/>
        <isstructureddocument/>
        <defaultdocument/>
        <isroot/>
      </prop>
      <status>HTTP/1.1 404 Not Found</status>
    </propstat>
    <propstat>
      <prop>
        <creationdate>2000-04-13T10:00:07-04:00</creationdate>
        <getlastmodified>2000-04-13T10:01:58-04:00</getlastmodified>
        <getcontentlength>0</getcontentlength>
        <resourcetype>
  <collection/>
</resourcetype>
        <displayname>A WebDAV resource.</displayname>
      </prop>
      <status>HTTP/1.1 200 Ok</status>
    </propstat>
    <href>/dav/gifs/</href>
  </response>
  <response>
    <propstat>
      <prop>
        <name/>
        <parentname/>
        <href/>
        <ishidden/>
        <iscollection/>
        <isreadonly/>
        <getcontenttype/>
        <contentclass/>
        <getcontentlanguage/>
        <lastaccessed/>
        <resourcetype/>
        <isstructureddocument/>
        <defaultdocument/>
        <isroot/>
      </prop>
      <status>HTTP/1.1 404 Not Found</status>
    </propstat>
    <propstat>
      <prop>
        <creationdate>2000-04-27T12:05:34-04:00</creationdate>
        <getlastmodified>2000-04-27T12:05:35-04:00</getlastmodified>
        <getcontentlength>272</getcontentlength>
        <displayname>A WebDAV resource.</displayname>
      </prop>
      <status>HTTP/1.1 200 Ok</status>
    </propstat>
    <href>/dav/index.html</href>
  </response>
  <response>
    <propstat>
      <prop>
        <name/>
        <parentname/>
        <href/>
        <ishidden/>
        <iscollection/>
        <isreadonly/>
        <getcontenttype/>
        <contentclass/>
        <getcontentlanguage/>
        <lastaccessed/>
        <isstructureddocument/>
        <defaultdocument/>
        <isroot/>
      </prop>
      <status>HTTP/1.1 404 Not Found</status>
    </propstat>
    <propstat>
      <prop>
        <creationdate>2000-04-12T16:18:59-04:00</creationdate>
        <getlastmodified>2000-04-28T13:27:05-04:00</getlastmodified>
        <getcontentlength>0</getcontentlength>
        <resourcetype><collection/></resourcetype>
        <displayname>A WebDAV resource.</displayname>
      </prop>
      <status>HTTP/1.1 200 Ok</status>
    </propstat>
    <href>/dav</href>
  </response>
</multistatus>

---

From: [email-masked] (WJCarpenter)
Date: Fri, 28 Apr 2000 11:12:26 -0700

tim> Martin is right.  I tried with "OK" and "Ok" in the propstat
tim> status element.

I believe (but haven't confirmed) this whole "text stuff" problem is
fixed if the client is Windows2000.  Might also be fixed if the client 
machine runs Office2000 with the ill-fated SR1 installed.  I don't
know if there is (yet) a fix if you aren't in one of those buckets
(if, for example, you get your Web Folders by virtue of using a recent 
MSIE).
-- 
[email-masked] (WJCarpenter)    PGP 0x91865119
38 95 1B 69 C9 C6 3D 25    73 46 32 04 69 D6 ED F3