Subject: RE: DAV: header values

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 18 May 2000 12:46:52 -0400

I'd probably vote for

  extend = Coded-URL | token

so that standard DAV defined extensions can be specified in a terse form.

Cheers,
Geoff

-----Original Message-----
From: Greg Stein [mailto:[email-masked]]
Sent: Monday, April 10, 2000 5:37 PM
To: Juergen Reuter
Cc: [email-masked]; [email-masked]
Subject: Re: DAV: header values 

On Mon, 10 Apr 2000, Juergen Reuter wrote:
> P.S.:
> 
> However, the rule
> 
>    extend = Coded-URL
> 
> should be fine, because the rule
> 
>    Coded-URL = "<" absoluteURI ">"
> 
> implies that, as soon as you have encountered a "<", you can
> accept as many "," as you find, belonging all to the absoluteURI,
> until you finally reach a ">". (I suppose that is the reason why
> people think that the brackets are needed. :-))

Exactly!

All righty then... I'll resubmit my proposal:

   extend = "<" absoluteURI ">"

For semantic purposes, I expanded Coded-URL since we will certainly have
URI values in there (e.g. DAV:bindings) rather than URLs. In an If:
header, the "URL" term makes sense.

Back to my original point, then: does anybody see a problem if I updated
mod_dav to use the following DAV: header:

  DAV: 1,2,<http://apache.org/dav/0.9.16>

??

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---

From: Greg Stein <[email-masked]>
Date: Thu, 18 May 2000 10:25:14 -0700 (PDT)

I'm fine with this.

Note that mod_dav 0.9.17 (and the next release, 1.0.0) already uses a
Coded-URL in the DAV: header. Specifically a mod_dav response looks like:

    DAV: 1,2,<http://apache.org/dav/propset/fs/1>

Cheers,
-g