Subject: Re: Multistatus required in responses?

From: [email-masked]
Date: Fri, 5 May 2000 16:21:31 -0400

Are responses for specific methods required to be multistatus?
   ..
   I apologize if this question has been answered before on this list.

I believe it has been discussed.  I believe I brought it up and
the conclusion was that PROPPATCH and PROPFIND must return
multistatus and take no shortcuts.  The reasoning behind this
was that it made things more predictable for the client and
really wasn't any harder for the server.

If it's not already on the issues list, a clarification of this
should be added to that list.

---

From: Greg Stein <[email-masked]>
Date: Fri, 5 May 2000 15:42:36 -0700 (PDT)

> should be added to that list.

I would disagree. I think that it is quite valid to return something like
403 (Forbidden) or 401 (Authorization required) as a response. Heck, you
could also return something like 412 or 301, too.

In each of these cases, the 3xx or 4xx applies to the Request-URI. If a
status code ever applies to a URI *other* than the Request-URI (say,
caused by a Depth: header), then a 207 (Multistatus) MUST be returned.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---

From: "Kaushik Sridharan" <[email-masked]>
Date: Sat, 6 May 2000 14:18:43 +0530

[Greg Stein wrote:]
> caused by a Depth: header), then a 207 (Multistatus) MUST be returned.

In my initial query I had assumed that 4xx or 3xx are valid. I meant to ask
about successful responses -- whether they must be 207, or whether a 200
could be expected as well.

To paraphrase: Are 200 responses for PROPFIND allowed?

Thanks,

Kaushik

---

From: Greg Stein <[email-masked]>
Date: Sun, 7 May 2000 02:37:46 -0700 (PDT)

> To paraphrase: Are 200 responses for PROPFIND allowed?

Nope. If a PROPFIND succeeds, then it is going to be returning properties.
Therefore, it must return a 207 which contains the <multistatus> element.

Sure, it is theoretically possible to state that the 200 has the XML body,
but that's not what was defined. PROPFIND returns 207 on success.

Cheers,
-g