Subject: Re: internationalization

From: "Jim Whitehead" <[email-masked]>
Date: Thu, 7 Dec 2000 14:14:27 -0800

Stewart Hersey, man of many email addresses :-) (another one caught by the
spam filter).  I've added [email-masked] to the accept2 list.

- Jim

-----Original Message-----
From: Stewart Hersey [mailto:[email-masked]]
Sent: Thursday, December 07, 2000 1:23 AM
To: Jim Whitehead; WebDAV WG
Subject: [Moderator Action] Re: internationalization

Thanks Jim,

Tried to figure out how to line up my comments with the attached graphic.
I believe that it will be easier for us all if I post text only to the list
and
keep screenshots available elsewhere.

On a hunch I attempted to open
http://www.sharemation.com/~jane/international
as a Web Folder on a Japanese WinMe Box.

Success...

I took a series of screenshots to benchmark the process.
They are accessible in the directory that this URL points to:

http://www.newma.org/WebDAV_WG/

Please use the table below as a process reference while viewing the
screenshots.

Graphic Title                                  Explanation
-------------                       -----------------------------

screenshot1.png:                Translation - "Enter the name or address of
the document
                                         you would like to open" (note: Web
Folder is checked).

screenshot2.png:               After opening the URL as a Web Folder I took
this shot
                                        of  the "Konnichiwa Sekai"
directory.

screenshot3.png:              Wide view of the Web Folder (notice that WinMe
couldn't
                                       grok the Korean or first character of
the Chinese directory, this time).

screenshot4.png:              Drilled down into the tree and tossed a GIF
in, to get this shot.

screenshot5.png:               I was prompted for a name and password. I'll
try this again with success,
                                        I suspect, in the future...

screenshot6.png:              A shot of My Computer's system properties, for
the record.

screenshot7.png:              Internet Explorer Version screen, from the
Help tab, for authentication
                                       purposes.

screenshot8.png:              A final shot of the "Default View" that IE5.5
will show, saying Hello World
                                       in a variety of double-byte character
lingos.

web_folder_error.bmp:   The original screenshot of the error message/prompt
that
                                      Win2K Pro (EN) popped up.

Questions and comments are welcome.

I'll be glad to continue the experiment with input and suggestions from the
WebDAV WG members.
If supplied with a username and password, I'll generate a Word file with MS
Office2000 (Japanese) and
attempt to save succeeding versions of it to this site.

Cheers,

Stewart

S. Matthew Hersey
President and CTO
Newma Net Works, Inc.
www.newma.com

----- Original Message -----
From: "Jim Whitehead" <[email-masked]>
To: "WebDAV WG" <[email-masked]>
Sent: Wednesday, December 06, 2000 5:22 PM
Subject: RE: internationalization

> Accidentally caught by the spam filter.  See the very bottom for new
> content.  I have added S. Matthew Hersey [[email-masked]] to the
accept2
> list, so future posts from this address will go through.
>
> - Jim
>
> -----Original Message-----
> From: S. Matthew Hersey [mailto:[email-masked]]
> Sent: Wednesday, December 06, 2000 1:16 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Moderator Action] RE: internationalization
>
>
> ----- Original Message -----
> From: "Adam Klatzkin" <[email-masked]>
> To: "'Stewart Hersey'" <[email-masked]>; "Wright, Tom"
> <[email-masked]>; <[email-masked]>
> Sent: Wednesday, December 06, 2000 9:59 AM
> Subject: RE: internationalization
>
>
> Tom,
>
> If you open the URL as a web folder does it still work correctly for you?
>
> Adam Klatzkin
> Software Engineer
> Bentley Systems
>
> -----Original Message-----
> From: Stewart Hersey [mailto:[email-masked]]
> Sent: Tuesday, December 05, 2000 11:41 PM
> To: Wright, Tom; [email-masked]
> Subject: Re: internationalization
>
>
> Tom (et al),
>
> Works fine for me in  IE5.5 Japanese Version on the Windows ME (Japanese)
> platform.
> I'll try it on my Mac later today.
>
> Cheers
>
> Stewart
>
> S. Matthew Hersey
> President and CTO
> Newma Net Works, Inc.
> www.newma.com
>
>
> ----- Original Message -----
> From: "Wright, Tom" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, December 05, 2000 11:55 PM
> Subject: RE: internationalization
>
> > Well guys, IE5 doesnt seem to like your site, returning do you want the
> > default view instead message. It seems fine with HTML view, but not
> WebDAV.
> > Is this the behaviour every one else is seeing?
> >
> > Best Regards
> >
> > Tom
> >
> > -----Original Message-----
> > From: Kevin Wiggen [mailto:[email-masked]]
> > Sent: 06 December 2000 01:08
> > To: Jim Whitehead; Adam Klatzkin; [email-masked]
> > Cc: Greg Stein
> > Subject: RE: internationalization
> >
> >
> >
> > Actually I agree that client support for internationalization is
lacking,
> > but server support has always been there :)
> >
> > Take a look at
> >
> > http://www.sharemation.com/~jane/international
> >
> > Hello World in English, Spanish, Russian, Chinese, Japanese and Korean
> > (you'll need the fonts installed to see these correctly).
> >
> > As always, Xythos supports the Webdav protocol so you can also do
> PROPFINDs
> > to the server.
> >
> > Kevin
> > Xythos
> >
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Jim Whitehead
> > Sent: Tuesday, December 05, 2000 3:54 PM
> > To: Adam Klatzkin; [email-masked]
> > Cc: Greg Stein
> > Subject: RE: internationalization
> >
> >
> > Hmm, this is worse than I had feared.  Based on your experience, it
seems
> > the best near-term approach is to stick with single-byte latin
characters.
> >
> > Looking to the future, however, one of the ways you could help the
> community
> > is by hosting (or allowing me to host) a publically available DAV server
> > that has a directory containing multiple character sets. Ideally, you
> would
> > have a Web site with a picture of what it is supposed to look like, and
> then
> > the area where DAV clients could be directed for testing.  One of the
> > reasons why the current i18n support is so bad is due to the lack of a
> > publically available server that is responding with multi-byte
characters.
> >
> > Alternately, perhaps this is something that mod_dav can do, and perhaps
> Greg
> > Stein could provide a multi-byte character testing directory on
> webdav.org.
> > Greg?
> >
> > - Jim
> >
> > Adam Klatzkin writes:
> > > Can anybody offer any advice on implementing an internationalized
webDAV
> > > server that will work with existing webDAV clients.
> > > The server I am developing encodes all data in utf-8.  Whenever I
return
> > > this multistatus response to Microsoft web folders (under Win2K) if
the
> > > utf-8 stream contains all latin (single-byte) characters it works
> > > fine.  If
> > > there are characters in the stream that are multi-byte, web
> > > folders crashes.
> > > e.g.
> > > <D:displayname>My Folder</D:displayname>
> > > ^--- works fine
> > > <D:displayName>["My Folder" in the Arabic unicode
> > > subrange]</D:displayName>
> > > ^--- web folders crashes and explorer goes down with it.
> > >
> > > Under WinNT webfolders does not crash, but I get the following error
> > > "The current operation cannot be completed because an unexpected error
> has
> > > occurred"
> > >
> > > Using Riverfront WebDrive I do not receive any errors but the
> > > UTF-8 data is
> > > displayed as ASCII.
> >
>
>
> Adam & Tom,
>
> Browsable but unable to save as Web Folder on Win2K Pro (English).
>
> Error message screenshot attachment enclosed.
>
> Stewart
>

---

From: "S. Matthew Hersey" <[email-masked]>
Date: Thu, 7 Dec 2000 15:48:54 -0800

Thanks again Jim,

Still cannot open URL as Web Folder under Win2KPro (English) Management.
As mentioned earlier, could be lack of embedded support for double-byte characters.

*S*

----- Original Message ----- 
From: "Jim Whitehead" <[email-masked]>
To: "WebDAV WG" <[email-masked]>
Sent: Thursday, December 07, 2000 2:14 PM
Subject: Re: internationalization

- Jim

-----Original Message-----
From: Stewart Hersey [mailto:[email-masked]]
Sent: Thursday, December 07, 2000 1:23 AM
To: Jim Whitehead; WebDAV WG
Subject: [Moderator Action] Re: internationalization

Thanks Jim,

Success...

Cheers,

Stewart

S. Matthew Hersey
President and CTO
Newma Net Works, Inc.
www.newma.com

----- Original Message -----
From: "Jim Whitehead" <[email-masked]>
To: "WebDAV WG" <[email-masked]>
Sent: Wednesday, December 06, 2000 5:22 PM
Subject: RE: internationalization

accept2
lacking,
seems
characters.
characters.
webDAV
return
the

---

From: "S. Matthew Hersey" <[email-masked]>
Date: Thu, 7 Dec 2000 16:34:31 -0800

Thank you once again, Jim, for posting my previous message.

As per Kevin's instructions:

I created an account @ Sharemation.

As soon as Kevin gives me write access to the folders,
I'll continue with the experiment on our WinMe (JP) box.

I'll be sure to include the following tasks:

1. Chuck a gif into the Japanese folder.
2. Save an html file in Japanese.
3. Upload a word file. Update the file remotely.
4. Attempt to write to and update files in other folders.
5.Other tests or procedures defined by this group's input.
6.Tests with Win2KPro (EN) and other operating systems.

Questions, Comments, Suggestions are welcome.

Stewart

----- Original Message ----- 
From: "S. Matthew Hersey" <[email-masked]>
To: "Jim Whitehead" <[email-masked]>; "WebDAV WG" <[email-masked]>
Sent: Thursday, December 07, 2000 3:48 PM
Subject: Re: internationalization

Thanks again Jim,

*S*

----- Original Message ----- 
From: "Jim Whitehead" <[email-masked]>
To: "WebDAV WG" <[email-masked]>
Sent: Thursday, December 07, 2000 2:14 PM
Subject: Re: internationalization

- Jim

-----Original Message-----
From: Stewart Hersey [mailto:[email-masked]]
Sent: Thursday, December 07, 2000 1:23 AM
To: Jim Whitehead; WebDAV WG
Subject: [Moderator Action] Re: internationalization

Thanks Jim,

Success...

Cheers,

Stewart

S. Matthew Hersey
President and CTO
Newma Net Works, Inc.
www.newma.com

----- Original Message -----
From: "Jim Whitehead" <[email-masked]>
To: "WebDAV WG" <[email-masked]>
Sent: Wednesday, December 06, 2000 5:22 PM
Subject: RE: internationalization

accept2
lacking,
seems
characters.
characters.
webDAV
return
the