Subject: RE: internationalization

From: "S. Matthew Hersey" <[email-masked]>
Date: Wed, 6 Dec 2000 18:23:34 -0800

Adam & Tom,

URL is browsable but unable to save as Web Folder on Win2K Pro (English).

Error message screenshot attachment enclosed.

Stewart

S. Matthew Hersey
Technical Writer, Operations
Certainty Solutions, Inc.

"Certainty in an Uncertain World"

----- Original Message ----- 
From: "Adam Klatzkin" <[email-masked]>
To: "'Stewart Hersey'" <[email-masked]>; "Wright, Tom" <[email-masked]>; <[email-masked]>
Sent: Wednesday, December 06, 2000 9:59 AM
Subject: RE: internationalization

Tom,

If you open the URL as a web folder does it still work correctly for you?

Adam Klatzkin
Software Engineer
Bentley Systems

-----Original Message-----
From: Stewart Hersey [mailto:[email-masked]]
Sent: Tuesday, December 05, 2000 11:41 PM
To: Wright, Tom; [email-masked]
Subject: Re: internationalization

Tom (et al),

Works fine for me in  IE5.5 Japanese Version on the Windows ME (Japanese)
platform.
I'll try it on my Mac later today.

Cheers

Stewart

S. Matthew Hersey
President and CTO
Newma Net Works, Inc.
www.newma.com

----- Original Message -----
From: "Wright, Tom" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, December 05, 2000 11:55 PM
Subject: RE: internationalization

> Well guys, IE5 doesnt seem to like your site, returning do you want the
> default view instead message. It seems fine with HTML view, but not
WebDAV.
> Is this the behaviour every one else is seeing?
>
> Best Regards
>
> Tom
>
> -----Original Message-----
> From: Kevin Wiggen [mailto:[email-masked]]
> Sent: 06 December 2000 01:08
> To: Jim Whitehead; Adam Klatzkin; [email-masked]
> Cc: Greg Stein
> Subject: RE: internationalization
>
>
>
> Actually I agree that client support for internationalization is lacking,
> but server support has always been there :)
>
> Take a look at
>
> http://www.sharemation.com/~jane/international
>
> Hello World in English, Spanish, Russian, Chinese, Japanese and Korean
> (you'll need the fonts installed to see these correctly).
>
> As always, Xythos supports the Webdav protocol so you can also do
PROPFINDs
> to the server.
>
> Kevin
> Xythos
>
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jim Whitehead
> Sent: Tuesday, December 05, 2000 3:54 PM
> To: Adam Klatzkin; [email-masked]
> Cc: Greg Stein
> Subject: RE: internationalization
>
>
> Hmm, this is worse than I had feared.  Based on your experience, it seems
> the best near-term approach is to stick with single-byte latin characters.
>
> Looking to the future, however, one of the ways you could help the
community
> is by hosting (or allowing me to host) a publically available DAV server
> that has a directory containing multiple character sets. Ideally, you
would
> have a Web site with a picture of what it is supposed to look like, and
then
> the area where DAV clients could be directed for testing.  One of the
> reasons why the current i18n support is so bad is due to the lack of a
> publically available server that is responding with multi-byte characters.
>
> Alternately, perhaps this is something that mod_dav can do, and perhaps
Greg
> Stein could provide a multi-byte character testing directory on
webdav.org.
> Greg?
>
> - Jim
>
> Adam Klatzkin writes:
> > Can anybody offer any advice on implementing an internationalized webDAV
> > server that will work with existing webDAV clients.
> > The server I am developing encodes all data in utf-8.  Whenever I return
> > this multistatus response to Microsoft web folders (under Win2K) if the
> > utf-8 stream contains all latin (single-byte) characters it works
> > fine.  If
> > there are characters in the stream that are multi-byte, web
> > folders crashes.
> > e.g.
> > <D:displayname>My Folder</D:displayname>
> > ^--- works fine
> > <D:displayName>["My Folder" in the Arabic unicode
> > subrange]</D:displayName>
> > ^--- web folders crashes and explorer goes down with it.
> >
> > Under WinNT webfolders does not crash, but I get the following error
> > "The current operation cannot be completed because an unexpected error
has
> > occurred"
> >
> > Using Riverfront WebDrive I do not receive any errors but the
> > UTF-8 data is
> > displayed as ASCII.
>

---

From: "Stewart Hersey" <[email-masked]>
Date: Thu, 7 Dec 2000 10:58:29 -0800

Now 21:00 hrs PMT 12/07/2000

Experiment underway using WinMe (JP) to place files in:
 http://www.sharemation.com/~jane/international

Image Title                                     Explanation
-----------                                 ---------------------------
screenshot9.png                         Dropped in index.html (Would you
like to overwrite?)

screenshot10.png                       Error in one or more of the folders
you tried to copy to.

screenshot11.png                       You can't save here. Try somewhere
else.

eureka.png                                 Created a new folder named
WebDAV, saved html
                                                  file inside it and tossed
it into ~jane/international !

eureka2.png                                Took a screenshot of the process
as it happened, and
                                                   chucked in the png file!

NOTE: I only succeeded in saving to sharemation when I opened the folder
from within another
application's "save as" window. I use TechSmith SnagIT to take my
screenshots, and to open ~jane.

Tried to save the Web Folder as a FrontPage 2000 Web (Web Folder becomes
.ink extension).
Tried to save a new file into ~jane/international/WebDAV with
FrontPage...FTP not supported.

changename.png                         Changed the name of eureka.png to
k.png

cantchangename.png                   Couldn't change the name of the file to
konnichiwa sekai (in Japanese).

End of Experiment 22:56 hrs PMT 12/07/2000

I will continue with the Phase II tomorrow. I will attempt to access the
folder with Word 2000 "Save As".
I will attempt to save a new version of index.html on to of the current
version.

Cheers

Stewart Hersey
Newma Net Works

http://www.newma.org/WebDAV_WG/

---

From: Greg Stein <[email-masked]>
Date: Thu, 7 Dec 2000 23:20:14 -0800

It would be really great if you could also do a bit of testing against
http://test.webdav.org/dav/  (mod_dav 1.0.1)

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---

From: "Stewart Hersey" <[email-masked]>
Date: Thu, 7 Dec 2000 23:24:59 -0800

Greg,

I'd love to.
But, not this evening.

zzz

:-)

Stewart
http://www.newma.com
"We put the 'E' in NET!

---

From: "Stewart Hersey" <[email-masked]>
Date: Thu, 7 Dec 2000 23:53:28 -0800

OK...

I couldn't resist.

Created a folder named "Hello World", yes, in Japanese (今日は世界).
The file inside was called helloworld.htm so I renamed it to KonnichiwaSekai ( 今日は世界.htm)

Took two screenshots with SnagIT and tossed them in as well.
Copies of these shots also live @ http://www.newma.org/WebDAV_WG .

All's well that ends well.

*S*

----- Original Message -----
From: "Greg Stein" <[email-masked]>
To: "Stewart Hersey" <[email-masked]>
Sent: Thursday, December 07, 2000 11:44 PM
Subject: Re: internationalization

> :-)
>
> Not a problem! Anything that you can do would be a help.
>
> Cheers,
> -g
>
> On Thu, Dec 07, 2000 at 11:24:59PM -0800, Stewart Hersey wrote:
> > Greg,
> >
> > I'd love to.
> > But, not this evening.
> >
> > zzz
> >
> > :-)
> >
> > Stewart
> > http://www.newma.com
> > "We put the 'E' in NET!
> >

---

From: Greg Stein <[email-masked]>
Date: Fri, 8 Dec 2000 00:06:10 -0800

Well... that seemed to work all right, eh? :-)

Thx!
-g

On Thu, Dec 07, 2000 at 11:53:28PM -0800, Stewart Hersey wrote:
> OK...
> 
> I couldn't resist.
> 
> Created a folder named "Hello World", yes, in Japanese (??h??).
> The file inside was called helloworld.htm so I renamed it to KonnichiwaSekai ( ??h??.htm)
>

---

From: "Stewart Hersey" <[email-masked]>
Date: Fri, 8 Dec 2000 00:12:53 -0800

Well, yes (initially) and no. 

Couldn't view (open) the html with IE5.5 (JP) by clicking on the files within the Web Folders view.

Will try a series of different experiments over the next few days.

As usual, I'll take screenshots for the benefit of those folks who are reading this in a Unix shell,
or who cannot view double-byte Kanji.

All the best,

Stewart
Newma Net Works