Subject: RE: PROPFIND returning *more* than expected, and other questions

From: "Clemm, Geoff" <[email-masked]>
Date: Fri, 17 Jan 2003 17:50:25 -0500

Minimally, we should indicate that PROPFIND MUST NOT ignore
unknown XML elements.

I personally would prefer us to state that PROPFIND SHOULD
(or even MUST) only return requested properties, unless
someone can come up with a compelling reason for not adding
this constraint.

Cheers,
Geoff

-----Original Message-----
From: Jason Crawford [mailto:[email-masked]]
Sent: Friday, January 17, 2003 5:35 PM
To: Clemm, Geoff
Cc: [email-masked]; [email-masked]
Subject: RE: PROPFIND returning *more* than expected, and other
questions

Do we think we need to enhance the spec in any way?  Or is it clear enough
now?

J.  (Yes, I'm alive... at least for the next 45 minutes. :-))

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Lisa Dusseault" <[email-masked]>
Date: Fri, 17 Jan 2003 20:50:40 -0800

Sorry, what's the rationale for PROPFIND not ignoring unknown XML
elements?  Does this mean anywhere in the propfind body or just in
certain places? I assume it's supposed to fail when it sees unknown
elements?

This would make some existing client/server interactions fail -- e.g.
clients that have already shipped extending the PROPFIND request in ways
that ordinary WebDAV servers ignore, but special WebDAV servers know the
extension & behave smarter.

lisa

> From: Clemm, Geoff [mailto:[email-masked]]
> Sent: Friday, January 17, 2003 2:50 PM
> To: [email-masked]
questions

---

From: "Julian Reschke" <[email-masked]>
Date: Sat, 18 Jan 2003 09:22:23 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Lisa Dusseault
> Sent: Saturday, January 18, 2003 5:51 AM
> To: 'Clemm, Geoff'; [email-masked]
> ...

Nope. PROPFIND must ignore unknown elements (hint: some servers don't...),
*except* when child of a DAV:prop or DAV:propname element.

Right, Geoff?

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: "Julian Reschke" <[email-masked]>
Date: Sat, 18 Jan 2003 10:13:22 +0100

> [mailto:[email-masked]]On Behalf Of Julian Reschke
> Sent: Saturday, January 18, 2003 9:22 AM
> To: Lisa Dusseault; 'Clemm, Geoff'; [email-masked]

(after the morning coffee...):

...*except* when child of a DAV:prop element.