Subject: RE: WebDAV and 404-handling

From: "Clemm, Geoff" <[email-masked]>
Date: Thu, 16 Jan 2003 17:55:48 -0500

If you knew that all of your clients will just display
the literal string "404- Not Found" whenever they receive
a 404 status (and they don't try to display the response
body), then you'd be tempted to compose a nice error message
page, and return 200 to avoid the poor 404 behavior of
your clients.  This is the "dumb client workaround" approach.

Note that I do not advocate this approach, since that makes
your web site perform poorly with smart clients, but I
think we should acknowledge that there are situations where
violating the protocol in this way produces a better user
experience.

To repeat though, this is not something I advocate, and it
violates the protocol.

Cheers,
Geoff

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]]
Sent: Thursday, January 16, 2003 5:18 PM
To: Clemm, Geoff; [email-masked]
Subject: RE: WebDAV and 404-handling

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Clemm, Geoff
> Sent: Thursday, January 16, 2003 7:12 PM
> To: [email-masked]
> Subject: RE: WebDAV and 404-handling
>
>
>
> Currently, there is no standard WebDAV content for a 404
> body, so you can replace that body without violating
> the WebDAV standard.  Probably the safest thing to do is to
> only substitute the error page if the 404-body is
> empty.
>
> I do see a tension here between what the server would
> want to do for a "dumb" client (that just knows how to
> render html, and does nothing interesting with status
> codes) and what it would do for a "smart" client.  I
> personally agree with Julian and Lisa that in these cases,
> the needs of the smart client should take precedence, and
> the correct error code (404) should be returned.

I don't understand this statement.

If  the resource was not found, return HTTP status 404. If you want to send
descriptive text, do so, but do *not* change the status code. That would be
a bug, and I really don't understand what it's good for.

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: "Julian Reschke" <[email-masked]>
Date: Fri, 17 Jan 2003 00:03:37 +0100

> Sent: Thursday, January 16, 2003 11:56 PM
> To: [email-masked]

I see. Is this just theoretical reasoning, or *are there* actually broken
clients like these?

> To repeat though, this is not something I advocate, and it

Yes.