Subject: RE: comments on RFC2518bis-02, sec 6.3

From: "Lisa Dusseault" <[email-masked]>
Date: Sun, 29 Jun 2003 10:50:04 -0700

> > > 5) Section 6.3, p3
> > >
> > > Replace
> > >
> > > "However resources are free to return any URI scheme so 
> long as it 
> > > meets
> > the
> > > uniqueness requirements."
> > >
> > > by
> > >
> > > "However servers are free to use any IETF-registered URI 
> scheme so 
> > > long
> > as
> > > it meets the uniqueness requirements."
> >
> > ? Is it important to be IETF registered ?
> 
> Yes. A non-registered URI scheme doesn't have *any* 
> guaranteed uniqueness, so it doesn't serve it's stated purpose...
> 

That's not true.  If I create a URI scheme where the scheme name is
"http://www.xythos.com/storageServer/locktoken/", without registering this
with the IETF, it can still meet the uniqueness guarantee.

For that matter, a sufficiently long randomly generated set of characters,
as long as it meets the URI formatting requirements, statistically meets the
uniqueness guarantee.

Lisa

---

From: "Julian Reschke" <[email-masked]>
Date: Sun, 29 Jun 2003 20:11:36 +0200

> From: Lisa Dusseault [mailto:[email-masked]]
> Sent: Sunday, June 29, 2003 7:50 PM
> To: 'Julian Reschke'; 'Jason Crawford'
> Cc: [email-masked]
> Subject: RE: comments on RFC2518bis-02, sec 6.3
>

You can't create a URI scheme with that kind of scheme name. The scheme part
of a URI is the string before the first colon, so the URI scheme for that
URI is just "http" (which indeed *is* a registered URI scheme).

And yes, you can use these kinds of URIs for lock tokens.

> as long as it meets the URI formatting requirements,

How do you "statistically" meet a requirement?

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760