Subject: BIND: precondition DAV:locked-update-allowed

From: "Nevermann, Dr., Peter" <[email-masked]>
Date: Wed, 18 Jun 2003 17:48:29 +0200

What return code should a BIND request return, if the precondition
DAV:locked-update-allowed is violated, i.e. the collection identified by the
request-URI is write-locked, but no appropriate token has been specified in
an If request header?

1) 409 "Conflict" with <D:error><D:locked-update-allowed/></error> in the
response-body

2) 423 "Locked"

3) 423 "Locked" with <D:error><D:locked-update-allowed/></error> in the
response-body

My feeling is that 2) would be correct.

Thanks,
Peter

---

From: "Julian Reschke" <[email-masked]>
Date: Wed, 18 Jun 2003 18:12:33 +0200

I'd say that 3) would always be better (because more specific) than 2).

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760 

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Nevermann, Dr., Peter
> Sent: Wednesday, June 18, 2003 5:48 PM
> To: [email-masked]'
> Subject: BIND: precondition DAV:locked-update-allowed
> 
> 
>

---

From: Elias Sinderson <[email-masked]>
Date: Wed, 18 Jun 2003 09:35:32 -0700

I think that, while (2) is correct, (3) is more correct as providing 
greater detail is preferred.

Cheers,
Elias