Subject: WebDAV Compliance Case Studies

From: Frank Lowney <[email-masked]>
Date: Thu, 14 Aug 2003 14:32:18 -0400

Continuing with the WebSTAR V case study and following Julian 
Reschke's tip on running the litmus test, we have more results for 
your comment.  How many of these failure pointa map to real world 
operations likely to impact end users?

-> running `basic':
  0. init.................. pass
  1. begin................. pass
  2. options............... pass
  3. put_get............... pass
  4. put_get_utf8_segment.. pass
  5. mkcol_over_plain...... pass
  6. delete................ pass
  7. delete_null........... pass
  8. mkcol................. pass
  9. mkcol_again........... pass
10. delete_coll........... pass
11. mkcol_no_parent....... WARNING: MKCOL with missing intermediate 
gave 403, should be 409
     ...................... pass (with 1 warning)
12. mkcol_with_body....... FAIL (MKCOL with weird body must fail 
(RFC2518:8.3.1))
13. finish................ pass
<- summary for `basic': of 14 tests run: 13 passed, 1 failed. 92.9%
-> 1 warning was issued.
-> running `copymove':
  0. init.................. pass
  1. begin................. pass
  2. copy_init............. pass
  3. copy_simple........... pass
  4. copy_overwrite........ pass
  5. copy_cleanup.......... pass
  6. copy_coll............. pass
  7. move.................. pass
  8. move_coll............. FAIL (MOVE collection 
`/path/litmus/mvdest2/' over non-collection `/path/litmus/mvnoncoll' 
with overwrite: 404 Not Found)
  9. move_cleanup.......... pass
10. finish................ pass
<- summary for `copymove': of 11 tests run: 10 passed, 1 failed. 90.9%
-> running `props':
  0. init.................. pass
  1. begin................. pass
  2. propfind_invalid...... pass
  3. propfind_invalid2..... FAIL (PROPFIND with invalid namespace 
declaration in body (see FAQ) got 207 response not 400)
  4. propfind_d0........... pass
  5. propinit.............. pass
  6. propset............... pass
  7. propget............... pass
  8. propmove.............. pass
  9. propget............... pass
10. propdeletes........... pass
11. propget............... pass
12. propreplace........... pass
13. propget............... pass
14. propnullns............ pass
15. propget............... FAIL (PROPFIND on `/path/litmus/prop2': 
Invalid namespace declaration for 'xmlns:ns2' in 'D:response' at line 
2.)
16. prophighunicode....... pass
17. propget............... FAIL (PROPFIND on `/path/litmus/prop2': 
Invalid namespace declaration for 'xmlns:ns2' in 'D:response' at line 
2.)
18. propvalnspace......... pass
19. propwformed........... FAIL (PROPFIND response was not 
well-formed: Invalid namespace declaration for 'xmlns:ns2' in 
'D:response' at line 2.)
20. propinit.............. pass
21. propmanyns............ pass
22. propget............... pass
23. propcleanup........... pass
24. finish................ pass
<- summary for `props': of 25 tests run: 21 passed, 4 failed. 84.0%
-> running `http':
  0. init.................. pass
  1. begin................. pass
  2. expect100............. FAIL (timeout waiting for interim response)
  3. finish................ pass
<- summary for `http': of 4 tests run: 3 passed, 1 failed. 75.0%
-- 
=====================================================================
Dr. Frank Lowney  [email-masked]
     Director, Electronic Instructional Services, a unit of the
     Office of Information and Instructional Technology,
     Professional Pages: http://www.gcsu.edu/oiit/eis/
     Personal Pages: http://www.faculty.de.gcsu.edu/~flowney
Voice: (478) 445-5260
=====================================================================
We don't make instruction effective, we make effective instruction 
more accessible.

---

From: "Julian Reschke" <[email-masked]>
Date: Thu, 14 Aug 2003 21:02:29 +0200

Frank,

1) I'd say whenever Litmus is reporting a FAIL that is serious. For
instance, the FAIL for props 3 indicates that the server doesn't use a
compliant XML parser.

2) Did you use the latest Litmus version? 0.9.2 includes many more tests,
I'm not sure why they weren't run in your case (maybe -k doesn't work as
advertised). For instance, I'm missing results of LOCK tests.

At the end of the day, Litmus is the thing closest to a "conformance test
suite" that we have. If a server produces failures, I'd recommend to get
back to the vendor and ask for an explanation.

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Frank Lowney
> Sent: Thursday, August 14, 2003 8:32 PM
> To: [email-masked]
> Subject: WebDAV Compliance Case Studies
>
>
>