Subject: BIND: precondition DAV:locked-overwrite-allowed

From: "Nevermann, Dr., Peter" <[email-masked]>
Date: Sun, 3 Aug 2003 17:24:09 +0200

Some time ago, I asked what status code should a BIND request return, if the
precondition
DAV:locked-update-allowed is violated. Apparently, there has been consensus
in that is should be:

423 "Locked" with <D:error><D:locked-update-allowed/></error> in the
response-body

What if DAV:locked-overwrite-allowed is violated? It could be:

1) 423 "Locked" with <D:error><D:locked-overwrite-allowed/></error> in the
response-body

2) 409 "Conflict" with <D:error><D:locked-overwrite-allowed/></error> in the
response-body

Isn't 2) more reasonable in this case, because this time it is not the
resource identified by the request URI which is locked?

Thanks,
Peter

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 4 Aug 2003 11:53:27 +0200

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Nevermann, Dr., Peter
> Sent: Sunday, August 03, 2003 5:24 PM
> To: [email-masked]'
> Subject: BIND: precondition DAV:locked-overwrite-allowed
>
>
> 2) 409 "Conflict" with
> <D:error><D:locked-overwrite-allowed/></error> in the
> response-body

Agreed.

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760