Subject: Re: redirect references protocol: MKRESOURCE issue

From: Geoffrey M Clemm <[email-masked]>
Date: Wed, 7 Jan 2004 18:14:18 -0500

I would suggest that we resolve these issues as follows:

- allow PROPPATCH to update the DAV:reftarget property

- have an additional property that specifies the status that
will be returned, e.g. DAV:redirectref-status
that has an integer value of either 301 or 302.

Cheers,
Geoff 

Julian on 01/05/2004 07:40:42 AM:

> 
> Hi,
> 
> there was an outstanding issue to replace MKRESOURCE by a less generic 
> method that only creates redirects and does not overlap with PROPPATCH.
> 
> This was added in the current edits at 
> <http://greenbytes.de/tech/webdav/draft-ietf-webdav-redirectref-
> protocol-latest.html#METHOD_MKREDIRECTREF>.
> 
> The following issues remain:
> 
> - missing ability to update the target without having to delete and 
> re-create the redirect resource (proposal: just add UPDATEREDIRECTREF)
> 
> - missing ability to create specific redirect types (such as those 
> generating a 301 rather than a 302)
> 
> 
> Regards, Julian
> 
> 
> -- 
> <green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760
>

---

From: "Lisa Dusseault" <[email-masked]>
Date: Wed, 7 Jan 2004 15:20:01 -0800

That does seem simpler to me, if we *do* in fact need both 301-style and 
302-style.  I recall the explanation that HTTP supports both, but that
doesn't
prove that WebDAV needs to create both.  Are both equally prevalent on the
Web?

lisa

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Geoffrey M Clemm
> Sent: Wednesday, January 07, 2004 3:14 PM
> To: webdav
> Subject: Re: redirect references protocol: MKRESOURCE issue
> 
> 
>

---

From: Geoffrey M Clemm <[email-masked]>
Date: Wed, 7 Jan 2004 18:23:13 -0500

I don't know whether they are equally prevalent, but I certainly
see many examples of each (and know of web-indexing programs that
act differently depending on which it sees).

Cheers,
Geoff

---

From: Julian Reschke <[email-masked]>
Date: Thu, 08 Jan 2004 00:49:59 +0100

> - allow PROPPATCH to update the DAV:reftarget property

Historically, people wanted the spec to be independant of WebDAV, so 
they wouldn't need full PROPPATCH support for the updated. However, that 
was over three years ago. So yes, unless somebody pushes back, making 
these PROPPATCHable would work to.

> that has an integer value of either 301 or 302.

Sounds good.

Thanks for the feedback,

Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 05 Jan 2004 13:40:42 +0100

Hi,

This was added in the current edits at 
<http://greenbytes.de/tech/webdav/draft-ietf-webdav-redirectref-protocol-latest.html#METHOD_MKREDIRECTREF>.

Regards, Julian