Subject: RE: cdo and webdav

From: "Lisa Dusseault" <[email-masked]>
Date: Wed, 7 Jan 2004 09:52:40 -0800

This resource explains how to use HTTP/WebDAV PUT to add a message to
outbox:
http://msdn.microsoft.com/library/en-us/e2k3/e2k3/_esdk_sending_a_message_we
bdav.asp

This page explains how to use PROPPATCH to create a new calendar
appointment:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q308373

Each of these help pages shows code, not HTTP/WebDAV requests, but you can
glean the request information from the code.

Either of these two methods should work for inbox, as well.  You will have
to figure out which properties to PROPPATCH to create a valid email or other
item, but you can figure that out by doing PROPFIND on existing resources
inside an inbox.  Also, the Exchange property schema is documented here:
http://msdn.microsoft.com/library/en-us/dnmes2k/html/wssschemause.asp

Lisa

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Jonathan Yu
> Sent: Wednesday, January 07, 2004 8:55 AM
> To: [email-masked]
> Subject: cdo and webdav
> 
> 
> 
> 
> Hi,
> 
> Currently, we are using microsoft CDO to send email to the 
> microsoft exchange inbox.  How does WEBDAV apply to this 
> process?  What methods can I use to do the same in WEBDAV?
> 
> Appreciate if someone can respond.
> Jonathan Yu  (403)319-6633
> 
> 
>

---

From: "Jonathan Yu" <[email-masked]>
Date: Wed, 7 Jan 2004 09:54:54 -0700

Hi,

Currently, we are using microsoft CDO to send email to the microsoft exchange inbox.  How does WEBDAV apply to this process?  What methods can I use to do the same in WEBDAV?