Subject: [websec] CRIME II alleged at Black Hat

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 2 Jul 2013 09:52:47 -0400

http://www.darkreading.com/vulnerability/https-side-channel-attack-a-tool-for-enc/240157583

We do not have the details yet. But it seems like this will be yet another
variant of the 'in the browser' adaptive plaintext attack against SSL
enabling cookie stealing.

There are two problems we need to fix:

1) Whatever the latest SSL issue is.

2) Stop using bearer tokens for authentication.

I anticipated this attack (it is the third time round after all) which is
why I wrote the session ID scheme as a drop in replacement for cookies. In
the short term sites would have to support both schemes as a transitional
measure but given the current transition to HTML5 it is entirely likely
that some sites can force a transition sooner.

http://www.ietf.org/id/draft-hallambaker-httpsession-01.txt

-- 
Website: http://hallambaker.com/

---

From: Tom Ritter <[email-masked]>
Date: Tue, 2 Jul 2013 09:59:56 -0400

> enabling cookie stealing.

Reading from what they're targeting: "could make it possible for
targeted attackers to dig up secrets like session identifiers, CSRF
tokens, OAuth tokens, and ViewState hidden fields " - I'm 90% certain
this is an attack on HTTP compression.  CSRF tokens and ViewState are
in the HTTP response body.  Session IDs and OAuth tokens *may* be in
the body in some cases.

-tom

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 2 Jul 2013 17:38:51 +0300

[I posted this mail also the CA Browser Forum list but it is read-only for non-members only. So, I post it here.]

Hi Phil, 

I am always a bit reluctant when I hear about these types of attacks. In many cases, they are very basic and make various assumptions. In the OAuth working group we had looked into various attacks and many of them turned out to be an implementation flaw: someone tried to make some short-cuts and then had to pay the price for it. The most recent example was Facebook earlier this year. 

So, I am looking forward to see the details of this attack. 

If you know the speakers maybe it is possible to get in touch with them upfront. 

Just saying move away from bearer tokens is certainly simplistic for a number of reasons. 

Ciao
Hannes

On Jul 2, 2013, at 4:52 PM, Phillip Hallam-Baker wrote:

> We do not have the details yet. But it seems like this will be yet another variant of the 'in the browser' adaptive plaintext attack against SSL enabling cookie stealing.
> 
> I anticipated this attack (it is the third time round after all) which is why I wrote the session ID scheme as a drop in replacement for cookies. In the short term sites would have to support both schemes as a transitional measure but given the current transition to HTML5 it is entirely likely that some sites can force a transition sooner.
> 
> _______________________________________________
> websec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/websec