Subject: [xml2rfc] non-IETF copyright?

From: Dave CROCKER <[email-masked]>
Date: Mon, 25 Apr 2011 10:55:36 -0700

Folks,

As I recall, xml2rfc can be used for more than IETF I-D and RFC production.  As 
such it at least needs to have different copyright information, including not 
having the "Intellectual Property and Copyright Statements" section at the end.

I'm not finding documentation for how to do this.

    <rfc
    ipr="none"
     submissionType="independent"

helps, but does nothing about the ending section.

Any guidance?

Thanks.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 26 Apr 2011 21:33:23 +0200

On 25 April 2011 19:55, Dave CROCKER <[email-masked]> wrote:

> As I recall, xml2rfc can be used for more than IETF I-D and RFC
> production.

Yes, it can generate slide shows (I never tested this feature) and
"private" drafts (like an I-D, minus boilerplates). That used to
work fine three years ago, therefore my search for "xml2rfc private"
hopefully produced a relevant hit:

http://osdir.com/ml/text.xml.rfc/2006-06/msg00026.html

P.S.: Sorry, my private reply was an error, now resent to the list.

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 29 Apr 2011 09:12:41 -0700

> http://osdir.com/ml/text.xml.rfc/2006-06/msg00026.html

Excellent.  That seemed to remove all of the problematic text.

In particular:

      <?rfc private="(c) Author, Year" ?>

Strips out all of the IETF-related copyright and IPR stuff and puts this new 
string in the upper right corner.  It's a hokey way to add new copyright info, 
but I think it suffices for the formalities.

Thanks!

d/
-- 

   Dave Crocker