Subject: [xml2rfc] Why doesn't the "strict" mode recognize "appendix"?

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 14 Apr 2011 10:23:43 +0200

Hi,

I just updated a I-D and tried running it through xml2rfc - in "strict"
mode it fails and cites the two "appendix" clauses as the problem, in
the "fast" mode, it completes with the proper txt file.

Last time I looked - 'appendix" was in the DTD - has something changed?

Best regards,
Yaacov Weingarten
Nokia Siemens Networks
Industry Environment, PTE
ph#:  +972-9-775 1827
mob#: +972-54-220 0977

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Apr 2011 10:42:00 +0200

On 14.04.2011 10:23, Weingarten, Yaacov (NSN - IL/Hod HaSharon) wrote:
> Hi,
>
> I just updated a I-D and tried running it through xml2rfc – in "strict"
> Last time I looked – 'appendix" was in the DTD – has something changed?

It is deprecated; just use <section> inside <back>.

In the DTD it appears to be present but not referenced, so this probably 
should be cleaned up.

 > ...

Best regards, Julian

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Thu, 14 Apr 2011 16:01:27 +0200

Hi,

I followed your advice - moved the </middle> <back> before the appendix, and then changed to <section ..> and </section> and then I received an error message that said that back only accepts (references*,section*) !!
The non-strict option had no problems!  What am I doing wrong?

Thanx

>> -----Original Message-----
>> From: ext Julian Reschke [mailto:[email-masked]]
>> Sent: ה 14 אפריל 2011 11:42
>> To: Weingarten, Yaacov (NSN - IL/Hod HaSharon)
>> Cc: [email-masked]
>> Subject: Re: [xml2rfc] Why doesn't the "strict" mode recognize
>> "appendix"?
>>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Apr 2011 16:10:38 +0200

On 14.04.2011 16:01, Weingarten, Yaacov (NSN - IL/Hod HaSharon) wrote:
> Hi,
>
> I followed your advice - moved the</middle>  <back>  before the appendix, and then changed to<section ..>  and</section>  and then I received an error message that said that back only accepts (references*,section*) !!

Hard to say without seeing the input.

What is the contents of <back>? It should be just <references> and 
<section> elements, in this order.

Best regards, Julian

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 14 Apr 2011 10:12:22 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Weingarten, Yaacov (NSN - IL/Hod HaSharon) [[email-masked]]

I followed your advice - moved the </middle> <back> before the appendix, and then changed to <section ..> and </section> and then I received an error message that said that back only accepts (references*,section*) !!
_______________________________________________

The text "(references*,section*)" is a regexp (more or less) telling what are allowed contents for <back>.  If I read it correctly, it means "zero or more <references> followed by zero or more <section>".  I would guess that your <section> is before a <references>.

Dale