Subject: [xml2rfc] xml2rfc isn't putting the filename into the document

From: Paul Kyzivat <[email-masked]>
Date: Sun, 01 May 2011 17:58:09 -0400

Today when I run xml2rfc (from http://xml.resource.org), its not putting 
the filename into the subject line. Instead, its putting: CGItemp9380-2 
there.

Then of course the submission tool is complaining and forbidding me from 
submitting the revised doc. :-(

	Help!
	Paul

---

From: Julian Reschke <[email-masked]>
Date: Mon, 02 May 2011 15:50:11 +0200

> submitting the revised doc. :-(

For me it works.

Does your input document have a /rfc/@docName attribute? It should.

Best regards, Julian

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 02 May 2011 16:26:52 -0400

> Does your input document have a /rfc/@docName attribute? It should.

It didn't, and never needed it before.

Exactly where does this go. I looked up the docs for the "unofficial 
successor", and find it as a parameter to <rfc>. So I tried putting that 
in, but it made no difference.

	Confused,
	Paul

---

From: Julian Reschke <[email-masked]>
Date: Mon, 02 May 2011 22:35:57 +0200

> It didn't, and never needed it before.

Then you've been relying on the code being permissive.

> in, but it made no difference.

I don't know; I didn't change anything. Just trying to help.

Note that docName is defined in RFC2629 and is what needs to be used 
when creating an Internet Draft.

I don't know what's going, but I might if you should me the source document.

Best regards, Julian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 03 May 2011 10:35:11 +1200

Paul,

Just to give you the pragmatic answer, you need something like

<rfc ipr="trust200902" docName="draft-kyzivat-mybrilliantidea-00" category="info">

I place it immediately before <front> so that it's easy to find. You have to edit
the version number each time.

Regards
   Brian Carpenter

On 2011-05-02 09:58, Paul Kyzivat wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Glen Zorn <[email-masked]>
Date: Tue, 03 May 2011 16:45:56 +0700

> in, but it made no difference.

Example:

<?rfc tocindent="yes"?>
<rfc category="std" obsoletes="4005"
docName="draft-ietf-dime-rfc4005bis-04" ipr="trust200902">
	<front>
		<title abbrev="Diameter NASREQ">Diameter Network Access Server
Application</title>