Subject: [xml2rfc] artwork type "abnf" doesn't seem to work

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 2 May 2011 10:43:03 -0700

I have this in a source file:

<figure>
<artwork type='abnf'>
[some stuff here]
</artwork>
</figure>

xml2rfc-1.36 complains like so:

xml2rfc: warning: content is not valid type="abnf" near "[some stuff here]" at line-offset 0 within <artwork> around input line 1528

Section 6.3 of http://xml.resource.org/authoring/README.html seems to suggest this should be legal.

What's up here?

-MSK

---

From: Julian Reschke <[email-masked]>
Date: Mon, 02 May 2011 20:27:13 +0200

On 02.05.2011 19:43, Murray S. Kucherawy wrote:
> xml2rfc: warning: content is not valid type="abnf" near "[some stuff
> here]" at line-offset 0 within <artwork> around input line 1528
>
> What’s up here?

type="abnf" is of course ok.

What xml2rfc is complaining about is the actual ABNF.

Example, please...

Best regards, Julian