Subject: [xml2rfc] Character entities

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Sat, 20 Aug 2011 14:00:35 -0400

Hi all,
I insert this to my XML document:

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
  <!ENTITY command "Test">
]>

Then, I do this:

<rfc ipr="pre5378Trust200902" category="exp" docName="draft-ordogh-test">
    <front>
...
        <abstract>
            <t>The &command; yadayada</t>
...

There is no error when I convert it to text so I guessed that it must have
worked, but the result in fact is as follows:

Abstract

   The &command; yadayada

The XML editor does offer &command; when I press the ampersand key, so the
declaration is probably correct.
But, it seems that it gets lost somewhere along the way.

Please advise.
Thank you.

Best regards: Zoltán Ördögh

---

From: Julian Reschke <[email-masked]>
Date: Sun, 21 Aug 2011 16:14:19 +0200

On 2011-08-20 20:00, Zoltán Ördögh (GMail) wrote:
> There is no error when I convert it to text so I guessed that it must
> have worked, but the result in fact is as follows:
>
> Abstract
>
>     The &command; yadayada
>
> The XML editor does offer &command; when I press the ampersand key, so
> the declaration is probably correct.

Works for me.

What version of xml2rfc are you using?

Best regards, Julian

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Mon, 22 Aug 2011 10:46:11 -0400

Hi Julian,
I am using xml2rfc v1.36pre1.
Windows XP Pro SP3, ActiveState ActiveTcl 8.5.9.2.294317
Thank you.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 22 Aug 2011 17:10:56 +0200

> Windows XP Pro SP3, ActiveState ActiveTcl 8.5.9.2.294317

The latest version is 1.36, but I doubt it makes a difference.

Can you reproduce the problem with the online version at xml.resource.org?

Best regards, Julian

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Mon, 22 Aug 2011 11:30:18 -0400

Hi Julian,
I am mailing you a copy of the paper, just a moment.

---

From: Julian Reschke <[email-masked]>
Date: Wed, 24 Aug 2011 11:11:20 +0200

> Can you reproduce the problem with the online version at xml.resource.org?

...conclusion: this works in text content, but not in attribute values. 
Workaround: preprocess with a proper XML tool.

Best regards, Julian