Subject: [xml2rfc] Intra-document xrefs

From: "John Levine" <[email-masked]>
Date: 20 Nov 2011 01:33:41 -0000

Say you have something like this:

  explained in more detail in <xref target="foostuff" />.
    ...
  <section anchor="foostuff" title="On the Nature of Foo">

The new xml2rfc expands the xref to [foostuff] while the
old xml2rfc expanded it to Section 4.2 or Appendix Z or
whatever.

I expect this is just something that's not fully implemented
yet, but I wanted to note it as something to fix.  Internal
crossrefs are fairly common in RFCs and it would be nice for
them to work.

R's,
John

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 20 Nov 2011 12:04:32 -0800

> crossrefs are fairly common in RFCs and it would be nice for

Yes, please. I'm working on a document with lots of internal crossrefs, and this output would definitely make the document unreadable.

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 28 Nov 2011 18:42:29 +0100

Hi John,

> old xml2rfc expanded it to Section 4.2 or Appendix Z or

Are you using a local copy of the new xml2rfc, or the web service?

If local, which version do you have?

Best regards,

	Henrik

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: "John R. Levine" <[email-masked]>
Date: 28 Nov 2011 12:58:10 -0500

> If local, which version do you have?

Local copy, from a tarball I downloaded on 15 Nov.  Most of the files in 
the tarball are dated Aug 24 and 25.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. http://jl.ly

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 29 Nov 2011 14:40:26 +0100

Hi John,

> the tarball are dated Aug 24 and 25.

Ok, I'll take a look at this as soon as I can.  Thanks.

Best regards,

	Henrik