Subject: Re: [xml2rfc] Various nits

From: Frank Ellermann <[email-masked]>
Date: Mon, 14 Nov 2011 05:45:19 +0100

On 23 October 2011 15:53, Henrik Levkowetz wrote:

Update on the <workgroup>&nbsp;</workgroup> hack:

>>>> To suppress the non-applicable WG I tried &nbsp;
>>>> as WG.

>>> That still leaves "Network Working Group" at the
>>> top.

>> Oops, no, &nbsp; worked for me.

> Ah!  Ok, I should try that again, then.

It turns out that xml2rfc supports &nbsp; as "WG",
but then the I-D submit tool does not more find
the author.  I've replaced &nbsp; by . (dot), that
worked.  No cancel problem this time, as promised ;-)

Oddly my old failed "fix stuck I-D N by new N+1"
attempt still existed "somewhere" (apparently the
name of this limbo is "staging area").  This time
the "send cancel URL" was no problem.

-Frank

---

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Nov 2011 10:24:57 +0100

On 2011-11-14 05:45, Frank Ellermann wrote:
> Update on the<workgroup>&nbsp;</workgroup>  hack:
>
>>>>> To suppress the non-applicable WG I tried&nbsp;
>>>>> as WG.
>
>>> Oops, no,&nbsp; worked for me.
>
> It turns out that xml2rfc supports&nbsp; as "WG",
> the author.  I've replaced&nbsp; by . (dot), that

Frank,

I'm struggling to understand the use case you're after. Could you 
rephrase all of this into a concrete feature request?

Best regards, Julian

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 14 Nov 2011 14:42:15 +0100

On 14 November 2011 10:24, Julian Reschke wrote:

> I'm struggling to understand the use case you're after.

Yes, I'm also struggling to understand what *exactly* I'm
after.  The I-D was (in 2008) a proposal to create an IETF
RFC.  It would require some major work to do this, and it
would involve things I don't really know (schema or relax
or whatever is state of the art, certainly not my limited
"can read DTD" knowledge).

There were no takers.  Inspired by happIANA discussions I
thought that an ordinary "please register this well-known
MIME type" draft could do the trick, after all that's in
theory possible.

For that the I-D has to be "not for RFC", "not IETF", "no
WG", and "independent submission" in no particular order.

The "not for RFC" boilerplate was a very bad idea, I've
fixed that.  The "no WG" hack &nbsp; went well as far as
xml2rfc is concerned, but it spooked the datatacker submit
tool:  The author wasn't found if the upper left corner of
the first page is empty.

A single dot suffices for the "find author" code in the
submit tool.  Nothing to do for xml2rfc.

-Frank

---

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Nov 2011 15:34:25 +0100

> WG", and "independent submission" in no particular order.

I still struggle to understand.

It seems you want a submit a type of Internet Draft that xml2rfc does 
not support.

What *exactly* distinguishes it from the ID types xml2rfc *does* support?

It is just the upper left table cell in the boilerplate? It it something 
for "Status of this Memo" or "Copyright"?

 > ...

Best regards, Julian

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 14 Nov 2011 16:18:30 +0100

On 14 November 2011 15:34, Julian Reschke wrote:

Hi Julian,

> It seems you want a submit a type of Internet Draft that
> xml2rfc does not support.

> What *exactly* distinguishes it from the ID types xml2rfc

xml2rfc supported both &nbsp; and . as WG name placeholder
for "no WG".  The default "Network WG" won't do for some
"non-IETF not for RFC" draft, the &nbsp; output confuses
the submit tool, the dot is odd, but otherwise okay.

xml2rfc also supports various kinds of IPR choices for the
"not for RFC" idea, among others "none" and a convoluted
"trust2009noderivative".  But the "none" output cannot be
submitted, it is obsolete, and the "trust2009derivative"
didn't match my idea of "not for RFC".  Therefore I'm now
using the ordinary "trust2009full", and add a normal note
that *this* I-D is not intended to be published as a RFC
(= derivative work is no problem).

I posted here that &nbsp; "works for me".  And that wasn't
the complete story, I had not tested to submit the output.
Now it's clear that it does not really work for the submit
tool (unless I'd click on "edit meta + manual processing").
Sorry for the confusion -- above all nothing is wrong with
the xml2rfc release version (modulo missing rfcprocack).

-Frank

---

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Nov 2011 16:36:20 +0100

On 2011-11-14 16:18, Frank Ellermann wrote:
> xml2rfc supported both&nbsp; and . as WG name placeholder
> "non-IETF not for RFC" draft, the&nbsp; output confuses

What's the definition of "non-IETF not for RFC" draft??? Speaking of
which, what's a "non-IETF Internet Draft"?

If there's such a thing, then yes, xml2rfc should support that. Right 
now I just don't understand what it is...

Best regards, Julian

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 14 Nov 2011 07:44:31 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Julian Reschke
> Sent: Monday, November 14, 2011 7:36 AM
> To: Frank Ellermann
> Cc: IETF xml2rfc
> Subject: Re: [xml2rfc] Various nits
> 
> > xml2rfc supported both&nbsp; and . as WG name placeholder for "no WG".
> > The default "Network WG" won't do for some "non-IETF not for RFC"
> > draft, the&nbsp; output confuses the submit tool, the dot is odd, but
> > otherwise okay.
> 

I've been using this for such purposes:

<?rfc private="private-org-name" ?>

Seems to work pretty well with 1.36.

-MSK