Subject: [xml2rfc] including a file

From: Randy Bush <[email-masked]>
Date: Mon, 17 Sep 2012 22:36:41 +0900

<?rfc include="RPKI-ROUTER-MIB.mib"?>

seems not to work, either with the above relative/local path or a fully
explicit one.  clue bat please.

randy

---

From: Glen Zorn <[email-masked]>
Date: Mon, 17 Sep 2012 21:01:05 +0700

> explicit one.  clue bat please.

The way I got this to work was to rename the included file w/a .xml 
extension.
Example:

Main draft:

         <section title="Diameter Base Protocol MIB Definitions">
             <t>
<?rfc include="base-mib-artwork-05.xml"?>
             </t>
         </section>

base-mib-artwork-05.xml:

<figure align="left" suppress-title="true"><artwork align="left"><![CDATA[
DIAMETER-BASE-PROTOCOL-MIB DEFINITIONS ::= BEGIN

<!-- ... -->

END
]]></artwork></figure>

It didn't work for me unless the included file was real XML: just 
renaming it failed silently.

>
> randy
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Randy Bush <[email-masked]>
Date: Mon, 17 Sep 2012 23:41:00 +0900

> The way I got this to work was to rename the included file w/a .xml 

that is simply disgusting.  it works, but is disgusting.  next, the name
to the left of the ".xml" will be restricted to eight characters.

but thanks.

randy