Subject: [xml2rfc] New xml2rfc release: 2.3.11

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 17:46:30 +0100

This announces the release of xml2rfc version 2.3.11, available for download
from:

   http://pypi.python.org/pypi/xml2rfc
   http://tools.ietf.org/tools/xml2rfc2/cli/

This release fixes all outstanding major bugs, details below.
The issue tracker is at http://tools.ietf.org/tools/xml2rfc/trac/.

 * Updated the nroff writer to do backslash escaping on source text, to 
   avoid escaping nroff control characters.  Fixes issue #77.

 * Added a modified xref writer to the nroff output writer, in order to 
   handle xref targets which should not be broken across lines.  This, 
   together with changeset [688], fixes issue #80.

 * Added text to the section test case to trigger the second part of issue 
   #79.  It turns out that the changes in [688] fixed this, too; this closes 
   issue #79.

 * Tweaked the nroff generation to not break on hyphens, in order to avoid 
   hyphenated words ending up with embedded spaces: 'pre-processing' becoming 
   'pre- processing' if 'pre-' occurred at the end of an nroff text line.  
   Also tweaked the line-width used in line-breaking to have matching 
   line-breaks between .txt and .nroff output (with exception for lines ending 
   in hyphens).

 * Tweaked roman number list counter to output roman numbers in a field 5 
   spaces wide, instead of having varied widths.  This is different from 
   version 1, so may have to be reverted, depending on how people react.

 * Added a warning for too long lines in figures and tables.  No 
   outdenting for now; I'd like to consult some about that. Fixes issue #76.

 * Updated tests showing that all list format specifiers mentioned in 
   issue #70 now works.  Closes isssue #70.

 * Changed spanx emphasis back to _this_ instead of -this-, matching the v1 
   behaviour.  Addresses issue #70.

 * Make <vspace/> in a hangindent list reset the indentation to the 
   hang-indent, even if the bullet text is longer than the hang-indent.  
   Addresses issue #70.

 * Refined the page-breaking to not insert an extra page break for artwork
   that won't fit on a page anyway.

 * Refined the page-breaking to avoid breaking artwork and tables across 
   pages, if possible.

 * Fixed a problem with centering of titles and labels.  Fixes issue #73.

 * Changed the leading and trailing whitespace lines of a page to better 
   match legacy output.  Fixed the autobreaking algorithm to correctly avoid 
   orphans and widows; fixes issue #72.  Removed an extra blank line at the 
   top of the page following an early page break to avoid orphan or widow.

 * Tweaked the generation of ToC dot-lines and page numbers to better 
   match legacy xml2rfc.  Fixed a bug in the generation of xref text where 
   trailing whitespace could cause double spaces.  Tweaked the output format 
   to produce the correct number of leading blank lines on the first page of a 
   document.

 * Modified the handling of figure titles, so that given titles will be 
   written also without anchor or figure counting.  Fixes issue #75.

 * Tweaked the html writer to have a buffer interface that provides a 
   self.buf similar to the other writers, for test purposes.

 * Reworked the WriterElementTest suite to test all the output formats, 
   not only paginated text.

 * Added a note about /usr/local/bin permissions.  This closes issue #65.

 * Added files describing possible install methods (INSTALL), and possible 
   build commands (Makefile).

 * The syntax that was used to specify the version of the lxml dependency 
   ('>=') is not supported in python distutil setup.py files, and caused setup 
   to try to find an lxml version greater than =2.2.8, which couldn't succeed. 
   Fixed to say '>2.2.7' instead.  This was probably the cause of always 
   reinstalling lxml even when it was present.

 * Updated README.rst to cover the new --date option, and tweaked it a bit.

 * Added some files to provide an enhanced source distribution package.

 * Updated setup.py with maintainer and licence information.

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 08:32:07 -1000

on mountain where xml2rfc-2.3.10 built just fine

randy

ryuu.psg.com:/usr/local/src/misc/xml2rfc-2.3.11.2# python setup.py install
running install
running bdist_egg
running egg_info
writing requirements to xml2rfc.egg-info/requires.txt
writing xml2rfc.egg-info/PKG-INFO
writing top-level names to xml2rfc.egg-info/top_level.txt
writing dependency_links to xml2rfc.egg-info/dependency_links.txt
reading manifest file 'xml2rfc.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no files found matching 'README.*'
writing manifest file 'xml2rfc.egg-info/SOURCES.txt'
installing library code to build/bdist.macosx-10.8-intel/egg
running install_lib
running build_py
creating build
creating build/lib
creating build/lib/xml2rfc
copying xml2rfc/__init__.py -> build/lib/xml2rfc
copying xml2rfc/log.py -> build/lib/xml2rfc
copying xml2rfc/parser.py -> build/lib/xml2rfc
copying xml2rfc/utils.py -> build/lib/xml2rfc
creating build/lib/xml2rfc/writers
copying xml2rfc/writers/__init__.py -> build/lib/xml2rfc/writers
copying xml2rfc/writers/base.py -> build/lib/xml2rfc/writers
copying xml2rfc/writers/expanded_xml.py -> build/lib/xml2rfc/writers
copying xml2rfc/writers/html.py -> build/lib/xml2rfc/writers
copying xml2rfc/writers/nroff.py -> build/lib/xml2rfc/writers
copying xml2rfc/writers/paginated_txt.py -> build/lib/xml2rfc/writers
copying xml2rfc/writers/raw_txt.py -> build/lib/xml2rfc/writers
creating build/lib/xml2rfc/templates
copying xml2rfc/templates/address_card.html -> build/lib/xml2rfc/templates
copying xml2rfc/templates/base.html -> build/lib/xml2rfc/templates
copying xml2rfc/templates/rfc2629-other.ent -> build/lib/xml2rfc/templates
copying xml2rfc/templates/rfc2629-xhtml.ent -> build/lib/xml2rfc/templates
copying xml2rfc/templates/rfc2629.dtd -> build/lib/xml2rfc/templates
creating build/bdist.macosx-10.8-intel
creating build/bdist.macosx-10.8-intel/egg
creating build/bdist.macosx-10.8-intel/egg/xml2rfc
copying build/lib/xml2rfc/__init__.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc
copying build/lib/xml2rfc/log.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc
copying build/lib/xml2rfc/parser.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc
creating build/bdist.macosx-10.8-intel/egg/xml2rfc/templates
copying build/lib/xml2rfc/templates/address_card.html -> build/bdist.macosx-10.8-intel/egg/xml2rfc/templates
copying build/lib/xml2rfc/templates/base.html -> build/bdist.macosx-10.8-intel/egg/xml2rfc/templates
copying build/lib/xml2rfc/templates/rfc2629-other.ent -> build/bdist.macosx-10.8-intel/egg/xml2rfc/templates
copying build/lib/xml2rfc/templates/rfc2629-xhtml.ent -> build/bdist.macosx-10.8-intel/egg/xml2rfc/templates
copying build/lib/xml2rfc/templates/rfc2629.dtd -> build/bdist.macosx-10.8-intel/egg/xml2rfc/templates
copying build/lib/xml2rfc/utils.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc
creating build/bdist.macosx-10.8-intel/egg/xml2rfc/writers
copying build/lib/xml2rfc/writers/__init__.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc/writers
copying build/lib/xml2rfc/writers/base.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc/writers
copying build/lib/xml2rfc/writers/expanded_xml.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc/writers
copying build/lib/xml2rfc/writers/html.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc/writers
copying build/lib/xml2rfc/writers/nroff.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc/writers
copying build/lib/xml2rfc/writers/paginated_txt.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc/writers
copying build/lib/xml2rfc/writers/raw_txt.py -> build/bdist.macosx-10.8-intel/egg/xml2rfc/writers
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/__init__.py to __init__.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/log.py to log.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/parser.py to parser.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/utils.py to utils.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/writers/__init__.py to __init__.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/writers/base.py to base.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/writers/expanded_xml.py to expanded_xml.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/writers/html.py to html.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/writers/nroff.py to nroff.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/writers/paginated_txt.py to paginated_txt.pyc
byte-compiling build/bdist.macosx-10.8-intel/egg/xml2rfc/writers/raw_txt.py to raw_txt.pyc
creating build/bdist.macosx-10.8-intel/egg/EGG-INFO
installing scripts to build/bdist.macosx-10.8-intel/egg/EGG-INFO/scripts
running install_scripts
running build_scripts
creating build/scripts-2.7
copying and adjusting scripts/xml2rfc -> build/scripts-2.7
changing mode of build/scripts-2.7/xml2rfc from 644 to 755
creating build/bdist.macosx-10.8-intel/egg/EGG-INFO/scripts
copying build/scripts-2.7/xml2rfc -> build/bdist.macosx-10.8-intel/egg/EGG-INFO/scripts
changing mode of build/bdist.macosx-10.8-intel/egg/EGG-INFO/scripts/xml2rfc to 755
copying xml2rfc.egg-info/PKG-INFO -> build/bdist.macosx-10.8-intel/egg/EGG-INFO
copying xml2rfc.egg-info/SOURCES.txt -> build/bdist.macosx-10.8-intel/egg/EGG-INFO
copying xml2rfc.egg-info/dependency_links.txt -> build/bdist.macosx-10.8-intel/egg/EGG-INFO
copying xml2rfc.egg-info/requires.txt -> build/bdist.macosx-10.8-intel/egg/EGG-INFO
copying xml2rfc.egg-info/top_level.txt -> build/bdist.macosx-10.8-intel/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
xml2rfc.parser: module references __file__
xml2rfc.writers.html: module references __file__
creating dist
creating 'dist/xml2rfc-2.3.11.2-py2.7.egg' and adding 'build/bdist.macosx-10.8-intel/egg' to it
removing 'build/bdist.macosx-10.8-intel/egg' (and everything under it)
Processing xml2rfc-2.3.11.2-py2.7.egg
creating /Library/Python/2.7/site-packages/xml2rfc-2.3.11.2-py2.7.egg
Extracting xml2rfc-2.3.11.2-py2.7.egg to /Library/Python/2.7/site-packages
Removing xml2rfc 2.3.10 from easy-install.pth file
Adding xml2rfc 2.3.11.2 to easy-install.pth file
Installing xml2rfc script to /usr/local/bin

Installed /Library/Python/2.7/site-packages/xml2rfc-2.3.11.2-py2.7.egg
Processing dependencies for xml2rfc==2.3.11.2
Searching for lxml>=2.2.8,<3.0
Reading http://pypi.python.org/simple/lxml/
Reading http://codespeak.net/lxml
Reading http://lxml.de/
Best match: lxml 3.0bugfix
Downloading https://github.com/lxml/lxml/tarball/lxml-3.0#egg=lxml-3.0bugfix
Processing lxml-3.0
Running lxml-lxml-bcfbb82/setup.py -q bdist_egg --dist-dir /tmp/easy_install-Jh0OtE/lxml-lxml-bcfbb82/egg-dist-tmp-xrrpAc
Building lxml version 3.0.
Traceback (most recent call last):
  File "setup.py", line 84, in <module>
    install_requires = ['lxml >= 2.2.8, < 3.0 '],
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/install.py", line 76, in run
    self.do_egg_install()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/install.py", line 104, in do_egg_install
    cmd.run()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 211, in run
    self.easy_install(spec, not self.no_deps)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 427, in easy_install
    return self.install_item(None, spec, tmpdir, deps, True)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 478, in install_item
    self.process_distribution(spec, dist, deps)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 519, in process_distribution
    [requirement], self.local_index, self.easy_install
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 563, in resolve
    dist = best[req.key] = env.best_match(req, self, installer)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 799, in best_match
    return self.obtain(req, installer) # try and download/install
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 811, in obtain
    return installer(requirement)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 446, in easy_install
    return self.install_item(spec, dist.location, tmpdir, deps)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 476, in install_item
    dists = self.install_eggs(spec, download, tmpdir)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 655, in install_eggs
    return self.build_and_install(setup_script, setup_base)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 930, in build_and_install
    self.run_setup(setup_script, setup_base, args)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 919, in run_setup
    run_setup(setup_script, args)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/sandbox.py", line 62, in run_setup
    lambda: execfile(
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/sandbox.py", line 105, in run
    return func()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/sandbox.py", line 64, in <lambda>
    {'__file__':setup_script, '__name__':'__main__'}
  File "setup.py", line 226, in <module>
    
  File "setup.py", line 139, in setup_extra_options
    
  File "/tmp/easy_install-Jh0OtE/lxml-lxml-bcfbb82/setupinfo.py", line 79, in ext_modules
RuntimeError: ERROR: Trying to build without Cython, but pre-generated 'src/lxml/lxml.etree.c' is not available (pass --without-cython to ignore this error).

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 19:42:49 +0100

Hi Randy,

> on mountain where xml2rfc-2.3.10 built just fine

... <<snip>>

> RuntimeError: ERROR: Trying to build without Cython, but pre-generated 'src/lxml/lxml.etree.c' is not available (pass --without-cython to ignore this error).

This seems to be a problem with building lxml >= 3.0.  I've uploaded a new
version, 2.3.11.2 which requires lxml >= 2.3.8, < 3.0, which hopefully should
work better -- it installs as it should at least on my debian and os-x boxes.

Best regards,

	Henrik

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 08:51:06 -1000

hi kenrik,

> work better -- it installs as it should at least on my debian and os-x boxes.

that error was on 2.3.11.2, xml2rfc-2.3.11.2.tar.gz

randy

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 19:53:18 +0100

Hi Randy,

> that error was on 2.3.11.2, xml2rfc-2.3.11.2.tar.gz

Ok; did you use pip install or python setup.py install?

Best regards,

	Henrik

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 08:55:22 -1000

> Ok; did you use pip install or python setup.py install?

the latter

randy

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:00:41 +0100

>> Ok; did you use pip install or python setup.py install?

Ok, which version of python, distutils and setuptools do you have?

 $ python --version
 $ python -c 'import distutils, print distutils.__version__'
 $ python -c 'import setuptools, print setuptools.__version__'

	Henrik

---

From: Miek Gieben <[email-masked]>
Date: Sun, 20 Jan 2013 20:05:41 +0100

[ Quoting <[email-masked]> in "Re: [xml2rfc] New xml2rfc release: ..." ]
> on mountain where xml2rfc-2.3.10 built just fine

it's working fine on Ubuntu (12.10). In fact I created a .deb for Ubuntu,
for those inclined:
http://miek.nl/downloads/2013/python-xml2rfc_2.3.11-0ubuntu1_all.deb

Kind regards,
Miek Gieben

---

From: Miek Gieben <[email-masked]>
Date: Sun, 20 Jan 2013 20:05:41 +0100

Kind regards,
Miek Gieben

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 09:06:31 -1000

henrik,

>  $ python -c 'import setuptools, print setuptools.__version__'

ryuu.psg.com:/Users/randy> python --version
Python 2.7.2
ryuu.psg.com:/Users/randy> python -c 'import distutils, print distutils.__version__'
  File "<string>", line 1
    import distutils, print distutils.__version__
                          ^
SyntaxError: invalid syntax
ryuu.psg.com:/Users/randy>  python -c 'import setuptools, print setuptools.__version__'
  File "<string>", line 1
    import setuptools, print setuptools.__version__
                           ^
SyntaxError: invalid syntax
ryuu.psg.com:/Users/randy> python -c 'import distutils; print distutils.__version__'
2.7.2
ryuu.psg.com:/Users/randy>  python -c 'import setuptools; print setuptools.__version__'
0.6c12

randy

---

From: Miek Gieben <[email-masked]>
Date: Sun, 20 Jan 2013 20:08:07 +0100

> >  $ python -c 'import setuptools, print setuptools.__version__'

Try it with a semi-colon:

 python -c 'import distutils; print distutils.__version__'

Seems to work for me.

grtz Miek

---

From: Miek Gieben <[email-masked]>
Date: Sun, 20 Jan 2013 20:08:07 +0100

Seems to work for me.

grtz Miek

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 09:15:46 -1000

> Try it with a semi-colon:

look a bit more carefully.  i did.  i just could not resist teasing
henrik for his not testing :)

randy

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 09:15:46 -1000

randy

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 20 Jan 2013 11:17:13 -0800

> http://miek.nl/downloads/2013/python-xml2rfc_2.3.11-0ubuntu1_all.deb

That's great, but the xml2rfc executable clashes with the xml2rfc 1.36-5
package that is already in Debian.  Using a diversion would fix that.

A Debian package for pandoc2rfc would be great too.

Also, what about publishing them in a repository, so the package is
automatically updated?  I can help with this.

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 20 Jan 2013 11:17:13 -0800

- -- 
Marc Petit-Huguenin

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:16:51 +0100

I'm sorry, my mistake, please instead do

 $ python -c 'import distutils; print distutils.__version__'
 $ python -c 'import setuptools; print setuptools.__version__'

[[ By the way, my results here are:

20:14 /tmp
henrik@vigonier $ python -c 'import distutils; print distutils.__version__'
2.7.3

20:14 /tmp
henrik@vigonier $ python -c 'import setuptools; print setuptools.__version__'
0.6c12

If you find versions substantially below these (not likely with distutils, but
could be the case with setuptools) it would be good to get a newer versions.

I had problems with the parsing of the dependency list in setup.py on os-x
before I fetched a newer version of pip... ]]

Best regards,

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 20 Jan 2013 08:58:59 -0800

>   http://tools.ietf.org/tools/xml2rfc2/cli/

For those of us who installed 2.3.10 yesterday :-), are there instructions for easy updating?

--Paul Hoffman

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 20 Jan 2013 08:58:59 -0800

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 19:39:17 +0100

Hi Paul,

> For those of us who installed 2.3.10 yesterday :-), are there instructions for easy updating?

On the command-line, with or without 'sudo' depending on your setup, do

  pip install xml2rfc --upgrade

or alternatively, download the package, cd into the unpacked top directory, and do

  python setup.py install

and you should be good.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 19:39:17 +0100

Hi Paul,

  python setup.py install

and you should be good.

Best regards,

	Henrik

---

From: Miek Gieben <[email-masked]>
Date: Sun, 20 Jan 2013 20:20:47 +0100

[ Quoting <[email-masked]> in "Re: [xml2rfc] New xml2rfc release: ..." ]
> package that is already in Debian.  Using a diversion would fix that.

Ah... I never actually made the time to understand how Debian's diversion
scheme would work.

> automatically updated?  I can help with this.

Good idea and yes, your help is welcome. I'm a bit curious though
as what should actually be packaged for pandoc2rfc? In essence
it is just 1 file: transform.xsl ?

 Regards,

-- 
    Miek Gieben                                               http://miek.nl

---

From: Miek Gieben <[email-masked]>
Date: Sun, 20 Jan 2013 20:20:47 +0100

Regards,

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:21:52 +0100

> henrik for his not testing :)

:-P

	Henrik 	,:-))

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:21:52 +0100

:-P

	Henrik 	,:-))

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 20 Jan 2013 11:23:39 -0800

> or alternatively, download the package, cd into the unpacked top directory, and do

But, as Randy points out, am not.

# python --version
Python 2.7.2
# python -c 'import distutils; print distutils.__version__'
2.7.2
# python -c 'import setuptools; print setuptools.__version__'
0.6c12

--Paul Hoffman

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 20 Jan 2013 11:23:39 -0800

# python --version
Python 2.7.2

--Paul Hoffman

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 09:25:19 -1000

> I'm sorry, my mistake, please instead do

though not known for subtlety, evidently i was too subtle

>> ryuu.psg.com:/Users/randy>  python -c 'import setuptools; print setuptools.__version__'

so how do i upgrade distutils on mtn lion?  i believe that have the cli
tools for the latest xcode.

randy

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:31:45 +0100

Hi Randy,

>> > ryuu.psg.com:/Users/randy>  python -c 'import setuptools; print setuptools.__version__'

Hmm.  In this case, I really don't know what to suggest next, except trying
with pip, which might produce better results.  pip also has has an option
'--no-dependencies' which I don't have an equivalent option for using
'python setup.py'; that would let you install 2.2.8 <= lxml < 3.0 separately,
and then install xml2rfc without its dependencies.

[ Grmph.  Package install tool troubles.  Grmph.  debian/rules! ]

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:31:45 +0100

Hi Randy,

Best regards,

	Henrik

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 20 Jan 2013 11:37:22 -0800

On 01/20/2013 11:20 AM, Miek Gieben wrote:
>>> it's working fine on Ubuntu (12.10). In fact I created a .deb for
>>> Ubuntu, for those inclined: 

Unfortunately, I did :-)

Send me directly a tarball of your debian/*, and I'll update it for you.

> Good idea and yes, your help is welcome.

OK, I already have a repository at debian.implementers.org for my own public
package, but perhaps a different name is better.  Choose a subdomain of
implementers.org, send me your ssh public key file and I'll setup everything.

> I'm a bit curious though as what should actually be packaged for
> pandoc2rfc? In essence it is just 1 file: transform.xsl ?

I was thinking about adding a wrapper so one can directly run "pandoc2rfc
file.mkd".  The Debian package would ensure that the correct versions of
xml2rfc and xsltproc are installed.

- -- 
Marc Petit-Huguenin

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 20 Jan 2013 11:37:22 -0800

Unfortunately, I did :-)

- -- 
Marc Petit-Huguenin

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 09:38:32 -1000

> with pip, which might produce better results.

and then again, it might not :)

ryuu.psg.com:/usr/local/src/misc/xml2rfc-2.3.11.2# pip install xml2rfc
Traceback (most recent call last):
  File "/usr/local/bin/pip", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2603, in <module>
    working_set.require(__requires__)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 666, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 565, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: pip==1.1

> pip also has has an option '--no-dependencies' Which I don't have an
> equivalent option for using 'python setup.py'; that would let you
> install 2.2.8 <= lxml < 3.0 separately, and then install xml2rfc
> without its dependencies.

ryuu.psg.com:/usr/local/src/misc/xml2rfc-2.3.11.2# pip install libxml
Traceback (most recent call last):
  File "/usr/local/bin/pip", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2603, in <module>
    working_set.require(__requires__)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 666, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 565, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: pip==1.1

> [ Grmph.  Package install tool troubles.  Grmph.  debian/rules! ]

debian breaks my 30 years of unix fingers.  and ls in color?  puhleeze!

randy

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 09:38:32 -1000

randy

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:41:20 +0100

Hi Randy,

> though not known for subtlety, evidently i was too subtle

Oh, I got it, eventually ,;-)

> tools for the latest xcode.

Your versions look good; see my suggestion in my previous mail about using
pip.

This is of course not a great answer; I'd like to find out how to do things
better.

Fwiw, I've uploaded 2.3.11.3 which requires lxml < 2.9; but if the version
parsing is broken, I'm not sure that will help.

Best regards,

	Henrik

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 Jan 2013 09:46:48 -1000

> parsing is broken, I'm not sure that will help.

mehr besser!  and the resulting xml2rfc ran on my i-d.xml!!!

owe you an espresso, berlin i guess

randy

ryuu.psg.com:/usr/local/src/misc# mv ~randy/Desktop/xml2rfc-2.3.11.3.tar.gz ../distfiles/
ryuu.psg.com:/usr/local/src/misc# tar xf ../distfiles/xml2rfc-2.3.11.3.tar.gz
ryuu.psg.com:/usr/local/src/misc# cd xml2rfc-2.3.11.3/
ryuu.psg.com:/usr/local/src/misc/xml2rfc-2.3.11.3# python setup.py install
running install
running bdist_egg
running egg_info
creating 'dist/xml2rfc-2.3.11.3-py2.7.egg' and adding 'build/bdist.macosx-10.8-intel/egg' to it
Processing xml2rfc-2.3.11.3-py2.7.egg
creating /Library/Python/2.7/site-packages/xml2rfc-2.3.11.3-py2.7.egg
Extracting xml2rfc-2.3.11.3-py2.7.egg to /Library/Python/2.7/site-packages
Removing xml2rfc 2.3.11.2 from easy-install.pth file
Adding xml2rfc 2.3.11.3 to easy-install.pth file

Installed /Library/Python/2.7/site-packages/xml2rfc-2.3.11.3-py2.7.egg
Processing dependencies for xml2rfc==2.3.11.3
Searching for lxml>=2.2.8,<2.9
Reading http://pypi.python.org/simple/lxml/
Reading http://codespeak.net/lxml
Reading http://lxml.de/
Best match: lxml 2.3.6
Downloading http://pypi.python.org/packages/source/l/lxml/lxml-2.3.6.tar.gz
Processing lxml-2.3.6.tar.gz
Running lxml-2.3.6/setup.py -q bdist_egg --dist-dir /tmp/easy_install-Bu4SGP/lxml-2.3.6/egg-dist-tmp-Gf4MIO
Building lxml version 2.3.6.
Building without Cython.
Using build configuration of libxslt 1.1.26
Removing lxml 3.0.1 from easy-install.pth file
Adding lxml 2.3.6 to easy-install.pth file

Installed /Library/Python/2.7/site-packages/lxml-2.3.6-py2.7-macosx-10.8-intel.egg
Finished processing dependencies for xml2rfc==2.3.11.3

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 20 Jan 2013 11:48:01 -0800

> parsing is broken, I'm not sure that will help.

That fixed it for me.

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:49:31 +0100

Hi Randy,

> pkg_resources.DistributionNotFound: pip==1.1

If I understand this correctly (and I'm not certain I do), you have two versions
of pip installed, and the versions of the invocation script doesn't agree with
the installed package version.  I'd first do pip uninstall pip, then see if there's
still a pip script available, and remove that and any package (try this to get
the package path: $ python -c 'import pip; print pip.__path__')

Once you don't have any pip script or package, choose your favourite install
method and install pip using that.

(For me, I always prefer debian packages first, then fall back to pip installs,
but as you've noted, YMMV ,;-)

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:49:31 +0100

Hi Randy,

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:50:21 +0100

> mehr besser!  and the resulting xml2rfc ran on my i-d.xml!!!

Ok, cool! :-))

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 20 Jan 2013 20:51:12 +0100

>> parsing is broken, I'm not sure that will help.

Splendid! :-)

	Henrik

---

From: Elwyn Davies <[email-masked]>
Date: Sun, 20 Jan 2013 22:42:42 +0000

Hi.

I just tried out 2.3.11.3 installation (after my problems with 2.3.10 
yesterday - tickets 97/98).
Seems to have fixed some of the problems - pip installation now works 
(more or less).
I take it that lxml version 3.x is not kosher for xml2rfc since you 
exclude it now... lxml 3.1beta1 downloaded and compiled Ok yesterday but 
I now have 2.3.6 for use with xml2rfc 2.3.11.x

BTW
the machine here is running
Ubuntu 10.04 on an old ASUS EEE-PC 1000 (Atom processor)
Python 2.6
setuptools 0.8
distutils 2.6.5

Both
sudo python setup.py install
and
sudo pip install xml2rfc --upgrade

work more or less as expected.  There are 3 minor issues;
1. The internal version of the version in the 2.3.11.3 package still 
reports itself as 2.3.11.1 with xml2rfc --version
2. If you don't have libxml2 and libxslt dev packages installed on 
Ubuntu lxml won't compile.
3.  There are still some minor issues with the install... transcript of 
pip install beloe:
  sudo pip install xml2rfc --upgrade
Downloading/unpacking xml2rfc
   Running setup.py egg_info for package xml2rfc
     warning: no files found matching 'README.*'
Downloading/unpacking lxml>=2.2.8,<2.9 (from xml2rfc)
   Could not fetch URL http://codespeak.net/lxml (from 
http://pypi.python.org/simple/lxml/): HTTP Error 404: Not Found
   Will skip URL http://codespeak.net/lxml when looking for download 
links for lxml>=2.2.8,<2.9 (from xml2rfc)
   Could not fetch URL http://codespeak.net/lxml (from 
http://pypi.python.org/simple/lxml/): HTTP Error 404: Not Found
   Will skip URL http://codespeak.net/lxml when looking for download 
links for lxml>=2.2.8,<2.9 (from xml2rfc)
   Downloading lxml-2.3.6.tar.gz (3.2Mb): 3.2Mb downloaded
   Running setup.py egg_info for package lxml
     Building lxml version 2.3.6.
     Building without Cython.
     Using build configuration of libxslt 1.1.26
     Building against libxml2/libxslt in the following directory: /usr/lib
     warning: no previously-included files found matching '*.py'
Installing collected packages: lxml, xml2rfc
   Running setup.py install for xml2rfc
     changing mode of build/scripts-2.6/xml2rfc from 644 to 755
     warning: no files found matching 'README.*'
     changing mode of /usr/local/bin/xml2rfc to 755
   Running setup.py install for lxml
     Building lxml version 2.3.6.
     Building without Cython.
     Using build configuration of libxslt 1.1.26
     Building against libxml2/libxslt in the following directory: /usr/lib
     building 'lxml.etree' extension
     gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall 
-Wstrict-prototypes -fPIC -I/usr/include/libxml2 
-I/usr/include/python2.6 -c src/lxml/lxml.etree.c -o 
build/temp.linux-i686-2.6/src/lxml/lxml.etree.o -w
     gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions 
build/temp.linux-i686-2.6/src/lxml/lxml.etree.o -lxslt -lexslt -lxml2 
-lz -lm -o build/lib.linux-i686-2.6/lxml/etree.so
     building 'lxml.objectify' extension
     gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall 
-Wstrict-prototypes -fPIC -I/usr/include/libxml2 
-I/usr/include/python2.6 -c src/lxml/lxml.objectify.c -o 
build/temp.linux-i686-2.6/src/lxml/lxml.objectify.o -w
     gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions 
build/temp.linux-i686-2.6/src/lxml/lxml.objectify.o -lxslt -lexslt 
-lxml2 -lz -lm -o build/lib.linux-i686-2.6/lxml/objectify.so
Successfully installed xml2rfc

Seems to work basically, BUT found a few slight differences with this 
version.
- centre field in footer is one character leftwards of 1.35 version
- hangindent=15 produces slightly different answers -- more white space 
between label and rest of text
- Reporting a reference not found as an 'IDREF not found' when it isn't 
an I-D is confusing.

Will do a proper report shortly.

Found a problem with an slightly old and very complicated draft that 
doesn't work in either 1.35 or 2.3.11.3 (in similar ways). Probably 
something to do with
<!ENTITY % rfc2629 PUBLIC "" 
"http://xml.resource.org/public/rfc/bibxml/reference.RFC.2629.xml">
which used to work when
  http://tools.ietf.org/id/draft-irtf-routing-reqs-11.xml was published 
back in February 2009 but no longer
finds a number of the RFC references after the 3 described with PUBLIC 
(which seem to be found) and the rest are described with SYSTEM.

I am away from home and don't have access to an old xml2rfc to check 
that the old draft compiled on the old xml2rfc.

Regards,
Elwyn

On 20/01/13 19:51, Henrik Levkowetz wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 21 Jan 2013 12:56:37 +0100

Hi Elwyn,

> I now have 2.3.6 for use with xml2rfc 2.3.11.x

I excluded 3.x because I hadn't tested xml2rfc with it, and didn't want
to do a release which pronounced it to be OK even if there might be
problems with it.

Assuming testing works, I'll allow it in the next release (but it looks
like I might have to exclude the 3.1 beta if they don't have the dependency
list in order)

> reports itself as 2.3.11.1 with xml2rfc --version

Right, I was a bit hurried with the 2.3.11.x minor releases, so missed
updating the version in one place.

> Ubuntu lxml won't compile.

Hm.  That's probably a bug in lxml's build dependencies, then.  I don't
know if  I should put in a guard for that in xml2rfc (I really shouldn't,
but might still do so it temporarily as a workaround).

>      warning: no files found matching 'README.*'

Right.  Already fixed in my sourcetree.

... <<snip>>

> - centre field in footer is one character leftwards of 1.35 version

Yes.  I can't make it come out exactly as 1.35 because of different
handling of centering in odd vs. even field widths, unless I override
Python's string centering, which I think is silly.

> between label and rest of text

Ah.  I'll have a look at that.

> - Reporting a reference not found as an 'IDREF not found' when it isn't 

Could you send me sample source for that, please?

> Will do a proper report shortly.

Ah, ok; thanks!

> (which seem to be found) and the rest are described with SYSTEM.

Ok.

> that the old draft compiled on the old xml2rfc.

Ok.

Thanks for the report!

Best regards,

	Henrik

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 21 Jan 2013 09:43:13 -0500

Is a web version available for those of us who just use the one on 
http://xml.resource.org/

	Thanks,
	Paul