Subject: [xml2rfc] author's job title

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 16 Jan 2013 15:13:55 -0800

I'm working on an I-D with a co-author and for various reasons we'd
like to include the author's job title in the author address block. I
don't see a place for that information in the DTD for RFC 2629. Adding
it as a <street/> element seems like a hack, but it appears to be the
best I can do. Any suggestions?

Thanks!

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 17 Jan 2013 10:15:17 +0100

On 2013-01-17 00:13, Peter Saint-Andre wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> ...

Don't :-)

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Thu, 17 Jan 2013 10:39:43 -0500

Peter,
I am interested in the "various reasons".
Could you give me at least three?
Thank you!

Best regards: Zoltán Ördögh

On Thu, Jan 17, 2013 at 4:15 AM, Julian Reschke <[email-masked]>wrote:

> ______________________________**_________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/xml2rfc<https://www.ietf.org/mailman/listinfo/xml2rfc>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 17 Jan 2013 17:04:02 +0100

HEre's some I could think of:

"Implementer of Running Code"

"Emperor"

"Consensus Builder"

etc.

Alex

Le 17/01/2013 16:39, Zoltán Ördögh (GMail) a écrit :
> On Thu, Jan 17, 2013 at 4:15 AM, Julian Reschke <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     _________________________________________________
>     xml2rfc mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/xml2rfc
>     <https://www.ietf.org/mailman/listinfo/xml2rfc>
>
>
>
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Thu, 17 Jan 2013 11:55:10 -0500

Hi Alexandru,
these are examples (thank you), not reasons.

On Thu, Jan 17, 2013 at 11:04 AM, Alexandru Petrescu <
[email-masked]> wrote:

>> <mailto:[email-masked]>**> wrote:
>>
>>     ______________________________**___________________
>>     xml2rfc mailing list
>>     https://www.ietf.org/mailman/_**_listinfo/xml2rfc<https://www.ietf.org/mailman/__listinfo/xml2rfc>
>>     <https://www.ietf.org/mailman/**listinfo/xml2rfc<https://www.ietf.org/mailman/listinfo/xml2rfc>
>> >
>>
>>
>>
>>
>>

---

From: Dave Crocker <[email-masked]>
Date: Thu, 17 Jan 2013 08:55:54 -0800

I could be wrong, but I assume that Zoltán meant the question seriously. 
  In any event, I do.

We've gone 40+ years without job titles as part of RFC author 
information, and no evident problems caused by their absence.

In policy terms the change would be quite significant.  It therefore 
needs serious justification (and support), IMO.

d/

-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Zoltán Ördögh (GMail) <[email-masked]>
Date: Thu, 17 Jan 2013 12:00:58 -0500

Hi Dave,
that's exactly why I'd like to see reasons. Preferably, the good ones (i.e.
the top three).

On Thu, Jan 17, 2013 at 11:55 AM, Dave Crocker <[email-masked]> wrote:

> We've gone 40+ years without job titles as part of RFC author information,
> and no evident problems caused by their absence.
>
> In policy terms the change would be quite significant.  It therefore needs
> serious justification (and support), IMO.
>
> d/
>
>

---

From: Nico Williams <[email-masked]>
Date: Thu, 17 Jan 2013 11:12:10 -0600

Given that xml2rfc supports private memos, this might be a marginally
useful feature to add.  But private memos are not really a primary
feature of xml2rfc, so that's not a really good justification.

Note though that having this feature wouldn't mean that it gets used
in actual RFCs.  It might be useful to be able to have something like
roles or job titles in I-Ds, but not in RFCs.  At any rate, I don't
need this feature, and I do think it's good that we keep job titles
out of RFCs *and* I-Ds.

To summarize: yeah, don't.

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Jan 2013 09:26:28 -0800

On 1/17/13 9:12 AM, Nico Williams wrote:
> Given that xml2rfc supports private memos, this might be a
> marginally useful feature to add.  But private memos are not really
> a primary feature of xml2rfc, so that's not a really good
> justification.
> 
> Note though that having this feature wouldn't mean that it gets
> used in actual RFCs.  It might be useful to be able to have
> something like roles or job titles in I-Ds, but not in RFCs.  At
> any rate, I don't need this feature, and I do think it's good that
> we keep job titles out of RFCs *and* I-Ds.
> 

OK, I won't try to do this in xml2rfc.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 18 Jan 2013 10:22:44 +0100

Le 17/01/2013 18:26, Peter Saint-Andre a écrit :
> -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
>

As a side note, some commonly use somehow wrongly that space to expose
that they look for new opportunities (-01 has afilliation, -02 same
person no affiliation).  Why not using a job title field instead.

Other (dubious) uses of the affiliation fields: this company paid my
travel so their name is on my badge, this other company pays my other
contract so their name is in my draft.

Maybe a job title may help to clarify readers (of badge and of draft) to
understand the particular interests of that particular person.

I've seen real business cards of respectable people with job title
"Router Goddess" which illustrates a high level of experience to some
readers.

Why not in the drafts.

Yours,

Alex

>
> Peter
>
> - -- Peter Saint-Andre https://stpeter.im/
>
>
> -----BEGIN PGP SIGNATURE----- Version: GnuPG/MacGPG2 v2.0.18 (Darwin)
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
>
> iEYEARECAAYFAlD4NEQACgkQNL8k5A2w/vwiSwCg6nGkwiYELYWwJkpZ2mxfqIqa
> OsgAoLTAr4QIjBytp/JqtjUoJ/LN5JlF =JHOw -----END PGP SIGNATURE-----
> _______________________________________________ xml2rfc mailing list
>  [email-masked] https://www.ietf.org/mailman/listinfo/xml2rfc
>
>