Subject: Re: [xml2rfc] hangText does not seem to work

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Mon, 28 Jan 2013 15:30:02 +0000

Sorry, I did not have this correct - the example below works. It seems the problem is more when the text is empty so something like 

   <t hangText="destination_data "></t>

   <t>The destination value itself, which is an encoded
                DestinationData structure, depending on the value of
                "type".</t>

Looses the destination_data in the txt output 

On Jan 28, 2013, at 8:21 AM, Cullen Jennings <[email-masked]> wrote:

> 
> In version 2.3.11.1, hangText does not seem to work.
> 
> For example, the XML 
> 
> <t><list style="hanging">
>            <t hangText="Foo:"> Bar </t>
> </list></t>
> 
> Ends up rendering just Bar in txt file but what I wanted was 
> 
>     Foo: Bar 
> 
> Thanks, Cullen

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 28 Jan 2013 10:06:35 -0700

On 1/28/13 8:30 AM, Cullen Jennings (fluffy) wrote:
> 
> Sorry, I did not have this correct - the example below works. It
> seems the problem is more when the text is empty so something like
> 
> 
> DestinationData structure, depending on the value of "type".</t>
> 

Because hangText doesn't work that way. For the output you want, use this:

   <t hangText="destination_data ">The destination value itself, which
is an encoded
                DestinationData structure, depending on the value of
                "type".</t>

If you want line breaks in there, use <vspace blankLines='1'/>.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/