Subject: [xml2rfc] a few issues with the updated xml.resource.org

From: Denis Ovsienko <[email-masked]>
Date: Mon, 11 Mar 2013 12:54:32 +0400

Hello.

I use the xml2rfc tool, namely, its web frontend at xml.resource.org. The frontend was recently switched to the beta version of xml2rfc and this new switch brings a few issues that I cannot report without a Trac account. Please address them in the way you find appropriate.

1. <artwork align="center"> now produces a left-justified text (both preamble and figure and postamble).

2. <eref target="https://example.com"> elements produced a "URIs" paragraph with footnotes right after the "References" section in the old version. In the new version the "URIs" paragraph is missing, the footnote markers are still in place in the main text.

3. A non-RFC citation is now rendered with an extra comma after "Technology", which shouldn't be there:
This is the source XML:
---------------------
			<reference anchor="FIPS-198">
				<front>
					<title>The Keyed-Hash Message Authentication Code (HMAC)</title>
					<author initials="" surname="US National Institute of Standards &amp; Technology">
						<organization>Unknown</organization>
					</author>
					<date month="March" year="2002" />
				</front>
				<seriesInfo name="FIPS PUB 198" value="" />
			</reference>
---------------------
The old version produces this:
---------------------
   [FIPS-198]
              US National Institute of Standards & Technology, "The
              Keyed-Hash Message Authentication Code (HMAC)", FIPS PUB
              198 , March 2002.
---------------------
The new version produces this:
---------------------
   [FIPS-198]
              US National Institute of Standards & Technology, , "The
              Keyed-Hash Message Authentication Code (HMAC)", FIPS PUB
              198 , March 2002.
---------------------

4. A referenced I-D document name isn't on a single line any more:
---------------------
<?rfc include="reference.I-D.sheffer-running-code"?>
---------------------
The old version produces this:
---------------------
   [I-D.sheffer-running-code]
              Sheffer, Y. and A. Farrel, "Improving Awareness of Running
              Code: the Implementation Status Section",
              draft-sheffer-running-code-02 (work in progress),
              January 2013.
---------------------
The new version produces this:
---------------------
   [I-D.sheffer-running-code]
              Sheffer, Y. and A. Farrel, "Improving Awareness of Running
              Code: the Implementation Status Section", draft-sheffer-
              running-code-02 (work in progress), January 2013.
---------------------

Thank you.

-- 
    Denis Ovsienko

---

From: Alice Russo <[email-masked]>
Date: Mon, 11 Mar 2013 09:41:51 -0400

Regarding 3, in order to create a reference where the author is an organization, give only the organization element. For example, change

> 						<organization>Unknown</organization>

to

<author>
  <organization>
    US National Institute of Standards &amp; Technology
  </organization>
</author>

Thank you.
RFC Editor/ar

On Mar 11, 2013, at 4:54 AM, Denis Ovsienko wrote:

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Tony Hansen <[email-masked]>
Date: Mon, 11 Mar 2013 09:53:34 -0400

> I use the xml2rfc tool, namely, its web frontend at xml.resource.org. The frontend was recently switched to the beta version of xml2rfc and this new switch brings a few issues that I cannot report…
See this page to get a login on all tools.ietf.org domains: 
http://trac.tools.ietf.org/tools/loginmgr/newlogin

     Tony Hansen

---

From: Denis Ovsienko <[email-masked]>
Date: Mon, 11 Mar 2013 18:18:34 +0400

>     US National Institute of Standards &amp; Technology

Thanks, it works for both the old and the new versions. The login manager page worked this time (it didn't before), should I file the remaining issues to Trac?

-- 
    Denis Ovsienko