Subject: [xml2rfc] Mysterious inability to convey a file to XML2RFC

From: Tom Taylor <[email-masked]>
Date: Mon, 11 Mar 2013 14:33:55 -0400

I am trying to compile a document by submitting to xml.resource.org, but I
keep getting the error: input file is gone", and a zero-byte text file is
returned. I've tried from different networks, I've tried recopying the
preamble from the template, I've had someone else submit the file -- always
with the same result. It must be this particular file, since others compile
readily.

I'm wondering if it's the sheer number of references that did it, or the
fact that I added a fairly recent reference, RFC6788. The opening tracking
information from XML2RFC lists the following file actions:

Generating Text output in ASCII format Expanding internal references and
generating txt
------------------------------

Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5
Parsing file INPUT
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml
Loaded from cache reference.RFC.2119.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2491.xml
Loaded from cache reference.RFC.2491.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2629.xml
Loaded from cache reference.RFC.2629.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.3376.xml
Loaded from cache reference.RFC.3376.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.3810.xml
Loaded from cache reference.RFC.3810.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4213.xml
Loaded from cache reference.RFC.4213.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4286.xml
Loaded from cache reference.RFC.4286.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4541.xml
Loaded from cache reference.RFC.4541.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4601.xml
Loaded from cache reference.RFC.4601.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4605.xml
Loaded from cache reference.RFC.4605.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.5569.xml
Loaded from cache reference.RFC.5569.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.5969.xml
Loaded from cache reference.RFC.5969.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.6052.xml
Loaded from cache reference.RFC.6052.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.6145.xml
Loaded from cache reference.RFC.6145.xml
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml
Loaded from cache reference.RFC.2119.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2491.xml
Loaded from cache reference.RFC.2491.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2629.xml
Loaded from cache reference.RFC.2629.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.3376.xml
Loaded from cache reference.RFC.3376.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.3810.xml
Loaded from cache reference.RFC.3810.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4213.xml
Loaded from cache reference.RFC.4213.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4286.xml
Loaded from cache reference.RFC.4286.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4541.xml
Loaded from cache reference.RFC.4541.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4601.xml
Loaded from cache reference.RFC.4601.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.4605.xml
Loaded from cache reference.RFC.4605.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.5569.xml
Loaded from cache reference.RFC.5569.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.5969.xml
Loaded from cache reference.RFC.5969.xml
Resolving entity... http://xml.resource.org/publiERROR: Unable to
validate the XML document: INPUT
 INPUT: Line 603: IDREF attribute target references an unknown ID
"I-D.ietf-6man-lineid"
 INPUT: Line 238: IDREF attribute target references an unknown ID
"I-D.ietf-softwire-dslite-multicast"
 INPUT: Line 479: IDREF attribute target references an unknown ID
"I-D.ietf-softwire-dslite-multicast"
c/rfc/bibxml/reference.RFC.6052.xml
Loaded from cache reference.RFC.6052.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.6145.xml
Loaded from cache reference.RFC.6145.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.3171.xml
Loaded from cache reference.RFC.3171.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.6788.xml
Loaded from cache reference.RFC.6788.xml

------------------------------
Then I get the error:
File is gone -- did you click reload?
------------------------------
Apache/2.2.21 (Debian) Server at xml.resource.org Port 80

---

From: Tony Hansen <[email-masked]>
Date: Mon, 11 Mar 2013 16:17:45 -0400

In the below, I do spot these error messages:

Resolving entity...http://xml.resource.org/publiERROR: Unable to validate the XML document: INPUT
  INPUT: Line 603: IDREF attribute target references an unknown ID "I-D.ietf-6man-lineid"
  INPUT: Line 238: IDREF attribute target references an unknown ID "I-D.ietf-softwire-dslite-multicast"
  INPUT: Line 479: IDREF attribute target references an unknown ID "I-D.ietf-softwire-dslite-multicast"

	Tony Hansen

On 3/11/2013 2:33 PM, Tom Taylor wrote:
> I am trying to compile a document by submitting to xml.resource.org 
> <http://xml.resource.org>, but I keep getting the error: input file is 
> gone", and a zero-byte text file is returned. I've tried from 
> different networks, I've tried recopying the preamble from the 
> template, I've had someone else submit the file -- always with the 
> same result. It must be this particular file, since others compile 
> readily.
>
> I'm wondering if it's the sheer number of references that did it, or 
> the fact that I added a fairly recent reference, RFC6788. The opening 
> tracking information from XML2RFC lists the following file actions:
>
>
>   Generating Text output in ASCII format
>
>
>     Expanding internal references and generating txt
>
> ------------------------------------------------------------------------
> Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5  <http://tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5>
> Parsing file INPUT
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.2491.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.2629.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.3376.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.3810.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4213.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4286.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4541.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4601.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4605.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.5569.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.5969.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.6052.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.6145.xml
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.2491.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.2629.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.3376.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.3810.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4213.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4286.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4541.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4601.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.4605.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.5569.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.5969.xml
> Resolving entity...http://xml.resource.org/publiERROR: Unable to validate the XML document: INPUT
>   INPUT: Line 603: IDREF attribute target references an unknown ID "I-D.ietf-6man-lineid"
>   INPUT: Line 238: IDREF attribute target references an unknown ID "I-D.ietf-softwire-dslite-multicast"
>   INPUT: Line 479: IDREF attribute target references an unknown ID "I-D.ietf-softwire-dslite-multicast"
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.6145.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.3171.xml
> Resolving entity...http://xml.resource.org/public/rfc/bibxml/reference.RFC.6788.xml
> ------------------------------------------------------------------------
> Then I get the error:
>
>
> ------------------------------------------------------------------------
> Apache/2.2.21 (Debian) Server at xml.resource.org 
> <http://xml.resource.org> Port 80
>
>
>
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Tony Hansen <[email-masked]>
Date: Mon, 11 Mar 2013 16:55:17 -0400

I've changed this particular error message to now say "The file is not 
there -- check for error messages or you may have clicked reload".

The error messages mentioned below were the reason Tom got his error 
message.

     Tony

On 3/11/2013 4:17 PM, Tony Hansen wrote:
>> <http://xml.resource.org>, but I keep getting the error: input file 
>> is gone", and a zero-byte text file is returned. I've tried from