Subject: Re: [xml2rfc] #136: <?rfc include> leaves in the include statements

From: Tony Hansen <[email-masked]>
Date: Wed, 13 Mar 2013 18:47:35 -0400

This is a question for the xml2rfc list: Should the updates that the 
trac issue tracker system generates be posted to this list automatically?

     Tony Hansen

On 3/13/2013 4:41 PM, xml2rfc issue tracker wrote:
> #136: <?rfc include> leaves in the include statements
>
>   For example, I have the following in my xml input:
>   <?rfc include=’reference.RFC.2634’ ?>
>
>   After expansion, the include statement is left in prior to what it expands
>   to.
>
>   The include statement should be removed and replaced by what it expands
>   into.
>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 24 Mar 2013 14:41:04 -0000

Changes (by [email-masked]):

 * priority:  medium => critical

-- 
----------------------------+----------------------------------
  Reporter:  [email-masked]   |      Owner:  [email-masked]
      Type:  defect         |     Status:  new
  Priority:  critical       |  Milestone:
 Component:  Version 2 cli  |    Version:  2.3.10
Resolution:                 |   Keywords:
----------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/136#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 24 Mar 2013 15:17:51 -0000

Comment (by [email-masked]):

 From [828]:

 Modified test case to show the problem with <?rfc include ?> statements
 which arn't stripped out when processed; see issue #136.

Ticket URL: </ticket/136#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 24 Mar 2013 15:52:18 -0000

* status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [830]:

 Changed handling of include PIs to replace the PI instead of just
 appending the included tree.  Updated a test file to match updated test
 case.  Fixes issue #136.

-- 
----------------------------+----------------------------------
  Reporter:  [email-masked]   |      Owner:  [email-masked]
      Type:  defect         |     Status:  closed
  Priority:  critical       |  Milestone:
 Component:  Version 2 cli  |    Version:  2.3.10
Resolution:  fixed          |   Keywords:
----------------------------+----------------------------------

Ticket URL: </ticket/136#comment:3>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>