Subject: Re: [xml2rfc] #115: xml2rfc 2.4.1 v2 puts two spaces after "i.e."

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 18 Mar 2013 14:06:11 -0000

#115: xml2rfc 2.4.1 v2 puts two spaces after "i.e."

Comment (by [email-masked]):

 The same applies for "Dr." and "Mr." -- essentially, it would be nice if
 v2 had special handling (a single space after a period) for the same cases
 that v1 did.

-- 
---------------------------------+-----------------
  Reporter:  [email-masked]  |      Owner:
      Type:  defect              |     Status:  new
  Priority:  medium              |  Milestone:
 Component:  Version 2 cli       |    Version:
Resolution:                      |   Keywords:
---------------------------------+-----------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/115#comment:3>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 18 Mar 2013 14:22:47 -0000

Comment (by [email-masked]):

 This is the v1 regex code (xml2rfc/version1/xml2rfc.tcl, r791 line 10847):

 {{{
         # Check for likely abbreviation.  Do not insert two spaces in
         # this case.
         # "e.g." and "i.e." are never directly followed by spaces.
         # "etc. " and "et al. " will often be the end of the sentence
 anyway.
         if {[regexp -expanded -- {(^|[^A-Za-z\xA0-])
                                   (  [A-Z]\.[])'"]*
                                    | (  [A-Z][a-z][a-z]
                                       | Fig | Tbl | Eq
                                       | [Cc]f | vs | resp
                                       | [JS]r | M[rs] | Messrs | Mrs |
 Mmes
                                       | Drs? | Profs?
                                       | Rep | Sen | Gov
                                       | St | Rev
                                       | Gen | Col | Maj | Cap | Lt)
                                      \.)
                                   \ $} $pre]} {
             continue
         }
 }}}

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/115#comment:4>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: Joe Abley <[email-masked]>
Date: Mon, 18 Mar 2013 10:43:19 -0400

Dr and Mr shouldn't have trailing periods anyway. They are
contractions, not abbreviations.

Aue Te Ariki! He toki ki roto taku mahuna!

On 2013-03-18, at 10:06, xml2rfc issue tracker <[email-masked]> wrote:

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 18 Mar 2013 08:02:30 -0700

> contractions, not abbreviations.

This mailing list is for the xml2rfc program, not the RFC Style Guide. To discuss the editorial style of RFCs, please send mail to [email-masked]. Seriously. Suggesting that a formatting tool enforce written style is a common but really dangerous layer violation.

--Paul Hoffman

---

From: Joe Abley <[email-masked]>
Date: Mon, 18 Mar 2013 11:07:01 -0400

> This mailing list is for the xml2rfc program, not the RFC Style Guide. To discuss the editorial style of RFCs, please send mail to [email-masked]. Seriously. Suggesting that a formatting tool enfor…

This was a response to a bug report and a proposed patch to xml2rfc (circulated on this list) that enshrines a grammatical error in code. This mailing list seems entirely apropos for such a comment.

Joe

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 18 Mar 2013 08:43:17 -0700

> This was a response to a bug report and a proposed patch to xml2rfc (circulated on this list) that enshrines a grammatical error in code. This mailing list seems entirely apropos for such a comment.

We fully disagree. If the RFC Style Guide says that "Dr" and "Mr" (and "Ms") are followed by a period, then the tool should not remove the period.

--Paul Hoffman

---

From: Joe Abley <[email-masked]>
Date: Mon, 18 Mar 2013 12:25:53 -0400

> We fully disagree. If the RFC Style Guide says that "Dr" and "Mr" (and "Ms") are followed by a period, then the tool should not remove the period.

Nobody is suggesting that the tool should remove the period. The suggestion is that the number of spaces following an incorrect "Dr." should be adjusted by the tool. My counter-suggestion is that the tool need not make allowances for incorrect grammar.

If the style guide insisted upon the incorrect forms "Mr." and "Dr." then I agree, my argument would be with the style guide. But the style guide is silent on this topic, which seems sensible (if the style guide made comments on every possible grammatical error, it would be very long and useless).

Joe

---

From: Glen Zorn <[email-masked]>
Date: Mon, 25 Mar 2013 10:37:01 +0700

On 03/18/2013 11:25 PM, Joe Abley wrote:

 >> We fully disagree. If the RFC Style Guide says that "Dr" and "Mr"
 >> (and "Ms") are followed by a period, then the tool should not
 >> remove the period.
 >
 > Nobody is suggesting that the tool should remove the period. The
 > suggestion is that the number of spaces following an incorrect "Dr."
 > should be adjusted by the tool. My counter-suggestion is that the
 > tool need not make allowances for incorrect grammar.

AFAICT, it is not incorrect, merely one of many differences between 
British  & American English usage.  I'm pretty sure that both I-Ds & 
RFCs are specified to be written in American English, so that would make 
the use of "Dr" inconsistent.

...

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 30 Mar 2013 06:51:45 -0000

Comment (by [email-masked]):

 "viz." would be a similar case.

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/115#comment:5>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: Nico Williams <[email-masked]>
Date: Sat, 30 Mar 2013 15:50:05 -0500

The simpler thing to do would be to require the author to insert the extra
space (or other sentence end maker) then have xml2rfc remove it as
necessary.

Nico
--

---

From: Denis Ovsienko <[email-masked]>
Date: Sun, 31 Mar 2013 10:55:16 +0400

31.03.2013, 00:50, "Nico Williams" <[email-masked]>:
> The simpler thing to do would be to require the author to insert the extra space (or other sentence end maker) then have xml2rfc remove it as necessary.
>

The additional explicit markup, if any, ought to stand for the case that is less common, such as &nbsp; and &wj; stand for supposedly rare exceptions and plain text stands for the implicit processing methods.

-- 
 Denis Ovsienko