Subject: [xml2rfc] #150: odd placement of .bps causing mid-line page breaks

From: "xml2rfc issue tracker" <[email-masked]>
Date: Fri, 22 Mar 2013 13:57:02 -0000

#150: odd placement of .bps causing mid-line page breaks

 v2 puts .bp where it causes a mid-line page break.
 (v1 puts a .bp only where between lines of the output.)

 Example: files from #118.

 v2 nroff output:
 {{{
 1577    .in 6
 1578    The TCP Urgent pointer, like the TCP window, is a 16 bit value.
 Some
 1579    .bp
 1580    of the original discussion for the TCP Window Scale option
 included
 1581    proposals to increase the Urgent pointer to 32 bits.  As it turns
 1582    out, this is unnecessary.  There are two observations that should
 be
 1583    made:
 }}}

 which yields text:
 {{{
 The TCP Urgent pointer, like the TCP window, is a 16 bit value.
 Some

 [page break]

 of the original discussion for the TCP Window Scale option
 included proposals to increase the Urgent pointer to 32 bits. As
 it turns out, this is unnecessary. There are two observations
 that should be made:
 }}}

 v1 nroff output:
 {{{
 .in 6
 .ti 6
 The TCP Urgent pointer, like the TCP window, is a 16 bit value.
 Some of the original discussion for the TCP Window Scale option
 included proposals to increase the Urgent pointer to 32 bits.  As
 it turns out, this is unnecessary.  There are two observations
 .bp
 that should be made:
 }}}

 Side note: in v1, the line breaks in the nroff output match those in the
 text output, which isn't necessary for the nroff to be correct, but is
 useful when working with the nroff output.

-- 
---------------------------------+----------------------------------
 Reporter:  [email-masked]      |      Owner:  [email-masked]
     Type:  defect               |     Status:  new
 Priority:  medium               |  Milestone:
Component:  Version 2 cli nroff  |    Version:  2.4.x
 Keywords:                       |
---------------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/150>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 31 Mar 2013 23:17:11 -0000

Comment (by [email-masked]):

 From [842]:

 Updated tests, see issue #150.

-- 
----------------------------------+----------------------------------
Resolution:                       |   Keywords:
----------------------------------+----------------------------------

Ticket URL: </ticket/150#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 31 Mar 2013 23:19:24 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [843]:

 Changed wrapping of nroff output to match text output closely, in order to
 minimize insertion of .bp in the middle of a line.  Fixes issue #150
 (mostly -- line breaks on hyphens may cause this to happen in very rare
 cases).

-- 
----------------------------------+----------------------------------
  Reporter:  [email-masked]      |      Owner:  [email-masked]
      Type:  defect               |     Status:  closed
  Priority:  medium               |  Milestone:
 Component:  Version 2 cli nroff  |    Version:  2.4.x
Resolution:  fixed                |   Keywords:
----------------------------------+----------------------------------

Ticket URL: </ticket/150#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>