Subject: [xml2rfc] Nit in 2.4.0 - date and expires

From: Erik Nordmark <[email-masked]>
Date: Wed, 13 Mar 2013 18:31:14 -0400

I just tried the web form xml2rfc 2.4.0 on an existing document, and I 
ended up with "Expires" lines without a date.

My document had
<date month="March" year="2013"/>
that makes xml2rfc 1.3.6 generate "Expires September 2, 2013", but 2.4.0 
generates "Expires".

Once I changed my document to
<date month="March" year="2013" day="13"/>
xml2rfc 2.4.0 generates expire text with a date.

   Erik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 13 Mar 2013 19:11:12 -0400

Hi Erik,

> xml2rfc 2.4.0 generates expire text with a date.

I believe I found this while working on 2.4.1, and fixed it there.  Could
you try your original unfixed document with 2.4.1?  (I've already tested
another document with your original <date/> element on 2.4.1, and it works
for me.)

Best regards,

	Henrik

---

From: Nico Williams <[email-masked]>
Date: Wed, 13 Mar 2013 18:25:49 -0500

I'd like <date> to be optional.  If absent -> use today's date.  The
XML made available on the IETF site would have to have a proper <date>
added, which could easily be done with an XSL (or, sure, us authors
could use an XSL to create an intermediate XML form for final
formatting and submission).

Basically, make life easy[ier] for authors, eh?  :)

Nico
--

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 13 Mar 2013 19:34:08 -0400

> another document with your original <date/> element on 2.4.1, and it works

Henrik,

I just tried the form at http://xml.resource.org/ with my original date 
element, and it works now.
(FWIW http://xml.resource.org/cgi-bin/xml2rfc-version still says 2.4.0, 
but the behavior has changed.)

Thanks,
    Erik

---

From: Tony Hansen <[email-masked]>
Date: Wed, 13 Mar 2013 19:43:47 -0400

Very odd. xml.resource.org has *not* been upgraded to 2.4.1 yet.

     Tony

On 3/13/2013 7:34 PM, Erik Nordmark wrote:
> I just tried the form at http://xml.resource.org/ with my original 
> date element, and it works now.
> (FWIW http://xml.resource.org/cgi-bin/xml2rfc-version still says 
> 2.4.0, but the behavior has changed.)

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 13 Mar 2013 19:47:47 -0400

Le 2013-03-13 à 19:25, Nico Williams <[email-masked]> a écrit :

> I'd like <date> to be optional.  If absent -> use today's date.  

+1. Marc.

> The
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 13 Mar 2013 19:56:28 -0400

> Very odd. xml.resource.org has *not* been upgraded to 2.4.1 yet.

Mean culpa - I was using my memory to revert the change instead of the 
actual old version.

Turns out the issue with 2.4.0 is with
<date month="Mar" year="2013"/>

2.4.0 works for

Where can I get 2.4.1?

    Erik

---

From: Tony Hansen <[email-masked]>
Date: Wed, 13 Mar 2013 20:05:37 -0400

Well, <date/> is not optional, but the attributes in it *are* optional, 
and have been for quite some time.

That is, you can use

     <date/>

just fine and xml2rfc will do *the right thing*. (TM)

     Tony

---

From: Nico Williams <[email-masked]>
Date: Wed, 13 Mar 2013 19:10:03 -0500

On Wed, Mar 13, 2013 at 7:05 PM, Tony Hansen <[email-masked]> wrote:
> Well, <date/> is not optional, but the attributes in it *are* optional, and
> have been for quite some time.
>
> That is, you can use
>
>     <date/>
>

Ah, OK.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Mar 2013 09:23:45 +0100

On 2013-03-14 00:56, Erik Nordmark wrote:
> ...

That's invalid and is not supposed to work.

Best regards, Julian

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 14 Mar 2013 11:03:46 -0400

> That's invalid and is not supposed to work.

FWIW it works with the old xml2rfc version.

If it is invalid it would be good in 2.4 could be made to generate an error.

    Erik

---

From: Bill Fenner <[email-masked]>
Date: Thu, 14 Mar 2013 12:30:47 -0400

> If it is invalid it would be good in 2.4 could be made to generate an error.

Out of curiosity, what does
http://www.fenron.com/~fenner/ietf/xml2rfc-valid/ say about it?

(Ignore the out-of-date ipr warnings.)

Thanks,
  Bill

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 14 Mar 2013 12:39:07 -0400

> (Ignore the out-of-date ipr warnings.)

Nothing (but those ipr warnings).

    Erik

Validation results for draft-ietf-6man-impatient-nud-06.xml

Processing...

     Validating document...
     Validation succeeded
     Performing additional checks...
         24: error: 3978-style IPR is required beginning 6 May 2005 (you 
are using trust200902)

           23:
           24: <rfc category="std" ipr="trust200902" 
docName="draft-ietf-6man-impatient-nud-06.txt" updates="4861">
           25: 	

     ...done

---

From: Julian Reschke <[email-masked]>
Date: Thu, 14 Mar 2013 17:42:14 +0100

> Nothing (but those ipr warnings).

Ack; I thought the set of valid month names was hardwired into the DTD, 
but apparently this is not the case.

That being said: RFC 2629 just gives an example ("February"), and is 
silent otherwise. IMHO we should stick with a single, interoperable 
format, and not try to "understand" more than that.

What the TCL code understands apparently is a side effect of a TCL date 
parse function, and that shouldn't affect the vocabulary...

Best regards, Julian