Subject: Re: [xml2rfc] #115: xml2rfc 2.4.1 v2 puts two spaces after "i.e."

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 06 May 2013 16:51:40 -0000

#115: xml2rfc 2.4.1 v2 puts two spaces after "i.e."

Comment (by [email-masked]):

 Another case: an initial followed by a period. v1 outputs 1 space after
 "W.", whereas v2 outputs 2 spaces.

 Example: Thanks to Bernie Volz, David W. Hankins, Pavan Kurapati, and Ted
 Lemon
 for providing valuable suggestions.

-- 
---------------------------------+-----------------
  Reporter:  [email-masked]  |      Owner:
      Type:  defect              |     Status:  new
  Priority:  major               |  Milestone:
 Component:  Version 2 cli       |    Version:
Resolution:                      |   Keywords:
---------------------------------+-----------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/115#comment:9>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 25 May 2013 22:14:33 -0000

Comment (by [email-masked]):

 From [875]:

 Updated tests, see issue #115

Ticket URL: </ticket/115#comment:10>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 25 May 2013 22:17:44 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [876]:

 Added special cases to avoid adding double spaces after many common
 abbreviations.  This fixes issue #115, but the code isn't quite as refined
 as v1, as it doesn't yet check that what follows actually looks like the
 start of a new sentence.  To be continued.

-- 
---------------------------------+--------------------
  Reporter:  [email-masked]  |      Owner:
      Type:  defect              |     Status:  closed
  Priority:  major               |  Milestone:
 Component:  Version 2 cli       |    Version:
Resolution:  fixed               |   Keywords:
---------------------------------+--------------------

Ticket URL: </ticket/115#comment:11>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 26 May 2013 07:54:48 -0000

From [881]:

Ticket URL: </ticket/115#comment:12>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 26 May 2013 07:55:55 -0000

From [882]:

 Refined the sentence-end double-space fixup further, to look at whether
 what follows looks like the start of a new sentence.  Related to issue
 #115.

Ticket URL: </ticket/115#comment:13>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>