Subject: Re: [xml2rfc] #174: after texttable, there are extraneous blank lines

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 02 Jun 2013 02:11:09 -0000

#174: after texttable, there are extraneous blank lines

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [904]:

 Changed the generation of tables and figures to produce less gratuitous
 vertical whitespace: Don't emit blank table header lines for empty tables,
 and don't emit blank title lines for tables without titles.  Fixes issue
 #174.

-- 
------------------------------+----------------------------------
  Reporter:  [email-masked]  |      Owner:  [email-masked]
      Type:  defect           |     Status:  closed
  Priority:  minor            |  Milestone:
 Component:  Version 2 cli    |    Version:  2.4.x
Resolution:  fixed            |   Keywords:
------------------------------+----------------------------------

Ticket URL: </ticket/174#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 03 Jun 2013 17:25:17 -0000

Comment (by [email-masked]):

 From [905]:

 Updated tests, see issue #174

Ticket URL: </ticket/174#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 4 Jun 2013 09:07:26 +0000

FYI:

See the second figure in the attached. In the source, I stated "<?rfc needLines="25"?>, and gave it a 24 line (including the title line) graphic. It broke the graphic over a page boundary. What I had hoped for was that it would either flow text before or after in such a way that the text still filled the page, but the graphic was entirely at the bottom of some page or the top of the next. What I expected at minimum was a page break (leaving less than 25 blank lines at the bottom of a page) forcing the graphic to the top of the next page.