Subject: [xml2rfc] Using xml2rfc without manual intervention, web-based ?

From: Toerless Eckert <[email-masked]>
Date: Tue, 11 Jun 2013 08:48:00 -0700

Hi Folks

Is there a way to call the xml2rfc conversion through a URL ? Eg: my
problem is that we're dealing with some drafts in progress, and i
want to have a web-page where i can click on a link that
will automatically deliver me a converted version.

Eg: i have some XML draft on something like:

http://somedomain.com/git/drafts/mydraft.xml

And i want to build a web/wiki page where i can click on a link that
would deliver me a text or html version of the document, so i was hoping i could
construct some URL like:

http://xml.resource.org/cgi-bin/xml2rfc.cgi?fomat=html&source=http://somedomain.com/svn/rfc/mydraft.xml

or

http://myinstall-xml2rfc.mydomain.org/cgi-bin/xml2rfc.cgi?fomat=html&source=http://somedomain.com/svn/rfc/mydraft.xml

Does this work ? I was looking through the xml.resource.org pages but couldn't
find a description. Instead, the upload/conversion seem to just work
with manual interaction. Hope i was just overlooking it.

Thanks!
    Toerless

---

From: Tony Hansen <[email-masked]>
Date: Tue, 11 Jun 2013 12:03:10 -0400

I know of other people who are using it that way. You can provide the
XML via file upload into the "input" argument, or use the url argument
to pull it in from a remote link. There are other needed options to
specify how to process the input. Should work just fine if you format
the input properly (multipart/form-data).

    Tony Hansen

On 6/11/2013 11:48 AM, Toerless Eckert wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc