Subject: [xml2rfc] #189: Spurious dot/point(.) characters in front of author names on page 1

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 15 Jul 2013 16:30:37 -0000

#189: Spurious dot/point(.) characters in front of author names on page 1

 The (online) tool is inserting a dot character followed by a space before
 each author's name in the header of page 1.  Thus:
 Network Working Group                                     . Quintin Zhao
                                                           ^^
 Octal dump of start of output:
 0000000  \n  \n  \n  \n   N   e   t   w   o   r   k       W   o   r   k
 0000020   i   n   g       G   r   o   u   p
 0000040
 0000060                                                           .
 0000100   Q   u   i   n   t   i   n       Z   h   a   o  \n

 This doesn't happen on the old tool:
 Network Working Group                                       Quintin Zhao

 Source file and output files [(2) from new tool, (3) from old] attached:

-- 
-----------------------------------+----------------------------------
 Reporter:  [email-masked]  |      Owner:  [email-masked]
     Type:  defect                 |     Status:  new
 Priority:  medium                 |  Milestone:
Component:  Version 2 cli          |    Version:  2.4.x
 Keywords:                         |
-----------------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/189>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 15 Jul 2013 17:00:51 -0000

Changes (by [email-masked]):

 * priority:  medium => minor

Comment:

 Hmm.  Interesting.  This seems to be the result of providing an author
 surname attribute
 without providing an initials attribute.  It shouldn't behave quite like
 this, of course,
 but I can see how it hasn't been caught by the current test suite.  The
 workaround is
 to let the surname attribute be the surname, rather than the full name,
 and provide the initials attribute:
 {{{
     <author fullname="Quintin Zhao" initials="Q." surname="Zhao">
       <organization>Huawei Technology</organization>
       <address>
         <postal>
           <street>125 Nagog Technology Park</street>
           <city>Acton</city>
           <region>MA</region>
           <code>01719</code>
           <country>US</country>
         </postal>
         <email>[email-masked]</email>
       </address>
     </author>
     <author fullname="Tao Chou" initials="T." surname="Chou">
       <organization>Huawei Technology</organization>
       <address>
         <postal>
           <street>156 Beiqing Rd</street>
           <city>Haidian District</city>
           <region>Beijing</region>
           <code>100095</code>
           <country>China</country>
         </postal>
         <email>[email-masked]</email>
       </address>
     </author>
     <author fullname="Boris Zhang" initials="B." surname="Zhang">
       <organization>Telus Communications</organization>
       <address>
         <postal>
           <street>200 Consilium Pl Floor 15</street>
           <city>Toronto, ON M1H 3J3</city>
           <country>Canada</country>
         </postal>
         <phone></phone>
         <email>[email-masked]</email>
       </address>
     </author>
     <author fullname="Emily Chen" initials="E." surname="Chen">
       <organization></organization>
       <address>
         <postal>
           <street>2717 Seville Blvd, Apt 1205</street>
           <city>Clearwater</city>
           <region>FL</region>
           <code>33764</code>
           <country>US</country>
         </postal>
         <email>[email-masked]</email>
       </address>
     </author>
 }}}

-- 
------------------------------------+----------------------------------
  Reporter:  [email-masked]  |      Owner:  [email-masked]
      Type:  defect                 |     Status:  new
  Priority:  minor                  |  Milestone:
 Component:  Version 2 cli          |    Version:  2.4.x
Resolution:                         |   Keywords:
------------------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/189#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>