Subject: [xml2rfc] "The file is not there" error

From: Pete Resnick <[email-masked]>
Date: Tue, 20 Aug 2013 09:25:26 -0500

I'm getting the following error in plaintext mode on xml.resource.org. 
HTML mode works just fine. Can someone tell me what's going wrong?

pr

--------

Generating Text output in ASCII format

Expanding internal references and generating Text

Using 
XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5
Parsing file INPUT
Resolving entity... 
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
Resolving entity... 
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
Resolving entity... 
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Resolving entity... 
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2026.xml
Loaded from cache reference.RFC.2026.xml
Resolving entity... 
http://xml.resource.org/public/rfc/bibxml/reference.RFC.5000.xml
Loaded from cache reference.RFC.5000.xml
Resolving entity... 
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
Resolving entity... 
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
Resolving entity... 
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Resolving entity... 
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2026.xml
Loaded from cache reference.RFC.2026.xml
Resolving entity... 
http://xml.resource.org/public/rfc/bibxml/reference.RFC.5000.xml
Loaded from cache reference.RFC.5000.xml
Traceback (most recent call last):
   File "/usr/local/bin/xml2rfc", line 224, in <module>
     main()
   File "/usr/local/bin/xml2rfc", line 209, in main
     pagedwriter.write(filename)
   File 
"/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 
1088, in write
     self.post_rendering()
   File 
"/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/paginated_txt.py", 
line 286, in post_rendering
     self.emit([''] * remainder)
   File 
"/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/paginated_txt.py", 
line 164, in emit
     if self.page_length == 1 and text.strip() == '':
AttributeError: 'list' object has no attribute 'strip'

-----

The file is not there -- check for error messages or you may have 
clicked reload

Apache/2.2.21 (Debian) Server at xml.resource.org Port 80

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Alice Russo <[email-masked]>
Date: Tue, 20 Aug 2013 10:52:20 -0400

Hi Pete, 

This appears to be the same error that is at the end of Elwyn's ticket:
http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/187

Also, it was reported to this list by R. Raymond in June. 

Although I had commented on that ticket about a possible cause (regarding figures), when I ran into it again recently, the error was caused when I added a single sentence to one page, apparently causing a crash with the page-breaking. Maybe you could add your file to #187 and I will do the same.

Thanks,
Alice

On Aug 20, 2013, at 10:25 AM, Pete Resnick wrote:

> I'm getting the following error in plaintext mode on xml.resource.org. HTML mode works just fine. Can someone tell me what's going wrong?
> 
> pr
> 
> --------
> 
> Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5
> Parsing file INPUT
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
> Resolving entity... http://xml.resource.org/public/rfc/bibxml/reference.RFC.2026.xml
> Resolving entity... http://xml.resource.org/public/rfc/bibxml/reference.RFC.5000.xml
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
> Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
> Resolving entity... http://xml.resource.org/public/rfc/bibxml/reference.RFC.2026.xml
> Resolving entity... http://xml.resource.org/public/rfc/bibxml/reference.RFC.5000.xml
>  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 1088, in write
>    self.post_rendering()
>  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/paginated_txt.py", line 286, in post_rendering
>  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/paginated_txt.py", line 164, in emit
> The file is not there -- check for error messages or you may have clicked reload
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Tony Hansen <[email-masked]>
Date: Tue, 20 Aug 2013 11:22:10 -0400

Looks like the list processing in xml2rfc v2 has a difference between
when generating plain text versus html, where one path recognizes a
"strip" attribute and the other doesn't. A definite bug in xml2rfc v2.

    Tony