Subject: [xml2rfc] Two issues with new version

From: Brian E Carpenter <[email-masked]>
Date: Sun, 22 Sep 2013 17:37:03 +1200

I had a couple of issues with the "March 2013" version (using the
Web service at http://xml.resource.org/) while processing
draft-carpenter-prismatic-reflections-00.xml.

(The posted I-D was processed with http://xml.resource.org/old.html)

ISSUE 1:

In the main text, I included some <erefs> such as

<eref target="https://www.schneier.com/blog/archives/2013/09/the_nsa_is_brea.html"/>

Generating an HTML file, there's no problem: this simply
generates a link, as expected.

BUT, generating a TXT file, each <eref> appears as [1], [2] etc (despite
using symrefs) but there is no [1], [2] to cite. The old version of XML2RFC,
as expected, just plants the URL in the text.

ISSUE 2:

To work around Issue 1 in a hurry, I simply replaced the
various <eref>s by the bare URL. Again, with the new version
of XML2RFC, HTML output is fine.

BUT, generating a TXT file, the output file is blank, with no
error message.

On further checking today, this problem is quite bizarre. At
first sight it's caused by one specific URL, the one quoted above:

https://www.schneier.com/blog/archives/2013/09/the_nsa_is_brea.html

but in fact any URL at that point seems to generate the problem.

I can "fix" the problem by deleting about 45 characters from
later in the same <section>, so I think there is some sort
of buffer overflow involved - but no error messages, just
an empty output file.

I will supply the guilty XML file to anyone interested.

     Brian

Regards
   Brian Carpenter

---

From: Denis Ovsienko <[email-masked]>
Date: Sun, 22 Sep 2013 11:37:13 +0400

[...]
> as expected, just plants the URL in the text.
[...]

Hello.

For my own input (symrefs="yes" and two EREFs in the middle of a list item each) the _old_ xml2rfc produces "[1]" and "[2]", adding an "URIs" section just after the informative references. 

-- 
    Denis Ovsienko

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 23 Sep 2013 08:07:02 +1200

> For my own input (symrefs="yes" and two EREFs in the middle of a list item each) the _old_ xml2rfc produces "[1]" and "[2]", adding an "URIs" section just after the informative references. 

That is definitely not what I see.

    Brian

---

From: Denis Ovsienko <[email-masked]>
Date: Mon, 23 Sep 2013 09:20:30 +0400

> That is definitely not what I see.

Just checked once again, it works in the old version (the source is http://tools.ietf.org/id/draft-ovsienko-babel-hmac-authentication-03.xml). The new version doesn't generate the "URIs" section (known issue #133). I don't know if it depends on any processing directives.

-- 
    Denis Ovsienko