Subject: Re: [xml2rfc] xml2rfc barfs on 'target' that starts with a number

From: Alice Russo <[email-masked]>
Date: Tue, 22 Oct 2013 09:10:16 -0400

Randall,

For xml2rfc v2, this has been reported here:
http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/160

Re: the xml2rfc FAQ, it's about v1 (which allowed an initial number in an anchor); it has not been updated for v2.

Thanks,
Alice

On Oct 22, 2013, at 2:15 AM, Randall Gellens wrote:

> Hi,
> 
> In the XML2RFC FAQ section 3.7 (http://xml.resource.org/xml2rfcFAQ.html#anchor15) gives an example of how to make a reference to a URL, and specifically uses "<reference anchor="3GPP" ... "
> 
> As it happens, I needed to reference 3GPP, and I also used "<reference anchor="3GPP" ... " but kept getting syntax errors. After much frustration, I realized that the FAQ is wrong, and that XML2RFC barfs if target starts with a letter.  Changing it to "<reference anchor="SDO-3GPP" ... " make it compile.
> 
> -- 
> Randall Gellens
> Opinions are personal;    facts are suspect;    I speak for myself only
> -------------- Randomly selected tag: ---------------
> There's nothing wrong with me.  Maybe there's something wrong with
> the universe.       --'Dr. Beverly Crusher' in ST:TNG _Remember Me_.
>

---

From: Tony Hansen <[email-masked]>
Date: Tue, 22 Oct 2013 11:10:19 -0400

I updated the FAQ. Working on the actual reference files will take
longer. Sounds like a good project for me at the code sprint.

    Tony

---

From: Randall Gellens <[email-masked]>
Date: Mon, 21 Oct 2013 23:15:29 -0700

Hi,

In the XML2RFC FAQ section 3.7 
(http://xml.resource.org/xml2rfcFAQ.html#anchor15) gives an example 
of how to make a reference to a URL, and specifically uses 
"<reference anchor="3GPP" ... "

As it happens, I needed to reference 3GPP, and I also used 
"<reference anchor="3GPP" ... " but kept getting syntax errors. 
After much frustration, I realized that the FAQ is wrong, and that 
XML2RFC barfs if target starts with a letter.  Changing it to 
"<reference anchor="SDO-3GPP" ... " make it compile.