Subject: Re: [xml2rfc] [rfc-i] xml2rfc borked on Mavericks?

From: Paul Hoffman <[email-masked]>
Date: Fri, 25 Oct 2013 07:48:59 -0700

On Oct 24, 2013, at 9:37 PM, Tim Bray <[email-masked]> wrote:

> I can’t get the shiny new Python xml2rfc to run on Mavericks; if this is working for anyone else I’ll assume it is one of the Google customizations getting in my way.  I tried with a homebrew-installed python too; either way, it blows up on a missing XML library.

Broken here too:

Traceback (most recent call last):
 File "/usr/local/bin/xml2rfc", line 4, in <module>
   import pkg_resources
 File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2607, in <module>
   parse_requirements(__requires__), Environment()
 File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 565, in resolve
   raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: xml2rfc==2.4.0
xml2rfc returned 1

--Paul Hoffman

---

From: Joe Abley <[email-masked]>
Date: Fri, 25 Oct 2013 11:52:45 -0400

> pkg_resources.DistributionNotFound: xml2rfc==2.4.0

Works perfectly well for me, installed via a freshly-built macports on a clean Mavericks/Xcode install.

Happy to diff what I have against what you have, in case that helps someone.

Joe

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 25 Oct 2013 09:17:08 -0700

Thanks. It turns out that I had a version mismatch for xml2rfc, and that error message was supposed to indicate it. Now fixed with:
   sudo pip install --upgrade xml2rfc

--Paul Hoffman