Subject: Re: [xml2rfc] #200: &nbsp; in title element makes bad output in TOC

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 23 Nov 2013 06:13:21 -0000

#200: &nbsp; in title element makes bad output in TOC

Changes (by [email-masked]):

 * owner:  [email-masked] => [email-masked]

-- 
------------------------------+------------------------------------
  Reporter:  [email-masked]  |      Owner:  [email-masked]
      Type:  defect           |     Status:  new
  Priority:  minor            |  Milestone:
 Component:  Version 2 cli    |    Version:  2.4.x
Resolution:                   |   Keywords:
------------------------------+------------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/200#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Tue, 26 Nov 2013 14:21:34 -0000

Comment (by [email-masked]):

 Also encountered this in a <t> within a <list> as follows:

 XML
 {{{
 <t hangText="cn0:">The signal-to-noise ratio for the satellite
 signal, measured in decibel-Hertz (dB-Hz).  The expected range is between
 20
 and 50&nbsp;dB-Hz.</t>
 }}}

 v2 txt:
 {{{
  cn0:  The signal-to-noise ratio for the satellite signal, measured in
      decibel-Hertz (dB-Hz).  The expected range is between 20 and
      50&#160;dB-Hz.
 }}}

 v1 txt:
 {{{
    cn0:  The signal to noise ratio for the satellite signal, measured in
       decibel-Hertz (dB-Hz).  The expected range is between 20 and
       50 dB-Hz.
 }}}

 side note: using v2, changing the XML to "and 50&nbsp;dB&nbhy;Hz" resolves
 the issue.

 (This ticket is similar to #202)

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/200#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 26 Nov 2013 08:29:07 -0800

Having looked at this, it is my expectation that this bug currently appears anywhere where text can appear in at an attribute value.

> -----Original Message-----
> From: xml2rfc issue tracker [mailto:[email-masked]]
> Sent: Tuesday, November 26, 2013 6:22 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [xml2rfc] #200: &nbsp; in title element makes bad output in TOC
> 
>  <t hangText="cn0:">The signal-to-noise ratio for the satellite  signal, measured
> in decibel-Hertz (dB-Hz).  The expected range is between
>  20
>  and 50&nbsp;dB-Hz.</t>
>  }}}
> 
>  v2 txt:
>  {{{
> Ticket URL:
> <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/200#comment:2>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 30 Nov 2013 21:31:46 -0000

* status:  new => closed
 * resolution:   => fixed

Comment:

 fixed in 1052

 Fixed by using Unicode rather than entities as the basic thing we play
 with.

-- 
------------------------------+------------------------------------
  Reporter:  [email-masked]  |      Owner:  [email-masked]
      Type:  defect           |     Status:  closed
  Priority:  minor            |  Milestone:
 Component:  Version 2 cli    |    Version:  2.4.x
Resolution:  fixed            |   Keywords:
------------------------------+------------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/200#comment:3>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>