Subject: [xml2rfc] Options for width attribute in tables

From: "Jim Schaad" <[email-masked]>
Date: Wed, 6 Nov 2013 10:36:22 -0800

Going through the TCL code for table widths  I have found a couple of
options for the width attribute that I have never used, and which are not
documented.

The following are legal width attributes

*
15
15em
15%
15*

15 is ignored
15em says use 15 columns
15% says use a 15% of the available space for this column
15* says allocate 15 parts of all of the * tagged items
(Note that 1* and * are equivalent  This means that it allocates evenly the
left-over space between all columns with a * in the width marker.)

The current xml2rfc only deals with percentages and assumes that all of the
items are going to be tagged as percentages.  Do we have cases where the
other are used and do they need to be moved forward into v2?

Jim

---

From: Julian Reschke <[email-masked]>
Date: Wed, 06 Nov 2013 10:44:27 -0800

On 2013-11-06 10:36, Jim Schaad wrote:
> ...

Cool, thanks for researching.

rfc2629.xslt currently only supports percentages. I'll try to run 
statistics on the AUTH48 RFC archive I have to find out what's actually 
used.

Best regards, Julian

---

From: Alice Russo <[email-masked]>
Date: Wed, 6 Nov 2013 10:49:51 -0800

Jim,

I looked at how ttcol width has been used in the author-submitted XML files for all published RFCs. "em" and "*" were not used -- only "%", so it seems fine to only provide "%" in v2.

Thanks,
Alice

---

From: "Jim Schaad" <[email-masked]>
Date: Thu, 7 Nov 2013 11:04:56 -0800

After thinking about it, I would like to have the 'em' version kept.   This
should be documented.  I would have used this in preference to the '%'
option if I had known that it existed in a number of documents.

I am agnostic about keeping the '*' option.

Jim

> -----Original Message-----
> From: Alice Russo [mailto:[email-masked]]
> Sent: Wednesday, November 06, 2013 10:50 AM
> To: Jim Schaad
> Cc: Julian Reschke; Sandy Ginoza; RSE; xml2rfc list
> Subject: Re: Options for width attribute in tables
> 
> Jim,
> 
> I looked at how ttcol width has been used in the author-submitted XML
files
> for all published RFCs. "em" and "*" were not used -- only "%", so it
seems
> fine to only provide "%" in v2.
> 
> Thanks,
> Alice
> 
> > options for the width attribute that I have never used, and which are
> > not documented.
> >
> > 15* says allocate 15 parts of all of the * tagged items (Note that 1*
> > and * are equivalent  This means that it allocates evenly the
> > The current xml2rfc only deals with percentages and assumes that all
> > of the items are going to be tagged as percentages.  Do we have cases
> > where the other are used and do they need to be moved forward into v2?
> >
> > Jim
> >
> >

---

From: Tony Hansen <[email-masked]>
Date: Thu, 07 Nov 2013 14:21:03 -0500

+1 to keeping 'em'.

This falls in the two categories of v2 parity with v1, and making tables
as useful as they are in html.

Isn't '*' is pretty much equivalent to the default of "shift things
around to make them fit"?

    Tony

On 11/7/2013 2:04 PM, Jim Schaad wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc