Subject: [xml2rfc] xml2rfc Output Error

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 12 Nov 2013 12:08:28 +0000

I'm getting an unusual (to me) error when using the web version of xml2rfc found here:

http://xml.resource.org/index.html

The output format is "plaintext" and I've selected "Use frames to show Warnings & Errors". The output file isn't being written. Instead, I see this stack trace:

"Traceback (most recent call last):
  File "/usr/local/bin/xml2rfc", line 224, in <module>
    main()
  File "/usr/local/bin/xml2rfc", line 209, in main
    pagedwriter.write(filename)
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 1088, in write
    self.post_rendering()
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/paginated_txt.py", line 286, in post_rendering
    self.emit([''] * remainder)
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/paginated_txt.py", line 164, in emit
    if self.page_length == 1 and text.strip() == '':
AttributeError: 'list' object has no attribute 'strip'"

There's something in this <list> element that's causing the problem. When I remove the last <t> element (with hangText="-08:") the output is properly written:

<list style="hanging">
  <t hangText="Initial -00:">Adopted as working group document.</t>
  <t hangText="-01:">Added "Conventions Used in This Document" section. Added
  normative reference to draft-ietf-weirds-rdap-sec and some wrapping text in
  the Security Considerations section.</t>
  <t hangText="-02:">Removed "unified" from the title. Rewrote the last paragraph
  of section 2. Edited the first paragraph of section 3 to more clearly note
  that only one path segement is provided. Added "bitmask" to "length" in
  section 3.1. Changed "lowest IP network" to "smallest IP network" in section
  3.1. Added "asplain" to the description of autonomous system numbers in
  section 3.2. Minor change from "semantics is" to "semantics are" in section
  3.2. Changed the last sentence in section 4 to more clearly specify error
  response behavior. Added acknowledgements. Added a paragraph in the
  introduction regarding future IETF standards and extensibility.</t>
  <t hangText="-03:">Changed 'query' to 'lookup' in document title to better describe the 'exact match lookup' purpose of this document. Included a multitude of minor additions and clarifications provided by Marc Blanchet and Jean-Philippe Dionne. Modified the domain and name server sections to include support for IDN U-labels.</t>
  <t hangText="-04:">Updated the domain and name server sections to use .example IDN U-labels. Added text to note that mixed IDN labels SHOULD NOT be used. Fixed broken sentences in <xref target="i18n"/>.</t>
  <t hangText="-05:">Added "help" path segment.</t>
  <t hangText="-06:">Added search text and removed or edited old search text.</t>
  <t hangText="-07:">Fixed query parameter typo by replacing "/?" with "?". Changed "asplain" to "AS Plain". Added entity search by handle. Corrected section references. Updated IDN search text.</t>
  <t hangText="-08:">Revised URI formats. Revised search processing text. Synchronized examples with response draft.</t>
</list>

Is there an obvious error here that I'm missing?

Scott

---

From: Tony Hansen <[email-masked]>
Date: Wed, 13 Nov 2013 10:19:14 -0500

You've tripped over a bug that we actually have a fix for in the pipeline.

Henrik said that he hopes to get it pushed out this weekend.

     Tony Hansen

On 11/12/13, 7:08 AM, Hollenbeck, Scott wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 13 Nov 2013 16:21:17 +0000

Thanks, Tony. Trying to find a bug in my XML source was driving me nuts.

Scott

> On Nov 13, 2013, at 10:19 AM, "Tony Hansen" <[email-masked]> wrote:
>