Subject: [xml2rfc] Confusing error message

From: Choose Account <[email-masked]>
Date: Sun, 08 Dec 2013 13:49:29 +1300

Using the "March 2013" release...

ERROR: Unable to parse the XML document: INPUT
 INPUT: Line 182: Extra content at the end of the document

However, the actual problem was the presence of a
non-ASCII closing quote ’ in line 182.

Sorry if this is old news.

   Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 11 Dec 2013 12:26:11 +0100

Hi Brian,

> non-ASCII closing quote ’ in line 182.

This particular case will be handled somewhat better in version 2.4.4, which
I released yesterday.  It should say something like:

  WARNING: Illegal character replaced in string: &#146;

and then get on with parsing the document with the non-ascii character replaced
by the ascii string '&#146' .

Best regards,

	Henrik