Subject: Re: [xml2rfc] attribute overlap on figure and artwork

From: Julian Reschke <[email-masked]>
Date: Sun, 01 Dec 2013 15:06:19 +0100

I agree for align, but not for src/widht/height...

On 2013-12-01 01:23, Jim Schaad wrote:
> After looking at this, it is there for what I would consider to be a good
> reason.
>
> The align on the figure applies to the preamble, the artwork and the
> postamble.  The align on the artwork would apply JUST to the artwork.
>
> <figure align="right">
>     <preamble>Text from the preamble</preamble>
>     <artwork align="center">....</artwork>
>     <postamble>.....</postamble>
> </figure>
>
> Jim
>
>> -----Original Message-----
>> From: xml2rfc [mailto:[email-masked]] On Behalf Of Paul Hoffman
>> Sent: Wednesday, November 27, 2013 2:45 PM
>> To: Julian Reschke
>> Cc: xml2rfc
>> Subject: Re: [xml2rfc] attribute overlap on figure and artwork
>>
>> On Nov 27, 2013, at 2:22 PM, Julian Reschke <[email-masked]> wrote:
>>
>>> On 2013-11-27 22:16, Paul Hoffman wrote:
>>>> On Nov 27, 2013, at 9:58 AM, Julian Reschke <[email-masked]>
>> wrote:
>>>>
>>>>> Right now it's the only mechanism to include non line-art artwork, so
> I'll
>> leave *one* mechanism in, even when it's not very useful for RFC
> production
>> today (but don't forget RFC 5598...).
>>>>
>>>> If v2 is for today's drafts and RFCs, and it is not very useful for
> them, why
>> leave it in?
>>>
>>> It's there (in the DTD), it's implemented (two independent
> implementations),
>> and it's been used in practice.
>>
>> Ah, I didn't know that last bit. Good enough.
>>
>> --Paul Hoffman
>> _______________________________________________
>> xml2rfc mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/xml2rfc
>
>

---

From: "Jim Schaad" <[email-masked]>
Date: Sun, 1 Dec 2013 10:46:23 -0800

> From: Julian Reschke [mailto:[email-masked]]
> Sent: Sunday, December 01, 2013 6:06 AM
> To: Jim Schaad; 'Paul Hoffman'
> Cc: 'xml2rfc'

So you feel that for src/width/height - there is no benefit to specifying
these values to include the preamble/postambles and title strings.  It
should just be for the art work itself.

Jim

> > After looking at this, it is there for what I would consider to be a
> > good reason.
> >

---

From: Julian Reschke <[email-masked]>
Date: Sun, 01 Dec 2013 19:52:53 +0100

> should just be for the art work itself.

Exactly.

I think for v3 we'll need structures anyway, so let's try to keep the 
legacy stuff minimal...

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Tue, 17 Dec 2013 19:57:41 +0100

On 2013-12-01 15:06, Julian Reschke wrote:
> ...

FWIW, I just added tests for @align on figure, see 
<http://greenbytes.de/tech/webdav/rfc2629xslt/testcase.html#figure.artwork.attribute.overlap>.

Results:

1) rfc2629.xslt ignores it

2) xml2rfc.tcl applies it to preamble and postamble; it leaves the title 
centered, and does not override the default handling of artwork/@align.

I would argue that changing the alignment of preamble and postamble is 
really an edge case, and thus I'd propose to document this one as 
deprecated.

Best regards, Julian